Upvote Upvoted 300 Downvote Downvoted
1 ⋅⋅ 70 71 72 73 74 75 76 77
mastercomfig - fps/customization config
posted in Customization
2161
#2161
1 Frags +

Im trying to use prec 2.0.5 and I'm having trouble getting it to work. My lovely friend kevinispwn suggested I might have to install it abnormally as I am using mastercomfig.

install configurations i have tried:
1. tf/custom/prec/*prec cfg files*
2. tf/custom/*prec cfg files*
3. tf/custom/prec files as vpk
(i converted the files to vpk by using the vpk .exe in the bin folder but I am not sure if that is ideal for this)

Im trying to use prec 2.0.5 and I'm having trouble getting it to work. My lovely friend kevinispwn suggested I might have to install it abnormally as I am using mastercomfig.

install configurations i have tried:
1. tf/custom/prec/*prec cfg files*
2. tf/custom/*prec cfg files*
3. tf/custom/prec files as vpk
(i converted the files to vpk by using the vpk .exe in the bin folder but I am not sure if that is ideal for this)
2162
#2162
2 Frags +
capnnofapnIm trying to use prec 2.0.5 and I'm having trouble getting it to work. My lovely friend kevinispwn suggested I might have to install it abnormally as I am using mastercomfig.

install configurations i have tried:
1. tf/custom/prec/*prec cfg files*
2. tf/custom/*prec cfg files*
3. tf/custom/prec files as vpk
(i converted the files to vpk by using the vpk .exe in the bin folder but I am not sure if that is ideal for this)

tf/custom/prec/addons/prec.dll + prec.cfg

[quote=capnnofapn]Im trying to use prec 2.0.5 and I'm having trouble getting it to work. My lovely friend kevinispwn suggested I might have to install it abnormally as I am using mastercomfig.

install configurations i have tried:
1. tf/custom/prec/*prec cfg files*
2. tf/custom/*prec cfg files*
3. tf/custom/prec files as vpk
(i converted the files to vpk by using the vpk .exe in the bin folder but I am not sure if that is ideal for this)[/quote]
tf/custom/prec/addons/prec.dll + prec.cfg
2163
#2163
-3 Frags +

I'd like to know something: Why is mat_reducefillrate set to 1? Doesn't that reduce FPS (I know that FPS is not the only important performance metric)? I'm not necessarily questioning the settings, I'm just curious about this cvar, because its default is set to 0.

I'd like to know something: Why is mat_reducefillrate set to 1? Doesn't that reduce FPS (I know that FPS is not the only important performance metric)? I'm not necessarily questioning the settings, I'm just curious about this cvar, because its default is set to 0.
2164
#2164
2 Frags +

No, it controls shader quality. Reducing fillrate in this instance means reducing the required pixel fill cost.

No, it controls shader quality. Reducing fillrate in this instance means reducing the required pixel fill cost.
2165
#2165
-2 Frags +

Ok I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.

Ok I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.
2166
#2166
-2 Frags +

Also just a heads up, but I personally think you should display frametimes in the graph in the performance section on your site. I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.

Also just a heads up, but I personally think you should display frametimes [url=https://mastercomfig.com/]in the graph in the performance section on your site.[/url] I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.
2167
#2167
1 Frags +
AimIsADickOk I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.

It does use some DX8 shaders so it might negatively affect stuff on your machine.

AimIsADickAlso just a heads up, but I personally think you should display frametimes in the graph in the performance section on your site. I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.

frametime = 1/FPS
1/frametime = FPS

FPS is bad to measure as a relative thing, like "I just gained 30 frames!", instead of "I had 240FPS before and now I have 270FPS." That latter one is fine.

if you mean the frame pacing, that's harder to compare and measure between configs.

[quote=AimIsADick]Ok I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.[/quote]
It does use some DX8 shaders so it might negatively affect stuff on your machine.

[quote=AimIsADick]Also just a heads up, but I personally think you should display frametimes [url=https://mastercomfig.com/]in the graph in the performance section on your site.[/url] I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.[/quote]

frametime = 1/FPS
1/frametime = FPS

FPS is bad to measure as a relative thing, like "I just gained 30 frames!", instead of "I had 240FPS before and now I have 270FPS." That latter one is fine.

if you mean the frame pacing, that's harder to compare and measure between configs.
2168
#2168
-5 Frags +
mastercomsAimIsADickOk I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.It does use some DX8 shaders so it might negatively affect stuff on your machine.

Guess that might explain some weird stuff going on.

mastercomsAimIsADickAlso just a heads up, but I personally think you should display frametimes in the graph in the performance section on your site. I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.
frametime = 1/FPS
1/frametime = FPS

FPS is bad to measure as a relative thing, like "I just gained 30 frames!", instead of "I had 240FPS before and now I have 270FPS." That latter one is fine.

if you mean the frame pacing, that's harder to compare and measure between configs.

Sometimes though the frametime varies and is not always perceptible with just FPS, but I can see where you are coming from.

I guess I technically mean frame pacing and not frametime.

[quote=mastercoms][quote=AimIsADick]Ok I understand now. Guess I was just seeing a false correlation between the cvar and frames. Thanks again.[/quote]
It does use some DX8 shaders so it might negatively affect stuff on your machine.
[/quote]

Guess that might explain some weird stuff going on.

[quote=mastercoms][quote=AimIsADick]Also just a heads up, but I personally think you should display frametimes [url=https://mastercomfig.com/]in the graph in the performance section on your site.[/url] I heard that FPS is generally an unreliable metric, so I think it's a good idea to include frametime as a consistent metric as well.[/quote]

frametime = 1/FPS
1/frametime = FPS

FPS is bad to measure as a relative thing, like "I just gained 30 frames!", instead of "I had 240FPS before and now I have 270FPS." That latter one is fine.

if you mean the frame pacing, that's harder to compare and measure between configs.[/quote]

Sometimes though the frametime varies and is not always perceptible with just FPS, but I can see where you are coming from.

I guess I technically mean frame pacing and not frametime.
2169
#2169
-9 Frags +

Guys, the customization page doesn't work now, but don't worry, you can still customize your modules.cfg file using notepad!!!

Guys, the customization page doesn't work now, but don't worry, you can still customize your modules.cfg file using notepad!!!
2170
#2170
-4 Frags +

Fixed now, thank you mastercoms!

Fixed now, thank you mastercoms!
2171
#2171
-5 Frags +

So I noticed that you were talking about how dxlevel 81 is often misused and that you wished you mentioned it? Why not go ahead and talk about it in the misconceptions page?

Same goes for the -force_device_id and -force_vendor_id launch options, though they seem to be rarely used nowadays. I personally think it's a good idea to do so anyways in case they ever got common usage again.

[url=https://www.teamfortress.tv/post/1016536/mastercomfig-fps-customization-config]So I noticed that you were talking about how dxlevel 81 is often misused[/url] and that you wished you mentioned it? Why not go ahead and talk about it in the misconceptions page?

Same goes for the -force_device_id and -force_vendor_id launch options, though they seem to be rarely used nowadays. I personally think it's a good idea to do so anyways in case they ever got common usage again.
2172
#2172
7 Frags +

Using dxlevel 81 is not a misconception. It has a valid use case. Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.

Using dxlevel 81 is not a misconception. It has a valid use case. Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.
2173
#2173
-7 Frags +
mastercomsUsing dxlevel 81 is not a misconception. It has a valid use case. Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.

Yeah I get that but people seem to misuse dxlevel 81 a lot, so while I guess it technically doesn't count as a misconception, I still think what you said about dxlevel 81 earlier should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.

[quote=mastercoms]Using dxlevel 81 is not a misconception. It has a valid use case. Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.[/quote]

Yeah I get that but people seem to misuse dxlevel 81 a lot, so while I guess it technically doesn't count as a misconception, I still think [url=https://www.teamfortress.tv/post/1016536/mastercomfig-fps-customization-config]what you said about dxlevel 81 earlier[/url] should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.
2174
#2174
3 Frags +
AimIsADickI still think what you said about dxlevel 81 earlier should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.

The cool thing about mastercomfig is that you can go ahead and add it to the docs right now if you want. I'm sure it would be merged if you write a good description of it.

[quote=AimIsADick]I still think [url=https://www.teamfortress.tv/post/1016536/mastercomfig-fps-customization-config]what you said about dxlevel 81 earlier[/url] should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.[/quote]
The cool thing about mastercomfig is that you can go ahead and add it to the docs right now if you want. I'm sure it would be merged if you write a good description of it.
2175
#2175
0 Frags +
mastercomsSame with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.

I can say that forcing vendor IDs for me when I was using NVIDIA optimus in Windows 7 with a driver that wasn't from the OEM helped my FPS a bit and allowed the game render correctly. I dont have the exact numbers on hand, but it helped.

For some reason the game was recognizing my dGPU as the Intel integrated one with the driver direct from NVIDIA. This was the github issue report that helped me: https://github.com/ValveSoftware/Source-1-Games/issues/633

On Windows 10 I didnt have the same issues though. Also apparently helps on some linux systems, but I never tested that.

[quote=mastercoms]Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.[/quote]

I can say that forcing vendor IDs for me when I was using NVIDIA optimus in Windows 7 with a driver that wasn't from the OEM helped my FPS a bit and allowed the game render correctly. I dont have the exact numbers on hand, but it helped.

For some reason the game was recognizing my dGPU as the Intel integrated one with the driver direct from NVIDIA. This was the github issue report that helped me: https://github.com/ValveSoftware/Source-1-Games/issues/633

On Windows 10 I didnt have the same issues though. Also apparently helps on some linux systems, but I never tested that.
2176
#2176
-6 Frags +
turbochad69AimIsADickI still think what you said about dxlevel 81 earlier should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.The cool thing about mastercomfig is that you can go ahead and add it to the docs right now if you want. I'm sure it would be merged if you write a good description of it.

I am planning on contributing this information to the docs. I just have no idea how to explain the "misconception" (or rather misusage).

FakemastercomsSame with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.
I can say that forcing vendor IDs for me when I was using NVIDIA optimus in Windows 7 with a driver that wasn't from the OEM helped my FPS a bit and allowed the game render correctly. I dont have the exact numbers on hand, but it helped.

For some reason the game was recognizing my dGPU as the Intel integrated one with the driver direct from NVIDIA. This was the github issue report that helped me: https://github.com/ValveSoftware/Source-1-Games/issues/633

On Windows 10 I didnt have the same issues though. Also apparently helps on some linux systems, but I never tested that.

Your situation is really the only time to use the force driver ID launch options.

[quote=turbochad69][quote=AimIsADick]I still think [url=https://www.teamfortress.tv/post/1016536/mastercomfig-fps-customization-config]what you said about dxlevel 81 earlier[/url] should at least be displayed somewhere in the docs, otherwise it likely will keep getting misused.[/quote]
The cool thing about mastercomfig is that you can go ahead and add it to the docs right now if you want. I'm sure it would be merged if you write a good description of it.[/quote]

I am planning on contributing this information to the docs. I just have no idea how to explain the "misconception" (or rather misusage).

[quote=Fake][quote=mastercoms]Same with the force ID settings. I haven't looked too much into those but people do strangely get a benefit out of them sometimes.[/quote]

I can say that forcing vendor IDs for me when I was using NVIDIA optimus in Windows 7 with a driver that wasn't from the OEM helped my FPS a bit and allowed the game render correctly. I dont have the exact numbers on hand, but it helped.

For some reason the game was recognizing my dGPU as the Intel integrated one with the driver direct from NVIDIA. This was the github issue report that helped me: https://github.com/ValveSoftware/Source-1-Games/issues/633

On Windows 10 I didnt have the same issues though. Also apparently helps on some linux systems, but I never tested that.[/quote]

Your situation is really the only time to use the force driver ID launch options.
2177
#2177
0 Frags +

.

.
2178
#2178
0 Frags +

Does anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.

Does anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.
2179
#2179
-6 Frags +
DulZuroDoes anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.

Try running a clean installation of TF2. If the still occurs with only mastercomfig, then it's certainly a bug in mastercomfig.

[quote=DulZuro]Does anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.[/quote]

Try running a [url=https://docs.mastercomfig.com/en/latest/setup/clean_up/]clean installation of TF2[/url]. If the still occurs with only mastercomfig, then it's certainly a bug in mastercomfig.
2180
#2180
payload.tf
2 Frags +
DulZuroDoes anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.
AimIsADick.

Not a bug, just is harvest lighting. I've experienced this in other configs.

[quote=DulZuro]Does anyone know what causes this lighting glitch on harvest?

https://imgur.com/a/BqW78tc

This screenshot is from mastercomfig ultra.

I first noticed it when using mastercomfig medium high, and tried changing some of the lighting settings but nothing seemed to fix this.[/quote]

[quote=AimIsADick].[/quote]


Not a bug, just is harvest lighting. I've experienced this in other configs.
2181
#2181
0 Frags +

bro go touch some grass

bro go touch some grass
2182
#2182
3 Frags +

I checked with a clean installation and it does indeed seem to be an issue with harvest.
I guess I just haven't played harvest enough to have noticed it in the past.

I checked with a clean installation and it does indeed seem to be an issue with harvest.
I guess I just haven't played harvest enough to have noticed it in the past.
2183
#2183
14 Frags +

9.2.0 released with massive performance improvements, a great amount of bug fixes and hitreg improvements.

Changelog
Support me

This release took 50 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]9.2.0[/url] released with massive performance improvements, a great amount of bug fixes and hitreg improvements.

[url=https://github.com/mastercomfig/mastercomfig/releases/tag/9.2.0]Changelog[/url]
[url=https://docs.mastercomfig.com/page/support_me/]Support me[/url]

This release took 50 hours to produce. If you like the work I do, consider supporting me!
2184
#2184
7 Frags +

9.2.1 released with 3 imposters among us.

Changelog
Support me

This release took 2 hours to produce. If you like the work I do, consider supporting me!

https://www.youtube.com/watch?v=o7UYe7dAxwA

[url=https://mastercomfig.com/download]9.2.1[/url] released with 3 imposters among us.

[url=https://github.com/mastercomfig/mastercomfig/releases/tag/9.2.1]Changelog[/url]
[url=https://docs.mastercomfig.com/page/support_me/]Support me[/url]

This release took 2 hours to produce. If you like the work I do, consider supporting me!

[youtube]https://www.youtube.com/watch?v=o7UYe7dAxwA[/youtube]
2185
#2185
2 Frags +

https://streamable.com/4y1f6h

is there any way to make my game look like this?

https://streamable.com/4y1f6h

is there any way to make my game look like this?
2186
#2186
0 Frags +
torrit3https://streamable.com/4y1f6h

is there any way to make my game look like this?

mat_fullbright 1 - cheat, probably this
Clean TF2 _unlit_world.vpk (iirc) on sv_pure 2 servers, can't find a working download

[quote=torrit3]https://streamable.com/4y1f6h

is there any way to make my game look like this?[/quote]
mat_fullbright 1 - cheat, probably this
Clean TF2 _unlit_world.vpk (iirc) on sv_pure 2 servers, can't find a working download
2187
#2187
2 Frags +

Clean TF2 doesn't work on sv_pure servers any more, you can't get your game to look like this in sv_pure 2 at all now.

Clean TF2 doesn't work on sv_pure servers any more, you can't get your game to look like this in sv_pure 2 at all now.
2188
#2188
-4 Frags +
_KermitClean TF2 doesn't work on sv_pure servers any more, you can't get your game to look like this in sv_pure 2 at all now.

Are you able to preload the mod in to sv_pure 2?

[quote=_Kermit]Clean TF2 doesn't work on sv_pure servers any more, you can't get your game to look like this in sv_pure 2 at all now.[/quote]

Are you able to preload the mod in to sv_pure 2?
2189
#2189
0 Frags +

whenever people start burning, wether im playing pyro or someone else gets hit by a pyro, my game starts to stutter incredibly hard. anything i can do to fix this?

whenever people start burning, wether im playing pyro or someone else gets hit by a pyro, my game starts to stutter incredibly hard. anything i can do to fix this?
2190
#2190
-3 Frags +

The Ultimate Visual Fix Pack mod will remove the flame lag + patch other numerous visual bugs.

The [url=https://github.com/agrastiOs/Ultimate-TF2-Visual-Fix-Pack]Ultimate Visual Fix Pack[/url] mod will remove the flame lag + patch other numerous visual bugs.
1 ⋅⋅ 70 71 72 73 74 75 76 77
Please sign in through STEAM to post a comment.