Upvote Upvoted 270 Downvote Downvoted
1 ⋅⋅ 108 109 110 111 112 113 114 ⋅⋅ 206
HUD editing: short questions, quick answers
posted in Customization
3301
#3301
1 Frags +
STOGEhttp://i.imgur.com/3pOnxFc.png

How do I get rid of the 2 outlined green things?, the oval being the random background and the square being the background behind the player portraits and what not.

Oval is HudObjectiveTimePanel set TimePanelBG (if_match visible 0)
Square is HudMatchStatus set BGFrame to wide 0

[quote=STOGE][img]http://i.imgur.com/3pOnxFc.png[/img]

How do I get rid of the 2 outlined green things?, the oval being the random background and the square being the background behind the player portraits and what not.[/quote]

Oval is HudObjectiveTimePanel set TimePanelBG (if_match visible 0)
Square is HudMatchStatus set BGFrame to wide 0
3302
#3302
0 Frags +
HypnotizeOval is HudObjectiveTimePanel set TimePanelBG (if_match visible 0)
Square is HudMatchStatus set BGFrame to wide 0

That was quick, thanks!

These icons are blurry too for some reason

http://i.imgur.com/VLH6HKO.png

Is this a hud problem or something else?

[quote=Hypnotize]
Oval is HudObjectiveTimePanel set TimePanelBG (if_match visible 0)
Square is HudMatchStatus set BGFrame to wide 0[/quote]

That was quick, thanks!

These icons are blurry too for some reason

[img]http://i.imgur.com/VLH6HKO.png[/img]

Is this a hud problem or something else?
3303
#3303
0 Frags +

I'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like this

Here's the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.

I'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like [url=https://imgur.com/qIMgCpH]this[/url]

[url=https://imgur.com/a/8CKBN]Here's[/url] the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.
3304
#3304
1 Frags +
TheRealSSI'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like this

Here's the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.

you need to know the name of the font and install it in your resource folder, just open it and press install

[quote=TheRealSS]I'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like [url=https://imgur.com/qIMgCpH]this[/url]

[url=https://imgur.com/a/8CKBN]Here's[/url] the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.[/quote]
you need to know the name of the font and install it in your resource folder, just open it and press install
3305
#3305
0 Frags +
yttriumquestion

Type in vgui_drawtree then click on show panel bounds

[quote=yttrium]question[/quote] Type in vgui_drawtree then click on show panel bounds
3306
#3306
0 Frags +
Phoenix21TheRealSSI'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like this

Here's the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.
you need to know the name of the font and install it in your resource folder, just open it and press install

I tried that too, still doesn't work.

[quote=Phoenix21][quote=TheRealSS]I'm having issues with installing a font. The fonts for my health and ammo don't seem to work. I haven't messed up the font name or the extension type yet the health and ammo show up like [url=https://imgur.com/qIMgCpH]this[/url]

[url=https://imgur.com/a/8CKBN]Here's[/url] the images for the lines in my clientscheme.res. I tried installing the font but that doesn't work either. The other weights of the font work perfectly fine somehow.[/quote]
you need to know the name of the font and install it in your resource folder, just open it and press install[/quote]
I tried that too, still doesn't work.
3307
#3307
0 Frags +
Lucky_Benderyttriumquestion Type in vgui_drawtree then click on show panel bounds

Thanks, knew that command existed somewhere but just couldn't find its name for the life of me.

[quote=Lucky_Bender][quote=yttrium]question[/quote] Type in vgui_drawtree then click on show panel bounds[/quote]
Thanks, knew that command existed somewhere but just couldn't find its name for the life of me.
3308
#3308
0 Frags +

not related to hud editing, but why can't I get updated huds to work? I've tried three different ones and the only things that work are the fonts and the startup loading screen.

not related to hud editing, but why can't I get updated huds to work? I've tried three different ones and the only things that work are the fonts and the startup loading screen.
3309
#3309
1 Frags +

there's this big gray box at the top of my screen and idk how to turn it off please help
kbnhud
http://steamcommunity.com/sharedfiles/filedetails/?id=721177996

there's this big gray box at the top of my screen and idk how to turn it off please help
kbnhud
http://steamcommunity.com/sharedfiles/filedetails/?id=721177996
3310
#3310
0 Frags +

Hello, I'm currently using Broeselhud, I'd like to replace the overheal cross (http://imgur.com/rJJscUl) with the box from yayahud (http://imgur.com/Gl0bf6L). Can anyone tell me what I need to change in the hud?
Thanks!

Hello, I'm currently using Broeselhud, I'd like to replace the overheal cross (http://imgur.com/rJJscUl) with the box from yayahud (http://imgur.com/Gl0bf6L). Can anyone tell me what I need to change in the hud?
Thanks!
3311
#3311
0 Frags +

http://imgur.com/OVOYoB7

Is there a way to remove this. I'm using bwhud.

http://imgur.com/OVOYoB7

Is there a way to remove this. I'm using bwhud.
3312
#3312
0 Frags +

After the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?

http://image.prntscr.com/image/9d91f3f378884d53914b1e1620528522.png

After the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?

[img]http://image.prntscr.com/image/9d91f3f378884d53914b1e1620528522.png[/img]
3313
#3313
0 Frags +
After the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?

I am guessing that it is from not updating all the hud files or something screwing up in hudlayout.res. I recall having a similar problem but after I scrolled through all the changes in GitHub and updated all of my hud to get it functioning it went away, along with another black box at the top of the screen. Also have you tried binding a button to +quickswitch and pressing it down? That would be the other thing that I would try to fix the problem.

[quote]After the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?[/quote]

I am guessing that it is from not updating all the hud files or something screwing up in hudlayout.res. I recall having a similar problem but after I scrolled through all the changes in GitHub and updated all of my hud to get it functioning it went away, along with another black box at the top of the screen. Also have you tried binding a button to +quickswitch and pressing it down? That would be the other thing that I would try to fix the problem.
3314
#3314
0 Frags +
XenThePybroAfter the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?
I am guessing that it is from not updating all the hud files or something screwing up in hudlayout.res. I recall having a similar problem but after I scrolled through all the changes in GitHub and updated all of my hud to get it functioning it went away, along with another black box at the top of the screen. Also have you tried binding a button to +quickswitch and pressing it down? That would be the other thing that I would try to fix the problem.

Yes, I know about the quickswitch fix but that seems unnecessary. There should be a way to remove it without a workaround like that. I guess I'll check out the hudlayout diff, but I'm pretty confident I updated everything that changed in my HUD.

[quote=XenThePybro][quote]After the meat your match update came out, I started hearing reports of this black loadout box appearing at the top of the screen. It doesn't allow people to switch weapons while it's active. Anyone know what this is?[/quote]

I am guessing that it is from not updating all the hud files or something screwing up in hudlayout.res. I recall having a similar problem but after I scrolled through all the changes in GitHub and updated all of my hud to get it functioning it went away, along with another black box at the top of the screen. Also have you tried binding a button to +quickswitch and pressing it down? That would be the other thing that I would try to fix the problem.[/quote]

Yes, I know about the quickswitch fix but that seems unnecessary. There should be a way to remove it without a workaround like that. I guess I'll check out the hudlayout diff, but I'm pretty confident I updated everything that changed in my HUD.
3315
#3315
0 Frags +

http://i.imgur.com/nhORlb1.png

Which hud file contains the bit where you see your medic's medigun?

thanks in advance!

[img]http://i.imgur.com/nhORlb1.png[/img]

Which hud file contains the bit where you see your medic's medigun?

thanks in advance!
3316
#3316
2 Frags +
Ash_http://i.imgur.com/nhORlb1.png

Which hud file contains the bit where you see your medic's medigun?

thanks in advance!

TargetID.res under TargetDataLabel

[quote=Ash_][img]http://i.imgur.com/nhORlb1.png[/img]

Which hud file contains the bit where you see your medic's medigun?

thanks in advance![/quote]

TargetID.res under TargetDataLabel
3317
#3317
0 Frags +

Does anyone know why the TF2 characters have disappeared from the main menu? I'm finishing up my Overwatch HUD and it the characters seem to have disappeared off the main menu.

Here's what the character image definition looks like:

http://puu.sh/pXrNt/aaf15b10db.png

I don't see anything that's making the character not show up.

Does anyone know why the TF2 characters have disappeared from the main menu? I'm finishing up my Overwatch HUD and it the characters seem to have disappeared off the main menu.

Here's what the character image definition looks like:
[img]http://puu.sh/pXrNt/aaf15b10db.png[/img]

I don't see anything that's making the character not show up.
3318
#3318
1 Frags +

What files are used for the animation in matchmaking and casual 10 seconds before the game starts? (Closing doors)
My game crashs everytime the timer reaches 10 seconds, so I asume it's caused by that animation.

I replaced the part in hudanimations_tf, but it's still happening.

What files are used for the animation in matchmaking and casual 10 seconds before the game starts? (Closing doors)
My game crashs everytime the timer reaches 10 seconds, so I asume it's caused by that animation.

I replaced the part in hudanimations_tf, but it's still happening.
3319
#3319
0 Frags +

Hello.
So, I'm trying to record with Lawena Recording Tool and I've set the hud to Kill Notices Only, when I record there is a black square on the top of my screen. How do I fix that?
Thanks in advance!

Image of the problem:

http://i.imgur.com/lR4Vdqo.jpg

EDIT: I found the updated killfeed hud here https://github.com/Kuw/recordinghuds

Hello.
So, I'm trying to record with Lawena Recording Tool and I've set the hud to Kill Notices Only, when I record there is a black square on the top of my screen. How do I fix that?
Thanks in advance!

Image of the problem:[img]http://i.imgur.com/lR4Vdqo.jpg[/img]

EDIT: I found the updated killfeed hud here https://github.com/Kuw/recordinghuds
3320
#3320
0 Frags +

http://i.imgur.com/8tCvX3B.png

Is there a way I can remove these player name backgrounds? (outlined in green)

[img]http://i.imgur.com/8tCvX3B.png[/img]

Is there a way I can remove these player name backgrounds? (outlined in green)
3321
#3321
0 Frags +

Does anyone know why when i open my console http://i.imgur.com/eMiCRLv.jpg turns to http://i.imgur.com/s0woVf3.png ?

Does anyone know why when i open my console http://i.imgur.com/eMiCRLv.jpg turns to http://i.imgur.com/s0woVf3.png ?
3322
#3322
0 Frags +

Is there any way to remove this white line ?

Is there any way to remove [url=http://imgur.com/GNFa6uC]this[/url] white line ?
3323
#3323
1 Frags +
HypnotizeProbably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?

Any answer to this question?

[quote=Hypnotize]Probably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?[/quote]

Any answer to this question?
3324
#3324
1 Frags +
Stochast1cHypnotizeProbably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?
Any answer to this question?

Record a demo of a MM game and use playdemo

[quote=Stochast1c][quote=Hypnotize]Probably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?[/quote]

Any answer to this question?[/quote]
Record a demo of a MM game and use playdemo
3325
#3325
0 Frags +

#3324, while a demo has always worked, I'm more interested in a method to force the mm hud on while playing locally, unless there is a repository of mm demos.

#3324, [s]while a demo has always worked[/s], I'm more interested in a method to force the mm hud on while playing locally, unless there is a repository of mm demos.
3326
#3326
-1 Frags +
CubekolIs there any way to remove this white line ?

no, sadly not.

[quote=Cubekol]Is there any way to remove [url=http://imgur.com/GNFa6uC]this[/url] white line ?[/quote]
no, sadly not.
3327
#3327
1 Frags +
umlflaccidStochast1cHypnotizeProbably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?
Any answer to this question?
Record a demo of a MM game and use playdemo
Stochast1c#3324, while a demo has always worked, I'm more interested in a method to force the mm hud on while playing locally, unless there is a repository of mm demos.

Demos do not store the fact that it recorded a matchmaking game. It will play back with the non-matchmaking HUD. I believe Wiet has contacted Valve to see if they'll add back a cvar to allow us to force it while watching demos.

[quote=umlflaccid][quote=Stochast1c][quote=Hypnotize]Probably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?[/quote]

Any answer to this question?[/quote]
Record a demo of a MM game and use playdemo[/quote]

[quote=Stochast1c]#3324, while a demo has always worked, I'm more interested in a method to force the mm hud on while playing locally, unless there is a repository of mm demos.[/quote]

Demos do not store the fact that it recorded a matchmaking game. It will play back with the non-matchmaking HUD. I believe Wiet has contacted Valve to see if they'll add back a cvar to allow us to force it while watching demos.
3328
#3328
0 Frags +
HypnotizeProbably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?

spawn a bunch of bots, type mp_tournament 1 into the console and join spectator.

When I was screwing around with my scoreboard I found the bit that lets you display the gamemode on the scoreboard but now it is broken, both mine and on valves, after I enabled it.

Show Content
[code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "ScoreboardVerySmall"
"labelText" "%gametype%"
"textAlignment" "east"
"xpos" "435"
"ypos" "32"
"zpos" "3"
"wide" "145"
"tall" "20"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "185 177 153 255"
"KillsLabel"[/code]
{
Show Content
[code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "Medium8"
//"font_minmode" "Medium8"
"labelText" "%gametype%"
"textAlignment" "center"
"xpos" "c-83" //"c-83"
//"xpos_minmode" "r198"
"ypos" "r121"
//"ypos_minmode" "r158"
"zpos" "3"
"wide" "165"
//"wide_minmode" "110"
"tall" "15"
//"tall_minmode" "16"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "White"
}[/code]

It just displays [unknown] on the scoreboard

[quote=Hypnotize]Probably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?[/quote]

spawn a bunch of bots, type mp_tournament 1 into the console and join spectator.

When I was screwing around with my scoreboard I found the bit that lets you display the gamemode on the scoreboard but now it is broken, both mine and on valves, after I enabled it.

[spoiler][code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "ScoreboardVerySmall"
"labelText" "%gametype%"
"textAlignment" "east"
"xpos" "435"
"ypos" "32"
"zpos" "3"
"wide" "145"
"tall" "20"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "185 177 153 255"
"KillsLabel"[/code]
{[/spoiler]


[spoiler][code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "Medium8"
//"font_minmode" "Medium8"
"labelText" "%gametype%"
"textAlignment" "center"
"xpos" "c-83" //"c-83"
//"xpos_minmode" "r198"
"ypos" "r121"
//"ypos_minmode" "r158"
"zpos" "3"
"wide" "165"
//"wide_minmode" "110"
"tall" "15"
//"tall_minmode" "16"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "White"
}[/code][/spoiler]

It just displays [unknown] on the scoreboard
3329
#3329
2 Frags +
XenThePybroHypnotizeProbably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?
spawn a bunch of bots, type mp_tournament 1 into the console and join spectator.

When I was screwing around with my scoreboard I found the bit that lets you display the gamemode on the scoreboard but now it is broken, both mine and on valves, after I enabled it.
Show Content
[code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "ScoreboardVerySmall"
"labelText" "%gametype%"
"textAlignment" "east"
"xpos" "435"
"ypos" "32"
"zpos" "3"
"wide" "145"
"tall" "20"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "185 177 153 255"
"KillsLabel"[/code]
{
Show Content
[code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "Medium8"
//"font_minmode" "Medium8"
"labelText" "%gametype%"
"textAlignment" "center"
"xpos" "c-83" //"c-83"
//"xpos_minmode" "r198"
"ypos" "r121"
//"ypos_minmode" "r158"
"zpos" "3"
"wide" "165"
//"wide_minmode" "110"
"tall" "15"
//"tall_minmode" "16"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "White"
}[/code]

It just displays [unknown] on the scoreboard

The gametype part has been broken for years, it's not at all recent. It was pointless to have on the scoreboard mostly but I kinda liked it.

[quote=XenThePybro][quote=Hypnotize]Probably not the best thread to ask this but, since tf_competitive_mode 1 is not working anymore for me is there a way to create a local sever and run the comp mode so i can edit my mm hud?[/quote]

spawn a bunch of bots, type mp_tournament 1 into the console and join spectator.

When I was screwing around with my scoreboard I found the bit that lets you display the gamemode on the scoreboard but now it is broken, both mine and on valves, after I enabled it.

[spoiler][code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "ScoreboardVerySmall"
"labelText" "%gametype%"
"textAlignment" "east"
"xpos" "435"
"ypos" "32"
"zpos" "3"
"wide" "145"
"tall" "20"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "185 177 153 255"
"KillsLabel"[/code]
{[/spoiler]


[spoiler][code] "GameType"
{
"ControlName" "CExLabel"
"fieldName" "gametype"
"font" "Medium8"
//"font_minmode" "Medium8"
"labelText" "%gametype%"
"textAlignment" "center"
"xpos" "c-83" //"c-83"
//"xpos_minmode" "r198"
"ypos" "r121"
//"ypos_minmode" "r158"
"zpos" "3"
"wide" "165"
//"wide_minmode" "110"
"tall" "15"
//"tall_minmode" "16"
"autoResize" "0"
"pinCorner" "0"
"visible" "1"
"enabled" "1"
"fgcolor" "White"
}[/code][/spoiler]

It just displays [unknown] on the scoreboard[/quote]

The gametype part has been broken for years, it's not at all recent. It was pointless to have on the scoreboard mostly but I kinda liked it.
3330
#3330
0 Frags +

I'm not entirely certain if this is a hud problem, but it happened after I installed mkhud. I noticed that all commands that were going through the dev console were showing up on the main ui. It was really annoying as I was bombarded by red text saying that some vtf files weren't acceptable, which isn't out of the ordinary, but I just don't want that to show up on the screen all the time. I tried searching this problem on google, but naturally it just came up with wiki pages of a list of all console commands.

I'm not entirely certain if this is a hud problem, but it happened after I installed mkhud. I noticed that all commands that were going through the dev console were showing up on the main ui. It was really annoying as I was bombarded by red text saying that some vtf files weren't acceptable, which isn't out of the ordinary, but I just don't want that to show up on the screen all the time. I tried searching this problem on google, but naturally it just came up with wiki pages of a list of all console commands.
1 ⋅⋅ 108 109 110 111 112 113 114 ⋅⋅ 206
Please sign in through STEAM to post a comment.