Upvote Upvoted 245 Downvote Downvoted
1 ⋅⋅ 33 34 35 36 37 38 39 ⋅⋅ 58
mastercomfig - fps/customization config
posted in Customization
1051
#1051
0 Frags +

For everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?

For everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?
1052
#1052
1 Frags +

6.4.1-b2 https://github.com/mastercoms/mastercomfig/releases/tag/6.4.1-b2

6.4.1-b2 https://github.com/mastercoms/mastercomfig/releases/tag/6.4.1-b2
1053
#1053
0 Frags +

I can't preload yttrium's comp viewmodels using this cfg. It crashes on startup every time no matter what. I tried many other cfgs and preloading works just fine. Any possible fixes?

I can't preload yttrium's comp viewmodels using this cfg. It crashes on startup every time no matter what. I tried many other cfgs and preloading works just fine. Any possible fixes?
1054
#1054
0 Frags +
BigWiggyStyleI can't preload yttrium's comp viewmodels using this cfg. It crashes on startup every time no matter what. I tried many other cfgs and preloading works just fine. Any possible fixes?

Are you using the beta? If so, preloading is not compatible with one of the memory optimizations. Here's how to fix it.

[quote=BigWiggyStyle]I can't preload yttrium's comp viewmodels using this cfg. It crashes on startup every time no matter what. I tried many other cfgs and preloading works just fine. Any possible fixes?[/quote]
Are you using the beta? If so, preloading is not compatible with one of the memory optimizations. Here's [url=https://github.com/mastercoms/mastercomfig/wiki/Troubleshooting#crashing-when-trying-to-preload-mods]how to fix it[/url].
1055
#1055
0 Frags +

I am using the newest version of the cfg the command that I use to preload it map_background preload_room; wait 10; disconnect it crashes on startup every time and cl_always_flush_models is set to 0. I tried with 1 too. Didn't work

I am using the newest version of the cfg the command that I use to preload it map_background preload_room; wait 10; disconnect it crashes on startup every time and cl_always_flush_models is set to 0. I tried with 1 too. Didn't work
1056
#1056
1 Frags +

6.4.1 released with memory usage optimizations, performance improvements and documentation updates

[b][url=https://github.com/mastercoms/tf2cfg/releases/tag/6.4.1]6.4.1[/url] released with memory usage optimizations, performance improvements and documentation updates[/b]
1057
#1057
0 Frags +

when im using the latest version i have some fogginess.

what do?

when im using the latest version i have some fogginess.

what do?
1058
#1058
0 Frags +

The latest version causes my screen to flicker rapidly upon startup, and causes the "next map" casual UI's position to glitch, appearing on the far left instead of the center. I'm running on Windows 10 with a GTX 1050 TI (driver version 390.77) and an i7-7700HQ. I'm rolling back to 6.4.0, the screen flicker really hurts my eyes.

The latest version causes my screen to flicker rapidly upon startup, and causes the "next map" casual UI's position to glitch, appearing on the far left instead of the center. I'm running on Windows 10 with a GTX 1050 TI (driver version 390.77) and an i7-7700HQ. I'm rolling back to 6.4.0, the screen flicker really hurts my eyes.
1059
#1059
0 Frags +
mastercomsFor everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?

i5-6200u
geforce 940mx
8 gb ram
windows 10
maxperformance
no applause and domination sounds
rayshud
that's pretty much it.
upd: also dxlevel 81

[quote=mastercoms]For everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?[/quote]
i5-6200u
geforce 940mx
8 gb ram
windows 10
maxperformance
no applause and domination sounds
rayshud
that's pretty much it.
upd: also dxlevel 81
1060
#1060
0 Frags +
Rotten_MindmastercomsFor everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?i5-6200u
geforce 940mx
8 gb ram
windows 10
maxperformance
no applause and domination sounds
rayshud
that's pretty much it.
upd: also dxlevel 81

Could you try using different dxlevels?It might be the culprit.

[quote=Rotten_Mind][quote=mastercoms]For everyone who crashes: what are your exact hardware specs, OS and preset? Also do you use any other custom files/mods?[/quote]
i5-6200u
geforce 940mx
8 gb ram
windows 10
maxperformance
no applause and domination sounds
rayshud
that's pretty much it.
upd: also dxlevel 81[/quote]

Could you try using different dxlevels?It might be the culprit.
1061
#1061
0 Frags +
solly6Could you try using different dxlevels?It might be the culprit.

bigger dxlevels eat a lot of fps for me, i found 81 is a big deal.
but ill try it anyways.

[quote=solly6]
Could you try using different dxlevels?It might be the culprit.[/quote]
bigger dxlevels eat a lot of fps for me, i found 81 is a big deal.
but ill try it anyways.
1062
#1062
0 Frags +

Hi, how does maxquality compare to vanilla TF2? Does it have an equivalent graphical quality with better performance, or does it have improved graphics but a worse performance compared to vanilla?

Hi, how does maxquality compare to vanilla TF2? Does it have an equivalent graphical quality with better performance, or does it have improved graphics but a worse performance compared to vanilla?
1063
#1063
0 Frags +
CapoFantasma97Hi, how does maxquality compare to vanilla TF2? Does it have an equivalent graphical quality with better performance, or does it have improved graphics but a worse performance compared to vanilla?

It has the optimizations from the default config that don't affect quality and it has higher graphics than the highest graphics available from the in-game settings. So honestly it mostly depends on your graphics card.

[quote=CapoFantasma97]Hi, how does maxquality compare to vanilla TF2? Does it have an equivalent graphical quality with better performance, or does it have improved graphics but a worse performance compared to vanilla?[/quote]
It has the optimizations from the default config that don't affect quality and it has higher graphics than the highest graphics available from the in-game settings. So honestly it mostly depends on your graphics card.
1064
#1064
0 Frags +

Hey, i just notice something. Why is Shaders on high? since i saw it on high in options

Hey, i just notice something. Why is Shaders on high? since i saw it on high in options
1065
#1065
0 Frags +
GoodOlDavyHey, i just notice something. Why is Shaders on high? since i saw it on high in options

no round shadows

[quote=GoodOlDavy]Hey, i just notice something. Why is Shaders on high? since i saw it on high in options[/quote]
no round shadows
1066
#1066
0 Frags +
GoodOlDavyHey, i just notice something. Why is Shaders on high? since i saw it on high in options

Because when on low, Source will use some DirectX 8 features. If you don't have a badgpu (which sets shaders to low), it is more optimal to use the latest features from PS2.0b.

[quote=GoodOlDavy]Hey, i just notice something. Why is Shaders on high? since i saw it on high in options[/quote]
Because when on low, Source will use some DirectX 8 features. If you don't have a badgpu (which sets shaders to low), it is more optimal to use the latest features from PS2.0b.
1067
#1067
-1 Frags +

Just thought I'd post as I don't have a cringe PC any more but still get cringe frames. Am I using the wrong preset or something? Should I go configless? I don't know as I've tried some stuff already and don't see to get very good frames. Could just be the fact that I have an AMD CPU.

CPU: AMD Ryzen 5 1400 @ 3.2 ghz
GPU: RX580 8GB @ 1.366 ghz
RAM: 8GB
WIN7
TF2 Installed on SSD, running dxlevel 95 and version 5.0.0 of this config. Using the competitive quality preset.

I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.

Just thought I'd post as I don't have a cringe PC any more but still get cringe frames. Am I using the wrong preset or something? Should I go configless? I don't know as I've tried some stuff already and don't see to get very good frames. Could just be the fact that I have an AMD CPU.

CPU: AMD Ryzen 5 1400 @ 3.2 ghz
GPU: RX580 8GB @ 1.366 ghz
RAM: 8GB
WIN7
TF2 Installed on SSD, running dxlevel 95 and version 5.0.0 of this config. Using the competitive quality preset.

I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.
1068
#1068
2 Frags +
MakJust thought I'd post as I don't have a cringe PC any more but still get cringe frames...
I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.

A- 120 frames's pretty good (edit: checked the price of your GPU and for that 120 is SHIT... if you were playing another game. Since TF2 came out in 2007 it's very CPU dependent and your CPU seems to be much cheaper than your GPU and not that good).
B- You should probably install a version of the config which is not 3 months old, since that "problem" may have already been fixed in the later releases.
C- If you want more frames you can use the comp preset, the other presets that have lower graphics than compquality (maxperformance and stripped) are not worth it if you're already getting about 120 fps. Also, use the SSD addon, and try seeing if other dxlevels boost your performance if you haven't done it already.

[quote=Mak]Just thought I'd post as I don't have a cringe PC any more but still get cringe frames...
I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.[/quote]
A- 120 frames's pretty good (edit: checked the price of your GPU and for that 120 is SHIT... if you were playing another game. Since TF2 came out in 2007 it's very CPU dependent and your CPU seems to be much cheaper than your GPU and not that good).
B- You should probably install a version of the config which is not 3 months old, since that "problem" may have already been fixed in the later releases.
C- If you want more frames you can use the comp preset, the other presets that have lower graphics than compquality (maxperformance and stripped) are not worth it if you're already getting about 120 fps. Also, use the SSD addon, and try seeing if other dxlevels boost your performance if you haven't done it already.
1069
#1069
0 Frags +
MakJust thought I'd post as I don't have a cringe PC any more but still get cringe frames. Am I using the wrong preset or something? Should I go configless? I don't know as I've tried some stuff already and don't see to get very good frames. Could just be the fact that I have an AMD CPU.

CPU: AMD Ryzen 5 1400 @ 3.2 ghz
GPU: RX580 8GB @ 1.366 ghz
RAM: 8GB
WIN7
TF2 Installed on SSD, running dxlevel 95 and version 5.0.0 of this config. Using the competitive quality preset.

I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.

What are your launch options?

And you really need to update to 6.4.1. Any reason why you're still on 5.0.0?

Also, keep in mind that compquality disables lots of optimizations for the sake of slightly improving accuracy of sounds and graphics. You might have better luck with default or comp.

[quote=Mak]Just thought I'd post as I don't have a cringe PC any more but still get cringe frames. Am I using the wrong preset or something? Should I go configless? I don't know as I've tried some stuff already and don't see to get very good frames. Could just be the fact that I have an AMD CPU.

CPU: AMD Ryzen 5 1400 @ 3.2 ghz
GPU: RX580 8GB @ 1.366 ghz
RAM: 8GB
WIN7
TF2 Installed on SSD, running dxlevel 95 and version 5.0.0 of this config. Using the competitive quality preset.

I get less than 120 fps on certain mid fights and drop below 120 quite often on pubs.[/quote]
What are your launch options?

And you really need to update to 6.4.1. Any reason why you're still on 5.0.0?

Also, keep in mind that compquality disables lots of optimizations for the sake of slightly improving accuracy of sounds and graphics. You might have better luck with default or comp.
1070
#1070
SizzlingStats
1 Frags +
-nohltv: disables SourceTV, faster startup and less memory usage but can't spectate through SourceTV

This launch option was causing me to get kicked from a few pub servers after playing for an arbitrary amount of time. The console message went something like this:

Disconnect: There was an error communicating with the server. Please reconnect..

Edit: This was actually false and the error came from a reserve slot system from the server I was connecting to.

[quote]-nohltv: disables SourceTV, faster startup and less memory usage but can't spectate through SourceTV[/quote]
[s]This launch option was causing me to get kicked from a few pub servers after playing for an arbitrary amount of time. The console message went something like this:[/s]
[code]Disconnect: There was an error communicating with the server. Please reconnect..[/code]


[b]Edit[/b]: This was actually false and the error came from a reserve slot system from the server I was connecting to.
1071
#1071
0 Frags +

Hey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_gl

Hey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_gl
1072
#1072
0 Frags +
DrasticBinHey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_gl

badgpu sets the fog to the hazy fog, you should set r_pixelfog 1 in your custom.cfg

[quote=DrasticBin]Hey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_gl[/quote]
badgpu sets the fog to the hazy fog, you should set r_pixelfog 1 in your custom.cfg
1073
#1073
0 Frags +
mastercomsDrasticBinHey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_glbadgpu sets the fog to the hazy fog, you should set r_pixelfog 1 in your custom.cfg

Thanks Its gone :D

[quote=mastercoms][quote=DrasticBin]Hey the fog is back when i installed the 6.4.1 mastercomfig and i used the comp preset with the badgpu,badcpu,ssd addons and my launch options are: -dxlevel 90 -high -w 800 -h 600 -novid -nojoy -nosteamcontroller -noff -softparticlesdefaultoff -reuse -r_emulate_gl[/quote]
badgpu sets the fog to the hazy fog, you should set r_pixelfog 1 in your custom.cfg[/quote]
Thanks Its gone :D
1074
#1074
-4 Frags +

hey I was wondering what settings I need to change to make my game look more like the pic on the left? im using comangliacoms
specifically the details in the facial cosmetic. I'm fine with having no eyes :)

https://i.imgur.com/TTXjq2Y.jpg

hey I was wondering what settings I need to change to make my game look more like the pic on the left? im using comangliacoms
specifically the details in the facial cosmetic. I'm fine with having no eyes :)
[img]https://i.imgur.com/TTXjq2Y.jpg[/img]
1075
#1075
0 Frags +

It still crashes on startup :c

It still crashes on startup :c
1076
#1076
4 Frags +
billwhey I was wondering what settings I need to change to make my game look more like the pic on the left? im using comangliacoms
specifically the details in the facial cosmetic. I'm fine with having no eyes :)
https://i.imgur.com/TTXjq2Y.jpg

Hi, comangliacoms isn't my config. Please ask support questions for it in the Comanglia thread. However, if I were to guess, you need a higher lod level.

BigWiggyStyleIt still crashes on startup :c

Open your config.cfg in tf/cfg. Find mat_antialias and remove that line from the file. Also make sure you remove your -dxlevel launch option if you have one.

[quote=billw]hey I was wondering what settings I need to change to make my game look more like the pic on the left? im using comangliacoms
specifically the details in the facial cosmetic. I'm fine with having no eyes :)
[img]https://i.imgur.com/TTXjq2Y.jpg[/img][/quote]
Hi, comangliacoms isn't my config. Please ask support questions for it in the Comanglia thread. However, if I were to guess, you need a higher lod level.

[quote=BigWiggyStyle]It still crashes on startup :c[/quote]
Open your config.cfg in tf/cfg. Find mat_antialias and remove that line from the file. Also make sure you remove your -dxlevel launch option if you have one.
1077
#1077
0 Frags +

just looked through comangliacoms and found this

-usetcp : allow usage of TCP where it would be more optimal than UDP, better network performance

is it really beneficial, and why isn't it in your config?

just looked through comangliacoms and found this
[quote]-usetcp : allow usage of TCP where it would be more optimal than UDP, better network performance
[/quote]
is it really beneficial, and why isn't it in your config?
1078
#1078
1 Frags +
Rotten_Mindjust looked through comangliacoms and found this-usetcp : allow usage of TCP where it would be more optimal than UDP, better network performanceis it really beneficial, and why isn't it in your config?

It was in my config, but I found that it caused errors so I removed it.

[quote=Rotten_Mind]just looked through comangliacoms and found this
[quote]-usetcp : allow usage of TCP where it would be more optimal than UDP, better network performance
[/quote]
is it really beneficial, and why isn't it in your config?[/quote]
It was in my config, but I found that it caused errors so I removed it.
1079
#1079
0 Frags +

are the errors worse than the benefits?

are the errors worse than the benefits?
1080
#1080
3 Frags +
charleare the errors worse than the benefits?

The benefits weren't very clear in the first place, UDP is acceptable in most if not all cases.

[quote=charle]are the errors worse than the benefits?[/quote]
The benefits weren't very clear in the first place, UDP is acceptable in most if not all cases.
1 ⋅⋅ 33 34 35 36 37 38 39 ⋅⋅ 58
Please sign in through STEAM to post a comment.