Upvote Upvoted 253 Downvote Downvoted
1 ⋅⋅ 10 11 12 13 14 15 16 ⋅⋅ 63
mastercomfig - fps/customization config
posted in Customization
361
#361
0 Frags +
AsecBesides the FPS improvement, I have noticed the game is much smoother now. Can't thank you enough for that, keep up the amazing work!

Glad to hear you've been liking it!!! Thank you for the kind words <3, it means a lot

FamesBenchmark mastercoms CFG

I've been looking into this.

[quote=Asec]
Besides the FPS improvement, I have noticed the game is much smoother now. Can't thank you enough for that, keep up the amazing work![/quote]
Glad to hear you've been liking it!!! Thank you for the kind words <3, it means a lot

[quote=Fames]
Benchmark mastercoms CFG
[/quote]
I've been looking into this.
362
#362
0 Frags +

do u know what settings can affect the visibility of rockets and stickies?

also what settings make you see people under water

do u know what settings can affect the visibility of rockets and stickies?

also what settings make you see people under water
363
#363
3 Frags +
yahoodo u know what settings can affect the visibility of rockets and stickies?

Not really any noticeable settings, are you having trouble seeing them compared to default?

yahooalso what settings make you see people under water
r_WaterDrawRefraction 1
r_cheapwaterstart 400
r_cheapwaterend 1000

Anyways, 4.2.0 just released. Blaze it (in moderation, or not at all, if that's not your thing).

EDIT: 4.2.1 released with a small fix to sound spatialization

[quote=yahoo]do u know what settings can affect the visibility of rockets and stickies?[/quote]
Not really any noticeable settings, are you having trouble seeing them compared to default?

[quote=yahoo]also what settings make you see people under water[/quote]
[code]r_WaterDrawRefraction 1
r_cheapwaterstart 400
r_cheapwaterend 1000[/code]

Anyways, [url=https://github.com/mastercoms/tf2cfg/releases/tag/4.2.0]4.2.0[/url] just released. Blaze it (in moderation, or not at all, if that's not your thing).

EDIT: [url=https://github.com/mastercoms/tf2cfg/releases/tag/4.2.1]4.2.1[/url] released with a small fix to sound spatialization
364
#364
6 Frags +

dxlevel 98 (must be set via launch options)

2639 frames 21.453 seconds 123.02 fps ( 8.13 ms/f) 11.517 fps variability
2639 frames 21.572 seconds 122.33 fps ( 8.17 ms/f) 11.070 fps variability
2639 frames 21.689 seconds 121.67 fps ( 8.22 ms/f) 10.910 fps variability
2639 frames 21.548 seconds 122.47 fps ( 8.17 ms/f) 11.271 fps variability

dxlevel 95

2639 frames 21.995 seconds 119.98 fps ( 8.33 ms/f) 11.652 fps variability
2639 frames 21.901 seconds 120.49 fps ( 8.30 ms/f) 10.653 fps variability
2639 frames 21.902 seconds 120.49 fps ( 8.30 ms/f) 10.890 fps variability
2639 frames 21.979 seconds 120.07 fps ( 8.33 ms/f) 10.401 fps variability

dxlevel 90

2639 frames 21.728 seconds 121.46 fps ( 8.23 ms/f) 11.570 fps variability
2639 frames 21.626 seconds 122.03 fps ( 8.19 ms/f) 11.028 fps variability
2639 frames 21.805 seconds 121.03 fps ( 8.26 ms/f) 11.047 fps variability
2639 frames 21.606 seconds 122.14 fps ( 8.19 ms/f) 11.122 fps variability

dxlevel 100

2639 frames 21.899 seconds 120.51 fps ( 8.30 ms/f) 11.548 fps variability
2639 frames 22.060 seconds 119.63 fps ( 8.36 ms/f) 11.086 fps variability
2639 frames 21.872 seconds 120.66 fps ( 8.29 ms/f) 11.107 fps variability
2639 frames 21.854 seconds 120.76 fps ( 8.28 ms/f) 10.886 fps variability

dxlevel 690

2639 frames 21.947 seconds 120.25 fps ( 8.32 ms/f) 11.446 fps variability
2639 frames 21.911 seconds 120.44 fps ( 8.30 ms/f) 10.762 fps variability
2639 frames 21.864 seconds 120.70 fps ( 8.29 ms/f) 10.461 fps variability
2639 frames 21.891 seconds 120.55 fps ( 8.30 ms/f) 10.939 fps variability

CPU: AMD FX-8350
GPU: NVIDIA GTX 960

dxlevel 98 (must be set via launch options)
[code]2639 frames 21.453 seconds 123.02 fps ( 8.13 ms/f) 11.517 fps variability
2639 frames 21.572 seconds 122.33 fps ( 8.17 ms/f) 11.070 fps variability
2639 frames 21.689 seconds 121.67 fps ( 8.22 ms/f) 10.910 fps variability
2639 frames 21.548 seconds 122.47 fps ( 8.17 ms/f) 11.271 fps variability[/code]

dxlevel 95
[code]2639 frames 21.995 seconds 119.98 fps ( 8.33 ms/f) 11.652 fps variability
2639 frames 21.901 seconds 120.49 fps ( 8.30 ms/f) 10.653 fps variability
2639 frames 21.902 seconds 120.49 fps ( 8.30 ms/f) 10.890 fps variability
2639 frames 21.979 seconds 120.07 fps ( 8.33 ms/f) 10.401 fps variability[/code]

dxlevel 90
[code]2639 frames 21.728 seconds 121.46 fps ( 8.23 ms/f) 11.570 fps variability
2639 frames 21.626 seconds 122.03 fps ( 8.19 ms/f) 11.028 fps variability
2639 frames 21.805 seconds 121.03 fps ( 8.26 ms/f) 11.047 fps variability
2639 frames 21.606 seconds 122.14 fps ( 8.19 ms/f) 11.122 fps variability[/code]

dxlevel 100
[code]2639 frames 21.899 seconds 120.51 fps ( 8.30 ms/f) 11.548 fps variability
2639 frames 22.060 seconds 119.63 fps ( 8.36 ms/f) 11.086 fps variability
2639 frames 21.872 seconds 120.66 fps ( 8.29 ms/f) 11.107 fps variability
2639 frames 21.854 seconds 120.76 fps ( 8.28 ms/f) 10.886 fps variability[/code]

dxlevel 690
[code]2639 frames 21.947 seconds 120.25 fps ( 8.32 ms/f) 11.446 fps variability
2639 frames 21.911 seconds 120.44 fps ( 8.30 ms/f) 10.762 fps variability
2639 frames 21.864 seconds 120.70 fps ( 8.29 ms/f) 10.461 fps variability
2639 frames 21.891 seconds 120.55 fps ( 8.30 ms/f) 10.939 fps variability[/code]

CPU: AMD FX-8350
GPU: NVIDIA GTX 960
365
#365
1 Frags +
Hoppsbenchmarks

What preset is this at? I'd like to see the performance with compquality, if you don't mind.

Also, I've released 4.2.2 which has some networking improvements. Tell me if you feel any difference.

EDIT: 4.2.3

[quote=Hopps]
benchmarks
[/quote]
What preset is this at? I'd like to see the performance with compquality, if you don't mind.

Also, I've released [url=https://github.com/mastercoms/tf2cfg/releases/tag/4.2.2]4.2.2[/url] which has some networking improvements. Tell me if you feel any difference.

EDIT: [url=https://github.com/mastercoms/tf2cfg/releases/tag/4.2.3]4.2.3[/url]
366
#366
3 Frags +

Really like the smoothness of this config (using comp, 4.2.3), I was surprised to see that maxquality doesn't enable antialiasing tho. It removes a lot of jagged lines improving visual clarity after all; with my GTX1070 sitting around doing nothing it seems that I was getting the exact same FPS through the tf2 benchmark file so I'm keeping that set to 8.

Really like the smoothness of this config (using comp, 4.2.3), I was surprised to see that maxquality doesn't enable antialiasing tho. It removes a lot of jagged lines improving visual clarity after all; with my GTX1070 sitting around doing nothing it seems that I was getting the exact same FPS through the tf2 benchmark file so I'm keeping that set to 8.
367
#367
4 Frags +

Hi,

Could you give details about what does mat_alphacoverage 0/1 cvar .

Default value is actually set to "1".

-I saw rhapsody cfg included and he set it up & commented it as :

"mat_alphacoverage 0 // Reduces shader complexity for some transparent materials."

*Assuming there is a fps increase with this.

-In the other side I Saw a guy who benchmarked it with it on/off and confirmed it actually decreased framerate a bit.
**Maybe cause his AA setting,that I mention later in this post.

So here my confusion , I tried myself to switch this cvar but cant see clearly the difference (at least not visually) and my testing fps benchs are not really trustable of info.

-I saw that an early version of your cfg contained this cvar to 0 , indicated for "potato" pcs but in later version this was removed.

Googling it , I found its related to Antialiasing , for ex. https://doc.qt.io/qt-5/qml-qt3d-render-alphacoverage.html ,
which says "AlphaCoverage does nothing if multisampling is disabled. Alpha-to-coverage is most useful when order independent blending is required, for example when rendering leaves, grass and other rich vegetation."

But since I cannot interpret the SRC , I landed on here , to clear my doubts

Hopefully you have an answer ,to whether to is related to AA or not and when to toggle it on or leave it .

Hi,

Could you give details about what does mat_alphacoverage 0/1 cvar .

Default value is actually set to "1".

-I saw rhapsody cfg included and he set it up & commented it as :

[i]"mat_alphacoverage 0 // Reduces shader complexity for some transparent materials."
[/i]
*Assuming there is a fps increase with this.


-In the other side I Saw a guy who benchmarked it with it on/off and confirmed it actually decreased framerate a bit.
**Maybe cause his AA setting,that I mention later in this post.

So here my confusion , I tried myself to switch this cvar but cant see clearly the difference (at least not visually) and my testing fps benchs are not really trustable of info.

-I saw that an early version of your cfg contained this cvar to 0 , indicated for "potato" pcs but in later version this was removed.

Googling it , I found its related to Antialiasing , for ex. https://doc.qt.io/qt-5/qml-qt3d-render-alphacoverage.html ,
which says "AlphaCoverage does nothing if multisampling is disabled. Alpha-to-coverage is most useful when order independent blending is required, for example when rendering leaves, grass and other rich vegetation."


But since I cannot interpret the SRC , I landed on here , to clear my doubts

Hopefully you have an answer ,to whether to is related to AA or not and when to toggle it on or leave it .
368
#368
1 Frags +
treetoonReally like the smoothness of this config (using comp, 4.2.3), I was surprised to see that maxquality doesn't enable antialiasing tho. It removes a lot of jagged lines improving visual clarity after all; with my GTX1070 sitting around doing nothing it seems that I was getting the exact same FPS through the tf2 benchmark file so I'm keeping that set to 8.

Glad you find it working well. Antialiasing missing is just an oversight. I'll update it soon to add this.

amazocmat_alphacoverage

It enables alpha to coverage, which is used to increase the quality of antialiasing for any overlapping thin objects like foliage, fences and grillwork.

It is run entirely on the GPU, so it will give you a small FPS increase when disabled, depending on your GPU.

Anyway, I actually forgot about this setting, so thanks for this. I'll be adding it to the config soon.

[quote=treetoon]Really like the smoothness of this config (using comp, 4.2.3), I was surprised to see that maxquality doesn't enable antialiasing tho. It removes a lot of jagged lines improving visual clarity after all; with my GTX1070 sitting around doing nothing it seems that I was getting the exact same FPS through the tf2 benchmark file so I'm keeping that set to 8.[/quote]
Glad you find it working well. Antialiasing missing is just an oversight. I'll update it soon to add this.

[quote=amazoc]
mat_alphacoverage
[/quote]

It enables alpha to coverage, which is used to increase the quality of antialiasing for any overlapping thin objects like foliage, fences and grillwork.

It is run entirely on the GPU, so it will give you a small FPS increase when disabled, depending on your GPU.

Anyway, I actually forgot about this setting, so thanks for this. I'll be adding it to the config soon.
369
#369
1 Frags +
mastercomsGlad you find it working well. Antialiasing missing is just an oversight. I'll update it soon to add this.

having mat_antialias [any value] executed on launch makes mumble overlay solid white

[quote=mastercoms]
Glad you find it working well. Antialiasing missing is just an oversight. I'll update it soon to add this.
[/quote]
having mat_antialias [any value] executed on launch makes mumble overlay solid white
370
#370
0 Frags +
deguhaving mat_antialias [any value] executed on launch makes mumble overlay solid white

Even 0? That's pretty strange. Do you have mat_aaquality set to a non-zero value?

EDIT: 4.2.4 released with better anti-aliasing controls and improved max quality settings for AA and texture filtering.

[quote=degu]
having mat_antialias [any value] executed on launch makes mumble overlay solid white[/quote]
Even 0? That's pretty strange. Do you have mat_aaquality set to a non-zero value?

EDIT: [url=https://github.com/mastercoms/tf2cfg/releases/tag/4.2.4]4.2.4[/url] released with better anti-aliasing controls and improved max quality settings for AA and texture filtering.
371
#371
0 Frags +

sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want?

also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reason

sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want?

also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reason
372
#372
1 Frags +
-Phantom-sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want?

pretty sure you just uncomment "exec maxperformance" at the end of comfig.cfg or put it into your autoexec :)

[quote=-Phantom-]sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want? [/quote]

pretty sure you just uncomment "exec maxperformance" at the end of comfig.cfg or put it into your autoexec :)
373
#373
2 Frags +
-Phantom-sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want?

zeSIMON is right, but make sure exec maxperformance is run after comfig. Do you have suggestions on how I can make this more clear?

-Phantom-also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reason

The mastercoms folder has its own cfg/autoexec.cfg file which overrides your existing autoexec. Delete autoexec.cfg in the mastercoms/cfg folder and add exec comfig to your own autoexec.

[quote=-Phantom-]sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want? [/quote]
zeSIMON is right, but make sure exec maxperformance is run after comfig. Do you have suggestions on how I can make this more clear?
[quote=-Phantom-]
also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reason
[/quote]
The mastercoms folder has its own cfg/autoexec.cfg file which overrides your existing autoexec. Delete autoexec.cfg in the mastercoms/cfg folder and add exec comfig to your own autoexec.
374
#374
1 Frags +
mastercomsmegaboyAlso, I have a problem that has to do with this config and joining other community servers that get stuck on parsing gaming info and never retrieves info from the server or getting any further into loading. Just stays there with 3 bars on parsing game info. Any suggestions on how to fix this?Is it just skial servers that have this issue, or all community servers? I've heard from some people it only happens on skial servers. I still don't have a clue what causes this, but you could try removing -reuse -usetcp from launch options. I'll try to look into it more. Does it happen when you do use -default, with no other launch options as well?

Sorry for late response, but no. When I use -default it let's me connect. But i'd rather not have that in my launch options as it resets everything. It's something within the config but I just can't figure it out. I really would like a solution to this if anyone has it. Or else i'll have to use comanglia's old config for skial severs which seems pretty unnecessary.

Edit: I've tracked down that it is something in the comfig file.

[quote=mastercoms][quote=megaboy]
Also, I have a problem that has to do with this config and joining other community servers that get stuck on parsing gaming info and never retrieves info from the server or getting any further into loading. Just stays there with 3 bars on parsing game info. Any suggestions on how to fix this?[/quote]
Is it just skial servers that have this issue, or all community servers? I've heard from some people it only happens on skial servers. I still don't have a clue what causes this, but you could try removing -reuse -usetcp from launch options. I'll try to look into it more. Does it happen when you do use -default, with no other launch options as well?[/quote]

Sorry for late response, but no. When I use -default it let's me connect. But i'd rather not have that in my launch options as it resets everything. It's something within the config but I just can't figure it out. I really would like a solution to this if anyone has it. Or else i'll have to use comanglia's old config for skial severs which seems pretty unnecessary.

Edit: I've tracked down that it is something in the comfig file.
375
#375
0 Frags +
mastercoms-Phantom-sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want? zeSIMON is right, but make sure exec maxperformance is run after comfig. Do you have suggestions on how I can make this more clear?-Phantom-also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reasonThe mastercoms folder has its own cfg/autoexec.cfg file which overrides your existing autoexec. Delete autoexec.cfg in the mastercoms/cfg folder and add exec comfig to your own autoexec.

I'm just confused why it comes in a custom folder. My understanding is that all I'm to do is put exec comfig in my autoexec, put exec comp inside comfig, then put all 3 inside my cfg folder. Should be done, right?

[quote=mastercoms][quote=-Phantom-]sorry for being stupid but how exactly do I install this for max performance? Am I supposed to go into the code and check every single comment for what I want and don't want? [/quote]
zeSIMON is right, but make sure exec maxperformance is run after comfig. Do you have suggestions on how I can make this more clear?
[quote=-Phantom-]
also not sure if someone mentioned this yet cause i haven't read the whole thread but putting the mastercom folder into my custom broke my null movement script for some reason
[/quote]
The mastercoms folder has its own cfg/autoexec.cfg file which overrides your existing autoexec. Delete autoexec.cfg in the mastercoms/cfg folder and add exec comfig to your own autoexec.[/quote]


I'm just confused why it comes in a custom folder. My understanding is that all I'm to do is put exec comfig in my autoexec, put exec comp inside comfig, then put all 3 inside my cfg folder. Should be done, right?
376
#376
5 Frags +
megaboySorry for late response, but no. When I use -default it let's me connect. But i'd rather not have that in my launch options as it resets everything. It's something within the config but I just can't figure it out. I really would like a solution to this if anyone has it. Or else i'll have to use comanglia's old config for skial severs which seems pretty unnecessary.

I was asking you to use -default to check if it was an issue from within the config, not as a permanent solution.

This should have been fixed since 4.1.7, by setting net_queued_packet_thread to 1, and then to 0 since 4.2.0. Have you updated?

-Phantom-I'm just confused why it comes in a custom folder. My understanding is that all I'm to do is put exec comfig in my autoexec, put exec comp inside comfig, then put all 3 inside my cfg folder. Should be done, right?

It is in the custom folder for easier management and updating of files and so it doesn't mess with people's files and possibly Steam Cloud Sync. You should be able to have exec comfig in your autoexec and then put the mastercoms folder in custom, and then delete the autoexec.cfg in the cfg folder in the mastercoms folder. But yes, it is possible but not recommended to manually copy the cfgs to your cfg folder.

EDIT: you'll also be missing out on file overrides in the custom folder for the texture preload list, as well as future changes to DirectX settings and shaders.

Also, I understand people might be more comfortable with Comanglia's config, so I've gone ahead and listed conservative changes to his config, along with explanations for the changes. These changes are very conservative and are not fully optimized. They also do not include new additional settings I've included in my config.

[quote=megaboy]
Sorry for late response, but no. When I use -default it let's me connect. But i'd rather not have that in my launch options as it resets everything. It's something within the config but I just can't figure it out. I really would like a solution to this if anyone has it. Or else i'll have to use comanglia's old config for skial severs which seems pretty unnecessary.
[/quote]
I was asking you to use -default to check if it was an issue from within the config, not as a permanent solution.

This should have been fixed since 4.1.7, by setting net_queued_packet_thread to 1, and then to 0 since 4.2.0. Have you updated?

[quote=-Phantom-]
I'm just confused why it comes in a custom folder. My understanding is that all I'm to do is put exec comfig in my autoexec, put exec comp inside comfig, then put all 3 inside my cfg folder. Should be done, right?
[/quote]
It is in the custom folder for easier management and updating of files and so it doesn't mess with people's files and possibly Steam Cloud Sync. You should be able to have exec comfig in your autoexec and then put the mastercoms folder in custom, and then delete the autoexec.cfg in the cfg folder in the mastercoms folder. But yes, it is possible but not recommended to manually copy the cfgs to your cfg folder.

EDIT: you'll also be missing out on file overrides in the custom folder for the texture preload list, as well as future changes to DirectX settings and shaders.

[quote][/quote]

Also, I understand people might be more comfortable with Comanglia's config, so I've gone ahead and [url=https://gist.github.com/mastercoms/f54f6476e0f2e4bdcf860ef902f1f93f]listed[/url] conservative changes to his config, along with explanations for the changes. These changes are very conservative and are not fully optimized. They also do not include new additional settings I've included in my config.
377
#377
10 Frags +

mastercoms is a fucking god wtf

mastercoms is a fucking god wtf
378
#378
-1 Frags +

hud_saytext_time 0 raised my fps by 11 (310 > 321) there is an element of rng to it in-game but it's something to consider.
and an additional +5 fps for r_drawviewmodel 0

hud_saytext_time 0 raised my fps by 11 (310 > 321) there is an element of rng to it in-game but it's something to consider.
and an additional +5 fps for r_drawviewmodel 0
379
#379
5 Frags +

HellO,
greatly appreciated and thankful for your thorough previous response,

I am still in debt with certain cvars values, in this case "mat_forcehardwaresync" which IIRC defaults at value "1".

I have seen the following scenarios (which may be not accurate per se):

-Value 0 does cause in some hw certain amount of input lag , specially in mice devices ,similar to vsync(commented below) or closely related , however I see a reversed situation there http://www.rage3d.com/Board/archive/index.php?t-33807316.html they affirm a value of 1 ,forcing vsync ,so does still confuse in layman terms.
-Its used only along mat_vsync 1 and mat_queue 2 (multicore),otherwise it can be the cause of screen tearing problems.
-Does sync hw when treading .
-In certain situations can cause graphical glitches or crashes,memory read exceptions , you can find documentation in steampowered dot com ,that in case of trouble they recommend setting this to '0' within the launch options of the specified game . -->https://support.steampowered.com/kb_article.php?ref=1274-uohk-5653 but doesnt give any in depth detail of it.

**I dont see actually anywhere in your cfg this cvar set on or off .

Would appreciate much ,If you could clear the confusion and doubt by explaining and detailing in which situations this can work best or how this is hw-dependant and so where to be cautious when setting up it.

Regards

HellO,
greatly appreciated and thankful for your thorough previous response,

I am still in debt with certain cvars values, in this case "[b]mat_forcehardwaresync[/b]" which IIRC defaults at value "1".

I have seen the following scenarios (which may be not accurate per se):

-Value 0 does cause in some hw certain amount of input lag , specially in mice devices ,similar to vsync(commented below) or closely related , however I see a reversed situation there http://www.rage3d.com/Board/archive/index.php?t-33807316.html they affirm a value of 1 ,forcing vsync ,so does still confuse in layman terms.
-Its used only along mat_vsync 1 and mat_queue 2 (multicore),otherwise it can be the cause of screen tearing problems.
-Does sync hw when treading .
-In certain situations can cause graphical glitches or crashes,memory read exceptions , you can find documentation in steampowered dot com ,that in case of trouble they recommend setting this to '0' within the launch options of the specified game . -->https://support.steampowered.com/kb_article.php?ref=1274-uohk-5653 but doesnt give any in depth detail of it.


**I dont see actually anywhere in your cfg this cvar set on or off .

Would appreciate much ,If you could clear the confusion and doubt by explaining and detailing in which situations this can work best or how this is hw-dependant and so where to be cautious when setting up it.

Regards
380
#380
2 Frags +
amazoc"mat_forcehardwaresync" which IIRC defaults at value "1"

On PCs, the ConVar default is 1, however, the value for PCs is defined by the dxsupport configuration, so depending on your dxlevel and hardware, the value may be 0 or 1 by default.

amazoc-Value 0 does cause in some hw certain amount of input lag , specially in mice devices ,similar to vsync(commented below) or closely related , however I see a reversed situation there http://www.rage3d.com/Board/archive/index.php?t-33807316.html they affirm a value of 1 ,forcing vsync ,so does still confuse in layman terms.

No, it is not VSync. Hardware sync waits per frame for the GPU to execute the commands in the command buffer and then stops waiting if the execution takes too long. Sure, it is some extra work and waiting, but it prevents the hardware from drifting behind too many frames from what the engine has requested. Most of the performance impact of hardware syncing depends on how poorly the driver behaves, not the extra work done from hardware syncing alone. And as you can imagine, this is partially accounted for in the dxsupport configuration per device.

amazoc-Its used only along mat_vsync 1 and mat_queue 2 (multicore),otherwise it can be the cause of screen tearing problems.
-Does sync hw when treading .

VSync isn't related to it, so mat_vsync doesn't affect HW sync. The material system queue modes 0 and 1 directly call it at the beginning of the frame, while mode 2 calls it in a queued call (for threading reasons).

amazoc-In certain situations can cause graphical glitches or crashes,memory read exceptions , you can find documentation in steampowered dot com ,that in case of trouble they recommend setting this to '0' within the launch options of the specified game . -->https://support.steampowered.com/kb_article.php?ref=1274-uohk-5653 but doesnt give any in depth detail of it.

This depends on your drivers and hardware, and only happens in specific rendering situations. These errors happen when the frame sync query object is lost and the driver isn't able to recover properly. (again mostly accounted for in the dxsupport configuration per device).

amazoc**I dont see actually anywhere in your cfg this cvar set on or off .

Would appreciate much ,If you could clear the confusion and doubt by explaining and detailing in which situations this can work best or how this is hw-dependant and so where to be cautious when setting up it.

I hope my explanations above were sufficient enough to come to the conclusion that configs and users probably have no business setting this convar themselves. It is best to trust what Source thinks is best for your hardware and only if you find it problematic, you should you change the value.

Good question, by the way.

[quote=amazoc]
"mat_forcehardwaresync" which IIRC defaults at value "1"
[/quote]
On PCs, the ConVar default is 1, however, the value for PCs is defined by the dxsupport configuration, so depending on your dxlevel and hardware, the value may be 0 or 1 by default.

[quote=amazoc]
-Value 0 does cause in some hw certain amount of input lag , specially in mice devices ,similar to vsync(commented below) or closely related , however I see a reversed situation there http://www.rage3d.com/Board/archive/index.php?t-33807316.html they affirm a value of 1 ,forcing vsync ,so does still confuse in layman terms.
[/quote]
No, it is not VSync. Hardware sync waits per frame for the GPU to execute the commands in the command buffer and then stops waiting if the execution takes too long. Sure, it is some extra work and waiting, but it prevents the hardware from drifting behind too many frames from what the engine has requested. Most of the performance impact of hardware syncing depends on how poorly the driver behaves, not the extra work done from hardware syncing alone. And as you can imagine, this is partially accounted for in the dxsupport configuration per device.

[quote=amazoc]
-Its used only along mat_vsync 1 and mat_queue 2 (multicore),otherwise it can be the cause of screen tearing problems.
-Does sync hw when treading .
[/quote]
VSync isn't related to it, so mat_vsync doesn't affect HW sync. The material system queue modes 0 and 1 directly call it at the beginning of the frame, while mode 2 calls it in a queued call (for threading reasons).

[quote=amazoc]
-In certain situations can cause graphical glitches or crashes,memory read exceptions , you can find documentation in steampowered dot com ,that in case of trouble they recommend setting this to '0' within the launch options of the specified game . -->https://support.steampowered.com/kb_article.php?ref=1274-uohk-5653 but doesnt give any in depth detail of it.
[/quote]
This depends on your drivers and hardware, and only happens in specific rendering situations. These errors happen when the frame sync query object is lost and the driver isn't able to recover properly. (again mostly accounted for in the dxsupport configuration per device).

[quote=amazoc]
**I dont see actually anywhere in your cfg this cvar set on or off .

Would appreciate much ,If you could clear the confusion and doubt by explaining and detailing in which situations this can work best or how this is hw-dependant and so where to be cautious when setting up it.
[/quote]
I hope my explanations above were sufficient enough to come to the conclusion that configs and users probably have no business setting this convar themselves. It is best to trust what Source thinks is best for your hardware and only if you find it problematic, you should you change the value.

Good question, by the way.
381
#381
0 Frags +

Hey I just installed the config today, went through the business in the readme with the cleanup, etc.

However, the console says that there a handful of unrecognized commands

Unknown command "gl_pow2_tempmem"
Unknown command "gl_batch_tex_creates"
Unknown command "gl_batch_tex_destroys"
Unknown command "gl_minimize_rt_tex"
Unknown command "gl_mtglflush_at_tof"
Unknown command "gl_debug_output"
Unknown command "gl_magnify_resolve_mode"
Unknown command "gl_paircache_rows_lg2"
Unknown command "gl_paircache_ways_lg2"

Should these be working or is something up

Hey I just installed the config today, went through the business in the readme with the cleanup, etc.

However, the console says that there a handful of unrecognized commands

[code]Unknown command "gl_pow2_tempmem"
Unknown command "gl_batch_tex_creates"
Unknown command "gl_batch_tex_destroys"
Unknown command "gl_minimize_rt_tex"
Unknown command "gl_mtglflush_at_tof"
Unknown command "gl_debug_output"
Unknown command "gl_magnify_resolve_mode"
Unknown command "gl_paircache_rows_lg2"
Unknown command "gl_paircache_ways_lg2"
[/code]

Should these be working or is something up
382
#382
6 Frags +

gl stuff is only for opengl (linux/mac), ignore it

gl stuff is only for opengl (linux/mac), ignore it
383
#383
2 Frags +

4.3.0 alpha 1

Has a few cool optimization updates, but the big thing is the dxlevel override. This will make installing my config in the custom folder mandatory if you want these DirectX optimizations that improve particle performance, with more to come in future releases, which will include shader optimizations and improvements to the texture preload list.

I would love for people to test and see if this prerelease makes a noticeable difference for them, thanks!

[url=https://github.com/mastercoms/tf2cfg/releases/tag/4.3.0a1]4.3.0 alpha 1[/url]

Has a few cool optimization updates, but the big thing is the dxlevel override. This will make installing my config in the custom folder [b]mandatory[/b] if you want these DirectX optimizations that improve particle performance, with more to come in future releases, which will include shader optimizations and improvements to the texture preload list.

I would love for people to test and see if this prerelease makes a noticeable difference for them, thanks!
384
#384
2 Frags +
mastercoms4.3.0 alpha 1

Has a few cool optimization updates, but the big thing is the dxlevel override. This will make installing my config in the custom folder mandatory if you want these DirectX optimizations that improve particle performance, with more to come in future releases, which will include shader optimizations and improvements to the texture preload list.

I would love for people to test and see if this prerelease makes a noticeable difference for them, thanks!

very weird but for some reason my game no longer mutes in the background, even though

snd_mute_losefocus 1

is set. know any changes that might have caused that? p sure it was working fine before i updated, my last version was some commit shortly after the lats 4.2 release

[quote=mastercoms][url=https://github.com/mastercoms/tf2cfg/releases/tag/4.3.0a1]4.3.0 alpha 1[/url]

Has a few cool optimization updates, but the big thing is the dxlevel override. This will make installing my config in the custom folder [b]mandatory[/b] if you want these DirectX optimizations that improve particle performance, with more to come in future releases, which will include shader optimizations and improvements to the texture preload list.

I would love for people to test and see if this prerelease makes a noticeable difference for them, thanks![/quote]

very weird but for some reason my game no longer mutes in the background, even though [code]snd_mute_losefocus 1[/code] is set. know any changes that might have caused that? p sure it was working fine before i updated, my last version was some commit shortly after the lats 4.2 release
385
#385
2 Frags +

You can fix the sound problem with the -primarysound -snoforceformat launch options. Using only -primarysound will cause it to always play the sound.

You can fix the sound problem with the -primarysound -snoforceformat launch options. Using only -primarysound will cause it to always play the sound.
386
#386
0 Frags +

awesome, thanks for investigating

awesome, thanks for investigating
387
#387
0 Frags +

Any way to improve felik's config ?

Also, once I installed your config, I've been getting some terrible fog everywhere.

Any way to improve felik's config ?

Also, once I installed your config, I've been getting some terrible fog everywhere.
388
#388
1 Frags +
GrinReaperAny way to improve felik's config ?

No

GrinReaperAlso, once I installed your config, I've been getting some terrible fog everywhere.

Preset? Launch options?

[quote=GrinReaper]Any way to improve felik's config ?[/quote]
No

[quote=GrinReaper]
Also, once I installed your config, I've been getting some terrible fog everywhere.[/quote]
Preset? Launch options?
389
#389
1 Frags +

Can you please explain for us non tech savvy how the prerelease improves particle performance?

Also for those of us who prefer dx8, are there any changes which we should be making?

Can you please explain for us non tech savvy how the prerelease improves particle performance?

Also for those of us who prefer dx8, are there any changes which we should be making?
390
#390
0 Frags +

One last thing, would you recommend the comp config for toasters? I think somewhere it mentioned this config being for average PCs and using this config on my toaster gave me less fps than comanglia's, though I'm only going off feeling; no official benchmarking.

One last thing, would you recommend the comp config for toasters? I think somewhere it mentioned this config being for average PCs and using this config on my toaster gave me less fps than comanglia's, though I'm only going off feeling; no official benchmarking.
1 ⋅⋅ 10 11 12 13 14 15 16 ⋅⋅ 63
Please sign in through STEAM to post a comment.