Upvote Upvoted 391 Downvote Downvoted
1 ⋅⋅ 37 38 39 40 41 42 43
rayshud
posted in Customization
1171
#1171
2 Frags +

just a headsup, 1280x960 isn't listed under resolutions in the installer.
good work on the update, mad props

also, trying to install with the minimal HUD setting enabled in the installer caused the installer to crash.

just a headsup, 1280x960 isn't listed under resolutions in the installer.
good work on the update, mad props

also, trying to install with the minimal HUD setting enabled in the installer caused the installer to crash.
1172
#1172
4 Frags +

The ingame Hud is not working for me. Main menu is using rayshud but when I join a game, it uses default HUD. I installed using the installer. Any suggestions?

EDIT: I fixed it by copying info.vdf from rayshud-master into just the rayshud folder

The ingame Hud is not working for me. Main menu is using rayshud but when I join a game, it uses default HUD. I installed using the installer. Any suggestions?

EDIT: I fixed it by copying info.vdf from rayshud-master into just the rayshud folder
1173
#1173
16 Frags +

Hey guys, I went ahead and made a quick hotfix to the installer. It won't address all crashing issues present already, but it should automatically include the info.vdf file upon installation, removing the need for the extra step of manually moving the info.vdf file from the direct download. If you were trying to use the installer prior and were having issues with the HUD appearing after installation, this should fix it.

You can download it here:

https://dl.dropboxusercontent.com/u/19762650/rayshud_installer_07122016.zip

Reminder that the installer requires a .NET framework of at least 4.0 to run properly. If the installer is giving you issues, check to make sure you have at least .Net 4.0.

I made this in a rush, so there's bound to be issues with it. If it doesn't work for whatever reason, please let me know.

Hey guys, I went ahead and made a quick hotfix to the installer. It won't address all crashing issues present already, but it should automatically include the info.vdf file upon installation, removing the need for the extra step of manually moving the info.vdf file from the direct download. If you were trying to use the installer prior and were having issues with the HUD appearing after installation, this should fix it.

You can download it here:

https://dl.dropboxusercontent.com/u/19762650/rayshud_installer_07122016.zip

Reminder that the installer requires a .NET framework of at least 4.0 to run properly. If the installer is giving you issues, check to make sure you have at least .Net 4.0.

I made this in a rush, so there's bound to be issues with it. If it doesn't work for whatever reason, please let me know.
1174
#1174
1 Frags +

First of all, ifly for constantly keeping your stuff updated. It's awesome to be able to rely on that! :D

Second, it looks like you forgot to put a Resume button on the escape menu. Not sure if that was intentional since you can accomplish the same thing with another escape.

First of all, ifly for constantly keeping your stuff updated. It's awesome to be able to rely on that! :D

Second, it looks like you forgot to put a Resume button on the escape menu. Not sure if that was intentional since you can accomplish the same thing with another escape.
1175
#1175
2 Frags +
DifferFirst of all, ifly for constantly keeping your stuff updated. It's awesome to be able to rely on that! :D

Second, it looks like you forgot to put a Resume button on the escape menu. Not sure if that was intentional since you can accomplish the same thing with another escape.

It should be below casual and competitive - If you can give me a screenshot of what you see, it'd help me out a lot though. Thanks! :D

[quote=Differ]First of all, ifly for constantly keeping your stuff updated. It's awesome to be able to rely on that! :D

Second, it looks like you forgot to put a Resume button on the escape menu. Not sure if that was intentional since you can accomplish the same thing with another escape.[/quote]

It should be below casual and competitive - If you can give me a screenshot of what you see, it'd help me out a lot though. Thanks! :D
1176
#1176
0 Frags +

Whoops... I guess I'm just blind. :0

Whoops... I guess I'm just blind. :0
1177
#1177
1 Frags +

For whatever reason my hud is broken. I have the installer and it has the version .0712 and it's set to the right resolution, but it turned out as some Frankenstein's monster of the default hud and rayshud.

For whatever reason my hud is broken. I have the installer and it has the version .0712 and it's set to the right resolution, but it turned out as some Frankenstein's monster of the default hud and rayshud.
1178
#1178
1 Frags +
leffendotzipFor whatever reason my hud is broken. I have the installer and it has the version .0712 and it's set to the right resolution, but it turned out as some Frankenstein's monster of the default hud and rayshud.

Can you verify that you have the info.vdf file in your tf/custom/rayshud folder?

[quote=leffendotzip]For whatever reason my hud is broken. I have the installer and it has the version .0712 and it's set to the right resolution, but it turned out as some Frankenstein's monster of the default hud and rayshud.[/quote]

Can you verify that you have the info.vdf file in your tf/custom/rayshud folder?
1179
#1179
0 Frags +

In my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. Help! (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )

In my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. [u]Help![/u] (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )
1180
#1180
-1 Frags +

Can someone tell me how to add a health cross bar next to a health ?

Can someone tell me how to add a health cross bar next to a health ?
1181
#1181
1 Frags +
DieKompetenteEnteIn my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. Help! (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )

Try this command

tf_hud_target_id_disable_floating_health 1

[quote=DieKompetenteEnte]In my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. [u]Help![/u] (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )[/quote]

Try this command

tf_hud_target_id_disable_floating_health 1
1182
#1182
2 Frags +
DreamerDieKompetenteEnteIn my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. Help! (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )
Try this command

tf_hud_target_id_disable_floating_health 1

You da real mvp <3

[quote=Dreamer][quote=DieKompetenteEnte]In my friend's and my rayshud the health of allies and enemies (spy) doesn't show up/ sometimes shortly shows up but then flies off when they move or i move and is generally offset, if it even shows up. [u]Help![/u] (picture of the health not showing http://steamcommunity.com/sharedfiles/filedetails/?id=726833837 )[/quote]

Try this command

tf_hud_target_id_disable_floating_health 1[/quote]

You da real mvp <3
1183
#1183
2 Frags +
CaDDyCan someone tell me how to add a health cross bar next to a health ?

custom > rayshud-master > resource > ui
In ui look for the file hudplayerhealth.res
There will be other versions of hudplayerhealth underneath: hudplayerhealth-teambar.res and hudplayerhealth-cross.res

Rename hudplayerhealth.res to hudplayerhealth_default.res or something so you can revert these changes later if you want to.
Now rename hudplayerhealth-cross.res to hudplayerhealth.res
Start TF2 (or do hud_reloadscheme in console if you already have TF2 open)

[quote=CaDDy]Can someone tell me how to add a health cross bar next to a health ?[/quote]
custom > rayshud-master > resource > ui
In ui look for the file hudplayerhealth.res
There will be other versions of hudplayerhealth underneath: hudplayerhealth-teambar.res and hudplayerhealth-cross.res

Rename hudplayerhealth.res to hudplayerhealth_default.res or something so you can revert these changes later if you want to.
Now rename hudplayerhealth-cross.res to hudplayerhealth.res
Start TF2 (or do hud_reloadscheme in console if you already have TF2 open)
1184
#1184
5 Frags +

Running a fresh install of the latest version of Rayshud, when I aim at teammates their health number flickers constantly. Not sure if it's related to the HUD or something with my settings

Running a fresh install of the latest version of Rayshud, when I aim at teammates their health number flickers constantly. Not sure if it's related to the HUD or something with my settings
1185
#1185
-1 Frags +

^

^
1186
#1186
-1 Frags +
lootRunning a fresh install of the latest version of Rayshud, when I aim at teammates their health number flickers constantly. Not sure if it's related to the HUD or something with my settings

Same here.

[quote=loot]Running a fresh install of the latest version of Rayshud, when I aim at teammates their health number flickers constantly. Not sure if it's related to the HUD or something with my settings[/quote]
Same here.
1187
#1187
1 Frags +

My scoreboard always starts in 6v6 mode. How do I get it to start in 16v16? Thanks.

My scoreboard always starts in 6v6 mode. How do I get it to start in 16v16? Thanks.
1188
#1188
1 Frags +
brownbagsupriseMy scoreboard always starts in 6v6 mode. How do I get it to start in 16v16? Thanks.

hud_minmode 0 in autoexec

[quote=brownbagsuprise]My scoreboard always starts in 6v6 mode. How do I get it to start in 16v16? Thanks.[/quote]

hud_minmode 0 in autoexec
1189
#1189
-2 Frags +

Uhh.. I think I found a bug. http://steamcommunity.com/id/supaswag/screenshot/260467680385180492

Uhh.. I think I found a bug. http://steamcommunity.com/id/supaswag/screenshot/260467680385180492
1190
#1190
0 Frags +

Is the flicking health bar still not fixed yet?

Is the flicking health bar still not fixed yet?
1191
#1191
0 Frags +

could you fix the font size difference for 10.. 9.. 8.. countdown in the close door animation? when the countdown is in the center. the font size difference only affects 10, 9 and 8.

could you fix the font size difference for 10.. 9.. 8.. countdown in the close door animation? when the countdown is in the center. the font size difference only affects 10, 9 and 8.
1192
#1192
-1 Frags +

I recently downloaded rayshud to give it a go and I really like it, I was just looking through the hudlayout text file and wanted to have a crosshair where its the basiccrosssmall and a thin circle around it.
I enable both the crosshairs basiccrosssmall and xHaircircle
But for some reason when I boot up my game and load up a offline server I dont see that the thin circle isn't thin, its a thick transparent circle.
Any help would be appreciated.

Thanks Crypt

I recently downloaded rayshud to give it a go and I really like it, I was just looking through the hudlayout text file and wanted to have a crosshair where its the basiccrosssmall and a thin circle around it.
I enable both the crosshairs basiccrosssmall and xHaircircle
But for some reason when I boot up my game and load up a offline server I dont see that the thin circle isn't thin, its a thick transparent circle.
Any help would be appreciated.

Thanks Crypt
1193
#1193
-3 Frags +

Apparently a bug, a while after freshly installing rayshud (via installer) some weapon models seem to completely disappear or seem to have a different color scheme (the latter seems to be rare) after starting the game again. I could not find out why, I only know that it happened like over 10 times in like a month now.

Example of missing rocket launchers (in third person, first person and also on different players
http://images.akamai.steamusercontent.com/ugc/436111076095639417/F124F4E4ED22DDAAD73DAE89B6C7F28F4ED9B0E9/ - loadout screen
http://images.akamai.steamusercontent.com/ugc/436111076095641165/F97FE6DB9E0E17701F9DE3D0884E46F05C571B28/ - first person, normal viewmodel
http://images.akamai.steamusercontent.com/ugc/436111076095642808/E986826706B99A6506A4D1F9D0E8CBC76C53FCFA/ - first person, min viewmodel
http://images.akamai.steamusercontent.com/ugc/436111076095644707/FC9DC707162D4BCB8F1069C66DBA1F4822717BBD/ - world player models not having rocket launchers either (other classes do)

A fresh install fixes it, but it comes back after a while. Does not happen with the default HUD nor other HUDs from my experience.

UPDATE: Neither a fresh install of the hud nor a fresh installer does the job anymore. Rip.

Apparently a bug, a while after freshly installing rayshud (via installer) some weapon models seem to completely disappear or seem to have a different color scheme (the latter seems to be rare) after starting the game again. I could not find out why, I only know that it happened like over 10 times in like a month now.

[u]Example of missing rocket launchers (in third person, first person and also on different players[/u]
http://images.akamai.steamusercontent.com/ugc/436111076095639417/F124F4E4ED22DDAAD73DAE89B6C7F28F4ED9B0E9/ - loadout screen
http://images.akamai.steamusercontent.com/ugc/436111076095641165/F97FE6DB9E0E17701F9DE3D0884E46F05C571B28/ - first person, normal viewmodel
http://images.akamai.steamusercontent.com/ugc/436111076095642808/E986826706B99A6506A4D1F9D0E8CBC76C53FCFA/ - first person, min viewmodel
http://images.akamai.steamusercontent.com/ugc/436111076095644707/FC9DC707162D4BCB8F1069C66DBA1F4822717BBD/ - world player models not having rocket launchers either (other classes do)

A fresh install fixes it, but it comes back after a while. Does not happen with the default HUD nor other HUDs from my experience.

UPDATE: Neither a fresh install of the hud nor a fresh installer does the job anymore. Rip.
1194
#1194
9 Frags +

My HUD does not mess with weapon models at all.

If you're having issues with them, I'd recommend you take a look at your config and/or custom weapon skins you may have had added. The fact that you say it happens on only my HUD and no other HUD is most likely placebo. All my HUD does is modify the in-game HUD files, and all the installer does is customize those files to give a more personalized user experience.

My HUD does not mess with weapon models at all.

If you're having issues with them, I'd recommend you take a look at your config and/or custom weapon skins you may have had added. The fact that you say it happens on only my HUD and no other HUD is most likely placebo. All my HUD does is modify the in-game HUD files, and all the installer does is customize those files to give a more personalized user experience.
1195
#1195
-1 Frags +

My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?

My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?
1196
#1196
0 Frags +
-Top_O_The_Morning-My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?

The scoreboard shows 6 players per team in minmode. You can toggle it in advanced options in game or via cl_hud_minmode console command.

The size of the hud crosshairs is determined by the font. If you look at the scripts/hudlayout.res file and find the crosshair you're using, you'll see a "font" property. That property is the font defined in resource/clientscheme.res. You could just duplicate that font's entry and change the "tall" property of the entry, or you could just modify the one that's there. Whatever you do though, make sure the crosshair entry in hudlayout.res is using the correct font.

[quote=-Top_O_The_Morning-]My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?[/quote]

The scoreboard shows 6 players per team in minmode. You can toggle it in advanced options in game or via cl_hud_minmode console command.

The size of the hud crosshairs is determined by the font. If you look at the scripts/hudlayout.res file and find the crosshair you're using, you'll see a "font" property. That property is the font defined in resource/clientscheme.res. You could just duplicate that font's entry and change the "tall" property of the entry, or you could just modify the one that's there. Whatever you do though, make sure the crosshair entry in hudlayout.res is using the correct font.
1197
#1197
-5 Frags +

Whenever I actually start up TF2, Rayshud will not look like what it is, it just keeps the stock hud showing.

(Forget this comment, I've managed to find out what it was.)

[b]Whenever I actually start up TF2, Rayshud will not look like what it is, it just keeps the stock hud showing.[/b]

(Forget this comment, I've managed to find out what it was.)
1198
#1198
-1 Frags +
Enderp-Top_O_The_Morning-My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?
The scoreboard shows 6 players per team in minmode. You can toggle it in advanced options in game or via cl_hud_minmode console command.

The size of the hud crosshairs is determined by the font. If you look at the scripts/hudlayout.res file and find the crosshair you're using, you'll see a "font" property. That property is the font defined in resource/clientscheme.res. You could just duplicate that font's entry and change the "tall" property of the entry, or you could just modify the one that's there. Whatever you do though, make sure the crosshair entry in hudlayout.res is using the correct font.

Thanks man, I really appreciate it!

[quote=Enderp][quote=-Top_O_The_Morning-]My scoreboard only shows 6 people, how do I enable one that will show all of the players currently on the server? Also, is there a way to change the size of a crosshair?[/quote]

The scoreboard shows 6 players per team in minmode. You can toggle it in advanced options in game or via cl_hud_minmode console command.

The size of the hud crosshairs is determined by the font. If you look at the scripts/hudlayout.res file and find the crosshair you're using, you'll see a "font" property. That property is the font defined in resource/clientscheme.res. You could just duplicate that font's entry and change the "tall" property of the entry, or you could just modify the one that's there. Whatever you do though, make sure the crosshair entry in hudlayout.res is using the correct font.[/quote]
Thanks man, I really appreciate it!
1199
#1199
-3 Frags +
raysMy HUD does not mess with weapon models at all.

If you're having issues with them, I'd recommend you take a look at your config and/or custom weapon skins you may have had added. The fact that you say it happens on only my HUD and no other HUD is most likely placebo. All my HUD does is modify the in-game HUD files, and all the installer does is customize those files to give a more personalized user experience.

As much as I would love to believe it being placebo, it literally never happened outside of your HUD. I have never used any custom weapon skins ever since I started playing TF2 (around 3 1/2 years now) and all my config does is changing network settings, crosshair options and mostly sound related things. The only thing that affects the viewmodel is the viewmodel changer that I have been using for around 3 years that only plays around with the r_drawviewmodel 1/0 command, minus that I have nothing customized. Although this bug did not happen all the time, it only started happening around the MYM update I believe.

I tested it with default HUD, improved default HUD, e.v.e. HUD, OW HUD and m0re HUD. None of these have these issues besides your HUD for me.

[quote=rays]My HUD does not mess with weapon models at all.

If you're having issues with them, I'd recommend you take a look at your config and/or custom weapon skins you may have had added. The fact that you say it happens on only my HUD and no other HUD is most likely placebo. All my HUD does is modify the in-game HUD files, and all the installer does is customize those files to give a more personalized user experience.[/quote]
As much as I would love to believe it being placebo, it literally never happened outside of your HUD. I have never used any custom weapon skins ever since I started playing TF2 (around 3 1/2 years now) and all my config does is changing network settings, crosshair options and mostly sound related things. The only thing that affects the viewmodel is the viewmodel changer that I have been using for around 3 years that only plays around with the r_drawviewmodel 1/0 command, minus that I have nothing customized. Although this bug did not happen all the time, it only started happening around the MYM update I believe.

I tested it with default HUD, improved default HUD, e.v.e. HUD, OW HUD and m0re HUD. None of these have these issues besides your HUD for me.
1200
#1200
5 Frags +

Not sure if it's a HUD issue or not but I can't rate the games after a casual match. I can select the rating but the submission button doesn't work.

Not sure if it's a HUD issue or not but I can't rate the games after a casual match. I can select the rating but the submission button doesn't work.
1 ⋅⋅ 37 38 39 40 41 42 43
Please sign in through STEAM to post a comment.