Upvote Upvoted 265 Downvote Downvoted
1 ⋅⋅ 63 64 65 66 67
mastercomfig - fps/customization config
posted in Customization
1951
#1951
0 Frags +

Don't know if this is relevant, but I've messed around with the launch option: -r_emulate_gl and my game seems to render particles way faster than if it were to not have the option in the first place. I don't quite know everything about the command, but it seems to (not fully sure) render particles in a way that makes it seem as if its rendering on a different part of TF2 itself, but still rendering them nonetheless, it seems to speed up alt-tabbing between programs under fullscreen (depending on window scaling, for example using the same window size as your monitor makes alt-tabbing a breeze), and some HUD elements seem to render slightly better (in terms of performance and quality).

Again, I haven't tested everything but it seems to help DirectX run the base game (models, the world, and some HUD elements) normally and then let OpenGL render the rest.

Don't know if this is relevant, but I've messed around with the launch option: -r_emulate_gl and my game seems to render particles way faster than if it were to not have the option in the first place. I don't quite know everything about the command, but it seems to (not fully sure) render particles in a way that makes it seem as if its rendering on a different part of TF2 itself, but still rendering them nonetheless, it seems to speed up alt-tabbing between programs under fullscreen (depending on window scaling, for example using the same window size as your monitor makes alt-tabbing a breeze), and some HUD elements seem to render slightly better (in terms of performance and quality).

Again, I haven't tested everything but it seems to help DirectX run the base game (models, the world, and some HUD elements) normally and then let OpenGL render the rest.
1952
#1952
0 Frags +

Just to clarify, -r_emulate_gl still uses DirectX. It just uses the OpenGL code pathways/workarounds for their DirectX compatibility layer.

Just to clarify, -r_emulate_gl still uses DirectX. It just uses the OpenGL code pathways/workarounds for their DirectX compatibility layer.
1953
#1953
0 Frags +

Looking for help,
Tried to install the config several times, always fucks up my controls and other binds(null movement, crouchjump, and basic tf2 controls like walkin forward).
I have several files where i store binds and class specific binds individually.
Other fps configs like chris dx8 and comingla's never caused any problems.
Is there something im missing? Does anyone has this problem or a fix for it?

Looking for help,
Tried to install the config several times, always fucks up my controls and other binds(null movement, crouchjump, and basic tf2 controls like walkin forward).
I have several files where i store binds and class specific binds individually.
Other fps configs like chris dx8 and comingla's never caused any problems.
Is there something im missing? Does anyone has this problem or a fix for it?
1954
#1954
1 Frags +
rahkshiLooking for help,
Tried to install the config several times, always fucks up my controls and other binds(null movement, crouchjump, and basic tf2 controls like walkin forward).
I have several files where i store binds and class specific binds individually.
Other fps configs like chris dx8 and comingla's never caused any problems.
Is there something im missing? Does anyone has this problem or a fix for it?

mastercom wrote all this nice documentation you should give it a look

https://docs.mastercomfig.com/en/latest/customization/custom_configs/

you should also just clean your tf folder if you keep experiencing issues

[quote=rahkshi]Looking for help,
Tried to install the config several times, always fucks up my controls and other binds(null movement, crouchjump, and basic tf2 controls like walkin forward).
I have several files where i store binds and class specific binds individually.
Other fps configs like chris dx8 and comingla's never caused any problems.
Is there something im missing? Does anyone has this problem or a fix for it?[/quote]

mastercom wrote all this nice documentation you should give it a look

https://docs.mastercomfig.com/en/latest/customization/custom_configs/

you should also just clean your tf folder if you keep experiencing issues
1955
#1955
1 Frags +

Has anyone made a non vpk version?

Has anyone made a non vpk version?
1956
#1956
0 Frags +
hi_Has anyone made a non vpk version?

unpack the VPK with Crowbar

[quote=hi_]Has anyone made a non vpk version?[/quote]
unpack the VPK with [url=https://github.com/ZeqMacaw/Crowbar/releases/tag/v0.64]Crowbar[/url]
1957
#1957
0 Frags +

Is there anything in this config that could be the reason why I can't record stv in a private server?

Is there anything in this config that could be the reason why I can't record stv in a private server?
1958
#1958
0 Frags +

that's tv_enable 1, pretty sure it's somewhere set to 0

that's tv_enable 1, pretty sure it's somewhere set to 0
1959
#1959
4 Frags +
Tobhi_Has anyone made a non vpk version?unpack the VPK with Crowbar

You don't need Crowbar to unpack it, just use GFCScape

[quote=Tob][quote=hi_]Has anyone made a non vpk version?[/quote]
unpack the VPK with [url=https://github.com/ZeqMacaw/Crowbar/releases/tag/v0.64]Crowbar[/url][/quote]
You don't need Crowbar to unpack it, just use [url=http://nemesis.thewavelength.net/?p=26]GFCScape[/url]
1960
#1960
0 Frags +
Rockzthat's tv_enable 1, pretty sure it's somewhere set to 0

No, I set tv_enable to 1, join a server and when I try to record it says sourcetv not active

[quote=Rockz]that's tv_enable 1, pretty sure it's somewhere set to 0[/quote]
No, I set tv_enable to 1, join a server and when I try to record it says sourcetv not active
1961
#1961
0 Frags +

you re-join the server after you set it to 1

you re-join the server after you set it to 1
1962
#1962
0 Frags +

I'm getting a black texture or lightning problem on the unofficial map "trade_plaza_2" and all other "trade_plaza" based maps that use that same object or texture of a target. I'm using the latest gfxc.cfg of Comanglia with very few changes.

Here is a screenshot of what I'm talking about:

https://i.postimg.cc/T2kJNGjP/20200118072327-1.jpg

I would really appreciate it if anyone can check on a community server that's using this map and see if they also get a black texture there.

I have no clue what cvar could be causing this, actually I tried changing a hand-full already without success including mat_mipmaptextures 0 and mat_phong 1 which seemed like it was the issue for some other people seeing black textures or whatever this is. All my weapons appear to be normal so I don't think I'm having the same issue as the other people I've found.

I'm sure it's gfxc.cfg because before installing Comanglia, the textures were present on the maps. It would just take forever for me to go through every single cvar to figure out which one is causing it though. I'd really appreciate some help if anyone has a clue.

Edit: After testing using the -default launch option, it appears that the "shoot targets" things that look black was not a "black texture" problem, the base object itself is black, so the problem is actually that the surface texture or image or whatever it is of those targets don't load for some reason when I have the gfxc.cfg cvars set.

I'm getting a black texture or lightning problem on the unofficial map "trade_plaza_2" and all other "trade_plaza" based maps that use that same object or texture of a target. I'm using the latest gfxc.cfg of Comanglia with very few changes.

Here is a screenshot of what I'm talking about:

https://i.postimg.cc/T2kJNGjP/20200118072327-1.jpg

I would really appreciate it if anyone can check on a community server that's using this map and see if they also get a black texture there.

I have no clue what cvar could be causing this, actually I tried changing a hand-full already without success including mat_mipmaptextures 0 and mat_phong 1 which seemed like it was the issue for some other people seeing black textures or whatever this is. All my weapons appear to be normal so I don't think I'm having the same issue as the other people I've found.

I'm sure it's gfxc.cfg because before installing Comanglia, the textures were present on the maps. It would just take forever for me to go through every single cvar to figure out which one is causing it though. I'd really appreciate some help if anyone has a clue.

Edit: [b]After testing using the -default launch option, it appears that the "shoot targets" things that look black was not a "black texture" problem, the base object itself is black, so the problem is actually that the surface texture or image or whatever it is of those targets don't load for some reason when I have the gfxc.cfg cvars set.[/b]
1963
#1963
0 Frags +
Rockzyou re-join the server after you set it to 1

yeah, doesn't work

[quote=Rockz]you re-join the server after you set it to 1[/quote]
yeah, doesn't work
1964
#1964
0 Frags +
QLI'm getting a black texture or lightning problem on the unofficial map "trade_plaza_2" and all other "trade_plaza" based maps that use that same object or texture of a target. I'm using the latest gfxc.cfg of Comanglia with very few changes.

Here is a screenshot of what I'm talking about:

https://i.postimg.cc/T2kJNGjP/20200118072327-1.jpg

I would really appreciate it if anyone can check on a community server that's using this map and see if they also get a black texture there.

I have no clue what cvar could be causing this, actually I tried changing a hand-full already without success including mat_mipmaptextures 0 and mat_phong 1 which seemed like it was the issue for some other people seeing black textures or whatever this is. All my weapons appear to be normal so I don't think I'm having the same issue as the other people I've found.

I'm sure it's gfxc.cfg because before installing Comanglia, the textures were present on the maps. It would just take forever for me to go through every single cvar to figure out which one is causing it though. I'd really appreciate some help if anyone has a clue.

Actually, if it's allowed by the forums, this request now has a bounty of 5 keys to whoever helps me solve this issue. I already dedicated over 8 hours to trying to get my config right after starting to play again, so yeah..

I believe the fix was to put in mat_antialias 1 or mat_trilinear 1 or both. I was having those issues before to until I fooled around with some settings

[quote=QL]I'm getting a black texture or lightning problem on the unofficial map "trade_plaza_2" and all other "trade_plaza" based maps that use that same object or texture of a target. I'm using the latest gfxc.cfg of Comanglia with very few changes.

Here is a screenshot of what I'm talking about:

https://i.postimg.cc/T2kJNGjP/20200118072327-1.jpg

I would really appreciate it if anyone can check on a community server that's using this map and see if they also get a black texture there.

I have no clue what cvar could be causing this, actually I tried changing a hand-full already without success including mat_mipmaptextures 0 and mat_phong 1 which seemed like it was the issue for some other people seeing black textures or whatever this is. All my weapons appear to be normal so I don't think I'm having the same issue as the other people I've found.

I'm sure it's gfxc.cfg because before installing Comanglia, the textures were present on the maps. It would just take forever for me to go through every single cvar to figure out which one is causing it though. I'd really appreciate some help if anyone has a clue.

Actually, if it's allowed by the forums, this request now has a bounty of 5 keys to whoever helps me solve this issue. I already dedicated over 8 hours to trying to get my config right after starting to play again, so yeah..[/quote]

I believe the fix was to put in mat_antialias 1 or mat_trilinear 1 or both. I was having those issues before to until I fooled around with some settings
1965
#1965
0 Frags +
syphRockzyou re-join the server after you set it to 1yeah, doesn't work

Do you have -nohltv in launch options?

[quote=syph][quote=Rockz]you re-join the server after you set it to 1[/quote]
yeah, doesn't work[/quote]

Do you have -nohltv in launch options?
1966
#1966
1 Frags +
WizardI believe the fix was to put in mat_antialias 1 or mat_trilinear 1 or both. I was having those issues before to until I fooled around with some settings

Thanks for the suggestion. I had mat_trilinear on 1 already and putting mat_antialias on 1 also didn't solve the issue. Honestly, it's very strange.

Would setting -default as a launch option allow me to temporarily double-check that it's indeed one of the cfgs that's causing the issue without effecting any of my already set game settings or cfg files?

Edit: After testing using the -default launch option, it appears that the "shoot targets" things that look black was not a "black texture" problem, the base object itself is black, so the problem is actually that the surface texture or image or whatever it is of those targets don't load for some reason when I have the gfxc.cfg cvars set.

[quote=Wizard]I believe the fix was to put in mat_antialias 1 or mat_trilinear 1 or both. I was having those issues before to until I fooled around with some settings[/quote]

Thanks for the suggestion. I had mat_trilinear on 1 already and putting mat_antialias on 1 also didn't solve the issue. Honestly, it's very strange.

Would setting -default as a launch option allow me to temporarily double-check that it's indeed one of the cfgs that's causing the issue without effecting any of my already set game settings or cfg files?

Edit: [b]After testing using the -default launch option, it appears that the "shoot targets" things that look black was not a "black texture" problem, the base object itself is black, so the problem is actually that the surface texture or image or whatever it is of those targets don't load for some reason when I have the gfxc.cfg cvars set.[/b]
1967
#1967
1 Frags +

I figured out the issue by going through the whole cfg bit by bit setting every cvar to its opposite value, turns out the "texture" of the target-things are considered a overlayfragment or decal-based thing by the game.

So setting r_renderoverlayfragment from 0 to 1, fixed the issue and now those "textures" are rendering again.

I figured out the issue by going through the whole cfg bit by bit setting every cvar to its opposite value, turns out the "texture" of the target-things are considered a overlayfragment or decal-based thing by the game.

So setting r_renderoverlayfragment from 0 to 1, fixed the issue and now those "textures" are rendering again.
1968
#1968
0 Frags +
QLI figured out the issue by going through the whole cfg bit by bit setting every cvar to its opposite value, turns out the "texture" of the target-things are considered a overlayfragment or decal-based thing by the game.

So setting r_renderoverlayfragment from 0 to 1, fixed the issue and now those "textures" are rendering again.

That's nice. I forgot about that command.

[quote=QL]I figured out the issue by going through the whole cfg bit by bit setting every cvar to its opposite value, turns out the "texture" of the target-things are considered a overlayfragment or decal-based thing by the game.

So setting r_renderoverlayfragment from 0 to 1, fixed the issue and now those "textures" are rendering again.[/quote]
That's nice. I forgot about that command.
1969
#1969
0 Frags +
hi_Has anyone made a non vpk version?

Can you let me know what you want from a non VPK version?

EDIT: Letting me know about your needs helps me better serve them, including adding new options to download and use mastercomfig. Instead of downfragging a simple question for seemingly no reason, I'd really like an answer. Thanks.

[quote=hi_]Has anyone made a non vpk version?[/quote]
Can you let me know what you want from a non VPK version?

EDIT: Letting me know about your needs helps me better serve them, including adding new options to download and use mastercomfig. Instead of downfragging a simple question for seemingly no reason, I'd really like an answer. Thanks.
1970
#1970
12 Frags +

8.3.0 released with usability enhancements, bug fixes and performance improvements. (and yes, it includes a non-VPK version for those don't want to move over for god knows why) One thing I want to stress is that people seem to just ask for stuff without saying why, and that means I have to guess as to how to best serve not only them but all mastercomfig users. If you make a suggestion and say what caused you to make that suggestion, I'm going to be able to actually address the problem better.

Changelog
Support me

This release took 12 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]8.3.0[/url] released with usability enhancements, bug fixes and performance improvements. (and yes, it includes a non-VPK version for those don't want to move over for god knows why) One thing I want to stress is that people seem to just ask for stuff without saying why, and that means I have to guess as to how to best serve not only them but all mastercomfig users. If you make a suggestion and say what caused you to make that suggestion, I'm going to be able to actually address the problem better.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.0]Changelog[/url]
[url=https://docs.mastercomfig.com/en/latest/support_me/]Support me[/url]

This release took 12 hours to produce. If you like the work I do, consider supporting me!
1971
#1971
2 Frags +
mastercoms8.3.0 released with usability enhancements, bug fixes and performance improvements. (and yes, it includes a non-VPK version for those don't want to move over for god knows why) One thing I want to stress is that people seem to just ask for stuff without saying why, and that means I have to guess as to how to best serve not only them but all mastercomfig users. If you make a suggestion and say what caused you to make that suggestion, I'm going to be able to actually address the problem better.

Changelog
Support me

This release took 12 hours to produce. If you like the work I do, consider supporting me!

thanks for updating and working on this as much as you do

[quote=mastercoms][url=https://mastercomfig.com/download]8.3.0[/url] released with usability enhancements, bug fixes and performance improvements. (and yes, it includes a non-VPK version for those don't want to move over for god knows why) One thing I want to stress is that people seem to just ask for stuff without saying why, and that means I have to guess as to how to best serve not only them but all mastercomfig users. If you make a suggestion and say what caused you to make that suggestion, I'm going to be able to actually address the problem better.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.0]Changelog[/url]
[url=https://docs.mastercomfig.com/en/latest/support_me/]Support me[/url]

This release took 12 hours to produce. If you like the work I do, consider supporting me![/quote]
thanks for updating and working on this as much as you do
1972
#1972
0 Frags +
hushsyphRockzyou re-join the server after you set it to 1yeah, doesn't work
Do you have -nohltv in launch options?

that was it thank you

[quote=hush][quote=syph][quote=Rockz]you re-join the server after you set it to 1[/quote]
yeah, doesn't work[/quote]

Do you have -nohltv in launch options?[/quote]
that was it thank you
1973
#1973
3 Frags +

8.3.1 released with bug fixes and updates to the localization files.

Changelog
Support me

This release took 2 hours to produce. If you like the work I do, consider supporting me!

harlowngthanks for updating and working on this as much as you do

<3 thanks!

[url=https://mastercomfig.com/download]8.3.1[/url] released with bug fixes and updates to the localization files.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.1]Changelog[/url]
[url=https://docs.mastercomfig.com/en/stable/support_me/]Support me[/url]

This release took 2 hours to produce. If you like the work I do, consider supporting me!

[quote=harlowng]thanks for updating and working on this as much as you do[/quote]
<3 thanks!
1974
#1974
5 Frags +

8.3.2 released with bug fixes and updates to the localization files.

Changelog
Support me

This release took 3 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]8.3.2[/url] released with bug fixes and updates to the localization files.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.2]Changelog[/url]
[url=https://docs.mastercomfig.com/en/stable/support_me/]Support me[/url]

This release took 3 hours to produce. If you like the work I do, consider supporting me!
1975
#1975
0 Frags +

Does DirectX 8 support mat_queue_mode 2 or multicore/quadcore in general?

Does DirectX 8 support mat_queue_mode 2 or multicore/quadcore in general?
1976
#1976
0 Frags +
sAvenDoes DirectX 8 support mat_queue_mode 2 or multicore/quadcore in general?

I believe so

[quote=sAven]Does DirectX 8 support mat_queue_mode 2 or multicore/quadcore in general?[/quote]
I believe so
1977
#1977
5 Frags +

8.3.3 released with performance improvements and experimental hitreg improvements.

Changelog
Support me

This release took 8 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]8.3.3[/url] released with performance improvements and experimental hitreg improvements.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.3]Changelog[/url]
[url=https://docs.mastercomfig.com/en/stable/support_me/]Support me[/url]

This release took 8 hours to produce. If you like the work I do, consider supporting me!
1978
#1978
7 Frags +

8.3.4 released with performance improvements, hitreg enhancements and bug fixes.

Changelog
Support me

This release took 6 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]8.3.4[/url] released with performance improvements, hitreg enhancements and bug fixes.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.4]Changelog[/url]
[url=https://docs.mastercomfig.com/en/stable/support_me/]Support me[/url]

This release took 6 hours to produce. If you like the work I do, consider supporting me!
1979
#1979
6 Frags +

8.3.5 released with performance improvements, hitreg enhancements and bug fixes.

Changelog
Support me

This release took 5 hours to produce. If you like the work I do, consider supporting me!

[url=https://mastercomfig.com/download]8.3.5[/url] released with performance improvements, hitreg enhancements and bug fixes.

[url=https://github.com/mastercoms/mastercomfig/releases/tag/8.3.5]Changelog[/url]
[url=https://docs.mastercomfig.com/en/stable/support_me/]Support me[/url]

This release took 5 hours to produce. If you like the work I do, consider supporting me!
1980
#1980
0 Frags +

Is the zoom_sensitivity_ratio in the flat mouse addon affected by aspect ratio, m_yaw, or both?

Is the zoom_sensitivity_ratio in the flat mouse addon affected by aspect ratio, m_yaw, or both?
1 ⋅⋅ 63 64 65 66 67
Please sign in through STEAM to post a comment.