Upvote Upvoted 250 Downvote Downvoted
1 ⋅⋅ 22 23 24 25 26 27 28 ⋅⋅ 61
mastercomfig - fps/customization config
posted in Customization
721
#721
1 Frags +
mastercomsThat's pretty much the config (excluding the igpu addon) unless you're talking about very weak CPUs, which the stripped addon already provides some CVars you can try.

Allright

[quote=mastercoms]
That's pretty much the config (excluding the igpu addon) unless you're talking about very weak CPUs, which the stripped addon already provides some CVars you can try.[/quote]

Allright
722
#722
-1 Frags +
MalkrazmastercomsTry -nouserclip
Seems to have made a minor improvement but I'm still dipping pretty hard in the problem areas. It's more like 95-110 now instead of 80-90 down from 280+ on spawn.

There's something fundamentally wrong with your setup. Your CPU and GPU are excellent and such dips should never occur. I'd start by taking a look into UEFI to check if there isn't some kind of CPU throttling turned on. Also check the frequency of your ram and make sure they run in dual channel. Afterwards, I'd take a look into the GPU drivers. Get nvidiainspector and modify the tf2 profile as follows:

Power management mode - prefer maximum performance
Multi-display/mixed-GPU acceleration - Single display performance mode

[quote=Malkraz][quote=mastercoms]
Try -nouserclip[/quote]

Seems to have made a minor improvement but I'm still dipping pretty hard in the problem areas. It's more like 95-110 now instead of 80-90 down from 280+ on spawn.[/quote]

There's something fundamentally wrong with your setup. Your CPU and GPU are excellent and such dips should never occur. I'd start by taking a look into UEFI to check if there isn't some kind of CPU throttling turned on. Also check the frequency of your ram and make sure they run in dual channel. Afterwards, I'd take a look into the GPU drivers. Get nvidiainspector and modify the tf2 profile as follows:

Power management mode - prefer maximum performance
Multi-display/mixed-GPU acceleration - Single display performance mode
723
#723
0 Frags +
fagoatseThere's something fundamentally wrong with your setup. Your CPU and GPU are excellent and such dips should never occur. I'd start by taking a look into UEFI to check if there isn't some kind of CPU throttling turned on. Also check the frequency of your ram and make sure they run in dual channel. Afterwards, I'd take a look into the GPU drivers. Get nvidiainspector and modify the tf2 profile as follows:
Power management mode - prefer maximum performance
Multi-display/mixed-GPU acceleration - Single display performance mode

Thanks for the reply.
I've checked out CPU usage and it's not being throttled. Back when I first put this machine together I made sure there wasn't any weird stuff going on with throttling, and my friend who has the exact same issues with same GPU/CPU but different MB doesn't have any throttling either.
I've confirmed RAM is running in dual-channel, and my Nvidia drivers are up to date. I already set power management and multi-display acceleration to those values globally in the Nvidia control panel.

Mastercoms and I had done some testing yesterday and (probably) isolated the problem to have something to do with being around characters that are firing their weapons. When walking from spawn at the start of the game with my entire team there are no issues whatsoever until people start shooting at each other.
She recommended these commands and they seem to have made this only happen in the more intensive firefights:
mod_load_anims_async 0
mod_forcedata 1
mod_forcetouchdata 1
mod_touchalldata 1

[quote=fagoatse]
There's something fundamentally wrong with your setup. Your CPU and GPU are excellent and such dips should never occur. I'd start by taking a look into UEFI to check if there isn't some kind of CPU throttling turned on. Also check the frequency of your ram and make sure they run in dual channel. Afterwards, I'd take a look into the GPU drivers. Get nvidiainspector and modify the tf2 profile as follows:
Power management mode - prefer maximum performance
Multi-display/mixed-GPU acceleration - Single display performance mode[/quote]
Thanks for the reply.
I've checked out CPU usage and it's not being throttled. Back when I first put this machine together I made sure there wasn't any weird stuff going on with throttling, and my friend who has the exact same issues with same GPU/CPU but different MB doesn't have any throttling either.
I've confirmed RAM is running in dual-channel, and my Nvidia drivers are up to date. I already set power management and multi-display acceleration to those values globally in the Nvidia control panel.

Mastercoms and I had done some testing yesterday and (probably) isolated the problem to have something to do with being around characters that are firing their weapons. When walking from spawn at the start of the game with my entire team there are no issues whatsoever until people start shooting at each other.
She recommended these commands and they seem to have made this only happen in the more intensive firefights:
mod_load_anims_async 0
mod_forcedata 1
mod_forcetouchdata 1
mod_touchalldata 1
724
#724
0 Frags +

I took off your config and went back to comanglias and now my tf2 is taking a really long time to load, should i just -autoconfig?

I took off your config and went back to comanglias and now my tf2 is taking a really long time to load, should i just -autoconfig?
725
#725
0 Frags +
VulcanI took off your config and went back to comanglias and now my tf2 is taking a really long time to load, should i just -autoconfig?

Reset your TF2: https://github.com/mastercoms/tf2cfg/#clean-up

Also sorry to see you go. Anything I can do better?

[quote=Vulcan]I took off your config and went back to comanglias and now my tf2 is taking a really long time to load, should i just -autoconfig?[/quote]
Reset your TF2: https://github.com/mastercoms/tf2cfg/#clean-up

Also sorry to see you go. Anything I can do better?
726
#726
0 Frags +

You mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it

You mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it
727
#727
1 Frags +
priestmuffinYou mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it

https://github.com/mastercoms/SourceEngine

[quote=priestmuffin]You mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it[/quote]
https://github.com/mastercoms/SourceEngine
728
#728
0 Frags +
mastercomspriestmuffinYou mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it
https://github.com/mastercoms/SourceEngine

Ah I thought you were referring to the TF2 source code in particular, rather than the engine.
Thanks for linking though

[quote=mastercoms][quote=priestmuffin]You mention on your github page that your config is based on the TF2 source code somehow.
How is this possible if TF2 is closed source?

If the source code is floating around somewhere I'd love to take a look at it[/quote]
https://github.com/mastercoms/SourceEngine[/quote]

Ah I thought you were referring to the TF2 source code in particular, rather than the engine.
Thanks for linking though
729
#729
0 Frags +

Hi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?

Hi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?
730
#730
1 Frags +
N0umHi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?

tf_hud_target_id_disable_floating_health 1 might do the trick.

[quote=N0um]Hi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?[/quote]
[b]tf_hud_target_id_disable_floating_health 1[/b] might do the trick.
731
#731
3 Frags +
priestmuffinAh I thought you were referring to the TF2 source code in particular, rather than the engine.
Thanks for linking though

https://github.com/mastercoms/SourceEngine/tree/master/src/game/shared/tf
https://github.com/mastercoms/SourceEngine/tree/master/src/game/client/tf
https://github.com/mastercoms/SourceEngine/tree/master/src/game/server/tf

N0umHi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?

Maybe try tf_hud_target_id_alpha 100.

Aetf_hud_target_id_disable_floating_health 1 might do the trick.

1 disables the floating health box.

5.1.3 released with a health icon bug fix, revert of an unneeded memory fix and bonus ducks.

[quote=priestmuffin]Ah I thought you were referring to the TF2 source code in particular, rather than the engine.
Thanks for linking though[/quote]
https://github.com/mastercoms/SourceEngine/tree/master/src/game/shared/tf
https://github.com/mastercoms/SourceEngine/tree/master/src/game/client/tf
https://github.com/mastercoms/SourceEngine/tree/master/src/game/server/tf

[quote=N0um]Hi, I'm currently using your config with the maxperformance preset. Yesterday I ran into a problem though, when I look at my teammates I cant see the little box that tells me their name/health. Any idea how to fix it?[/quote]
Maybe try tf_hud_target_id_alpha 100.

[quote=Ae]
[b]tf_hud_target_id_disable_floating_health 1[/b] might do the trick.[/quote]
1 disables the floating health box.

[quote][/quote]

[url=https://github.com/mastercoms/tf2cfg/releases/tag/5.1.3]5.1.3[/url] released with a health icon bug fix, revert of an unneeded memory fix and bonus ducks.
732
#732
2 Frags +
mastercoms1 disables the floating health box.

Most custom HUD need to disable the floating health box to show the name/health number (target ID).

[quote=mastercoms]
1 disables the floating health box.[/quote]

Most custom HUD need to disable the floating health box to show the name/health number (target ID).
733
#733
4 Frags +
AeMost custom HUD need to disable the floating health box to show the name/health number (target ID).

Ohh ok. Thanks for pointing that out.

I just read some 4chan archives and got a kick out of people arguing about my config. If anyone from 4chan is reading this, thank you for the entertainment.

[quote=Ae]
Most custom HUD need to disable the floating health box to show the name/health number (target ID).[/quote]
Ohh ok. Thanks for pointing that out.

[quote][/quote]

I just read some 4chan archives and got a kick out of people [url=https://boards.fireden.net/v/thread/396618647/#396645636]arguing[/url] about my config. If anyone from 4chan is reading this, thank you for [url=https://boards.fireden.net/v/thread/396618647/#396645215]the[/url] [url=https://boards.fireden.net/vg/thread/195762304/#195775668]entertainment[/url].
734
#734
1 Frags +
mastercomsIf anyone from 4chan is reading this, thank you for the entertainment.

Most of those posts were directed at me

https://puu.sh/ynXYj/95125e3f66.jpg

Speaking of that thread can anyone make sense of these posts:

Valve servers run at below minimum of comp interlop speed. BY adjusting the cmdrate and update rate to 67 the game will:
-Run smoother
-Boot up faster
-Target acquisition is faster and much easier to obtain
>When a shitpost who knows nothing about source and server time intervals trys to shitpost at you but fails to understand that the advantage is about 67% faster. Valve servers can update up to 970 ticks per interval but since 970/67=1.34 you get about 1.3 seconds faster updates.

I had no idea what this meant when he was blabbing at me and still have no clue where he's getting "970 ticks per interval" from.

[quote=mastercoms]If anyone from 4chan is reading this, thank you for [url=https://boards.fireden.net/v/thread/396618647/#396645215]the[/url] [url=https://boards.fireden.net/vg/thread/195762304/#195775668]entertainment[/url].[/quote]
Most of those posts were directed at me
[img]https://puu.sh/ynXYj/95125e3f66.jpg[/img]

Speaking of that thread can anyone make sense of these posts:
[quote]Valve servers run at below minimum of comp interlop speed. BY adjusting the cmdrate and update rate to 67 the game will:
-Run smoother
-Boot up faster
-Target acquisition is faster and much easier to obtain[/quote]

[quote]>When a shitpost who knows nothing about source and server time intervals trys to shitpost at you but fails to understand that the advantage is about 67% faster. Valve servers can update up to 970 ticks per interval but since 970/67=1.34 you get about 1.3 seconds faster updates.[/quote]
I had no idea what this meant when he was blabbing at me and still have no clue where he's getting "970 ticks per interval" from.
735
#735
2 Frags +

Thank you so much, master! everything works like a charm now :)

Thank you so much, master! everything works like a charm now :)
736
#736
1 Frags +
MalkrazSpeaking of that thread can anyone make sense of these posts:Valve servers run at below minimum of comp interlop speed. BY adjusting the cmdrate and update rate to 67 the game will:
-Run smoother
-Boot up faster
-Target acquisition is faster and much easier to obtain
>When a shitpost who knows nothing about source and server time intervals trys to shitpost at you but fails to understand that the advantage is about 67% faster. Valve servers can update up to 970 ticks per interval but since 970/67=1.34 you get about 1.3 seconds faster updates.I had no idea what this meant when he was blabbing at me and still have no clue where he's getting "970 ticks per interval" from.

I saw that too. I couldn't stop laughing. Servers limit your cmdrate and updaterate to 66 by default, so 67 just gets capped to 66. Even if it was allowed and TF2 had a tickrate higher than 66, you would just be getting 1 more network tick, not 970 ticks. Also, they have no idea what cmdrate and updaterate controls. It doesn't affect "boot time" (which I assume means server load time). Not sure what they mean by "run smoother" and "target acquisition".

N0umThank you so much, master! everything works like a charm now :)

Yay :), but btw, my preferred shortname is coms, because master sounds weird to me.

[quote=Malkraz]
Speaking of that thread can anyone make sense of these posts:
[quote]
Valve servers run at below minimum of comp interlop speed. BY adjusting the cmdrate and update rate to 67 the game will:
-Run smoother
-Boot up faster
-Target acquisition is faster and much easier to obtain
[/quote]
[quote]>When a shitpost who knows nothing about source and server time intervals trys to shitpost at you but fails to understand that the advantage is about 67% faster. Valve servers can update up to 970 ticks per interval but since 970/67=1.34 you get about 1.3 seconds faster updates.[/quote]
I had no idea what this meant when he was blabbing at me and still have no clue where he's getting "970 ticks per interval" from.[/quote]
I saw that too. I couldn't stop laughing. Servers limit your cmdrate and updaterate to 66 by default, so 67 just gets capped to 66. Even if it was allowed and TF2 had a tickrate higher than 66, you would just be getting 1 more network tick, not 970 ticks. Also, they have no idea what cmdrate and updaterate controls. It doesn't affect "boot time" (which I assume means server load time). Not sure what they mean by "run smoother" and "target acquisition".

[quote=N0um]Thank you so much, master! everything works like a charm now :)[/quote]
Yay :), but btw, my preferred shortname is coms, because master sounds weird to me.
737
#737
0 Frags +

do the r_ambient commands not work in dx81 ? i feel like they dont make any difference there.
btw theres a line for r_lod 63 but console says this

] r_lod 63
sv_cheats=0 prevented changing r_lod outside of the range [-1,2] (was 63).
do the r_ambient commands not work in dx81 ? i feel like they dont make any difference there.
btw theres a line for [b]r_lod 63[/b] but console says this
[code]] r_lod 63
sv_cheats=0 prevented changing r_lod outside of the range [-1,2] (was 63).[/code]
738
#738
1 Frags +
sagedo the r_ambient commands not work in dx81 ? i feel like they dont make any difference there.
btw theres a line for r_lod 63 but console says this
] r_lod 63
sv_cheats=0 prevented changing r_lod outside of the range [-1,2] (was 63).

Sorry, this was accidentally left after a test. Fix will be in the next release.

About r_ambient commands, I'm not sure, maybe it's your r_worldlights setting.

[quote=sage]do the r_ambient commands not work in dx81 ? i feel like they dont make any difference there.
btw theres a line for [b]r_lod 63[/b] but console says this
[code]] r_lod 63
sv_cheats=0 prevented changing r_lod outside of the range [-1,2] (was 63).[/code][/quote]
Sorry, this was accidentally left after a test. Fix will be in the next release.

About r_ambient commands, I'm not sure, maybe it's your r_worldlights setting.
739
#739
3 Frags +
mastercomsbecause master sounds weird to me.

Oh
I'm sure it gets awkward if everyone in a call, per example, calls you that

[quote=mastercoms]
because master sounds weird to me.[/quote]
Oh
I'm sure it gets awkward if everyone in a call, per example, calls you that
740
#740
0 Frags +

just downloaded your cfg really like it. the only thing I dislike is the blood splatter when I shoot someone, do you happen to know how could I disable that?

http://puu.sh/yortG/f3c278b4fa.png

just downloaded your cfg really like it. the only thing I dislike is the blood splatter when I shoot someone, do you happen to know how could I disable that? [img]http://puu.sh/yortG/f3c278b4fa.png[/img]
741
#741
2 Frags +
capbrajust downloaded your cfg really like it. the only thing I dislike is the blood splatter when I shoot someone, do you happen to know how could I disable that? http://puu.sh/yortG/f3c278b4fa.png

violence_hblood 0

[quote=capbra]just downloaded your cfg really like it. the only thing I dislike is the blood splatter when I shoot someone, do you happen to know how could I disable that? [img]http://puu.sh/yortG/f3c278b4fa.png[/img][/quote]
violence_hblood 0
742
#742
0 Frags +
mastercomsviolence_hblood 0

If that disables blood coming out of a cloaked spy after getting hit with the Tribalman's shiv will i still see him blink?

[quote=mastercoms]
violence_hblood 0[/quote]
If that disables blood coming out of a cloaked spy after getting hit with the Tribalman's shiv will i still see him blink?
743
#743
0 Frags +
SiiLVERIf that disables blood coming out of a cloaked spy after getting hit with the Tribalman's shiv will i still see him blink?

It just turns on low violence mode and thus replaces blood with a low violence version. Blinking is unrelated to the blood effect, it just occurs on damage.

[quote=SiiLVER]
If that disables blood coming out of a cloaked spy after getting hit with the Tribalman's shiv will i still see him blink?[/quote]
It just turns on low violence mode and thus replaces blood with a low violence version. Blinking is unrelated to the blood effect, it just occurs on damage.
744
#744
0 Frags +

I switched to this yesterday after using no config/hud since the pyro update and it takes quite a bit longer for me to alt+tab now. It's not a big issue but it's quite a bit slower. Any idea what could be causing it?

I switched to this yesterday after using no config/hud since the pyro update and it takes quite a bit longer for me to alt+tab now. It's not a big issue but it's quite a bit slower. Any idea what could be causing it?
745
#745
0 Frags +
ShiftaI switched to this yesterday after using no config/hud since the pyro update and it takes quite a bit longer for me to alt+tab now. It's not a big issue but it's quite a bit slower. Any idea what could be causing it?

Did you forget to remove -dx_level 95 from launch options after first boot? That's usually the main culprit for long alt-tab times.

[quote=Shifta]I switched to this yesterday after using no config/hud since the pyro update and it takes quite a bit longer for me to alt+tab now. It's not a big issue but it's quite a bit slower. Any idea what could be causing it?[/quote]

Did you forget to remove -dx_level 95 from launch options after first boot? That's usually the main culprit for long alt-tab times.
746
#746
0 Frags +
asl

You meant -dxlevel 95

[quote=asl][/quote]
You meant -dxlevel 95
747
#747
0 Frags +

Ever since a couple weeks after Jungle Inferno hit. My game is constantly freezes on Sending client info with no response whenever I connect to pug servers (i.e pugchamp tf2c and faceit). It just stays like that and I can't alt+F4 neither.
I have downloaded the latest version of your config 5.13 and use the comfig, igpu, and maxperformance preset.

Ever since a couple weeks after Jungle Inferno hit. My game is constantly freezes on [b]Sending client info[/b] with no response whenever I connect to pug servers (i.e pugchamp tf2c and faceit). It just stays like that and I can't alt+F4 neither.
I have downloaded the latest version of your config 5.13 and use the comfig, igpu, and maxperformance preset.
748
#748
0 Frags +
HazzordEver since a couple weeks after Jungle Inferno hit. My game is constantly freezes on Sending client info with no response whenever I connect to pug servers (i.e pugchamp tf2c and faceit). It just stays like that and I can't alt+F4 neither.
I have downloaded the latest version of your config 5.13 and use the comfig, igpu, and maxperformance preset.

What are your specs and OS?

[quote=Hazzord]Ever since a couple weeks after Jungle Inferno hit. My game is constantly freezes on [b]Sending client info[/b] with no response whenever I connect to pug servers (i.e pugchamp tf2c and faceit). It just stays like that and I can't alt+F4 neither.
I have downloaded the latest version of your config 5.13 and use the comfig, igpu, and maxperformance preset.[/quote]
What are your specs and OS?
749
#749
0 Frags +
aslDid you forget to remove -dx_level 95 from launch options after first boot? That's usually the main culprit for long alt-tab times.

Nah, definitely removed it.

[quote=asl]
Did you forget to remove -dx_level 95 from launch options after first boot? That's usually the main culprit for long alt-tab times.[/quote]

Nah, definitely removed it.
750
#750
0 Frags +
ShiftaNah, definitely removed it.

What's your full launch options?

[quote=Shifta]
Nah, definitely removed it.[/quote]
What's your full launch options?
1 ⋅⋅ 22 23 24 25 26 27 28 ⋅⋅ 61
Please sign in through STEAM to post a comment.