Upvote Upvoted 131 Downvote Downvoted
1 ⋅⋅ 7 8 9 10
m0re hud
posted in Customization
271
#271
0 Frags +
LeBrontohow can I change the theme colour from pink? thx

Pink is used for the main menu and uber only if i remember right and you can change both from the m0re colors file, they are called:

"Main Menu Labels" ; "Full Ubercharge" ; "Ubercharge Bar"

[quote=LeBronto]how can I change the theme colour from pink? thx[/quote]

Pink is used for the main menu and uber only if i remember right and you can change both from the m0re colors file, they are called:

"Main Menu Labels" ; "Full Ubercharge" ; "Ubercharge Bar"
272
#272
0 Frags +

thank you!
also would you happen to have a dl for this version?

thank you!
also would you happen to have a dl for this [url=https://imgur.com/a/93cXDPw]version[/url]?
273
#273
0 Frags +

I updated my hud and it worked fine. I then put in my usual customizations and it crashed. I wouldnt mind testing out which one it is that breaks it but I dont have the time atm. I use the following customizations: Fosters Scoreboard, Health Cross, Killstreak Icon, Timer with background.

I updated my hud and it worked fine. I then put in my usual customizations and it crashed. I wouldnt mind testing out which one it is that breaks it but I dont have the time atm. I use the following customizations: Fosters Scoreboard, Health Cross, Killstreak Icon, Timer with background.
274
#274
0 Frags +
Wild_PiggieI updated my hud and it worked fine. I then put in my usual customizations and it crashed. I wouldnt mind testing out which one it is that breaks it but I dont have the time atm. I use the following customizations: Fosters Scoreboard, Health Cross, Killstreak Icon, Timer with background.

Oh wait yeah i only just realized that the tf_english file included with fosters scoreboard is probably outdated and might cause crashes. You can remove it and the scoreboard works fine anyway, my bad i'll fix it tomorrow.

LeBrontothank you!
also would you happen to have a dl for this version?

Here I have updated it a bit since the version in the screen but 90% of it its still the same

[quote=Wild_Piggie]I updated my hud and it worked fine. I then put in my usual customizations and it crashed. I wouldnt mind testing out which one it is that breaks it but I dont have the time atm. I use the following customizations: Fosters Scoreboard, Health Cross, Killstreak Icon, Timer with background.[/quote]

Oh wait yeah i only just realized that the tf_english file included with fosters scoreboard is probably outdated and might cause crashes. You can remove it and the scoreboard works fine anyway, my bad i'll fix it tomorrow.

[quote=LeBronto]thank you!
also would you happen to have a dl for this [url=https://imgur.com/a/93cXDPw]version[/url]?[/quote]

[url=https://github.com/Hypnootize/Hypnotize-m0rehud]Here[/url] I have updated it a bit since the version in the screen but 90% of it its still the same
275
#275
1 Frags +

I updated the tf_english file, the hud should be crash free now (hopefully)

I updated the tf_english file, the hud should be crash free now (hopefully)
276
#276
0 Frags +

Seems to work fine now, thanks!

Seems to work fine now, thanks!
277
#277
0 Frags +

Actually, when I got into the game the killfeed is missing the player names :/

Actually, when I got into the game the killfeed is missing the player names :/
278
#278
0 Frags +
Wild_PiggieActually, when I got into the game the killfeed is missing the player names :/

This also happens with the default scoreboard installed

[quote=Wild_Piggie]Actually, when I got into the game the killfeed is missing the player names :/[/quote]

This also happens with the default scoreboard installed
279
#279
0 Frags +

how do I change the overheal shadow to the numbers instead

how do I change the overheal shadow to the numbers instead
280
#280
0 Frags +
Wild_PiggieWild_PiggieActually, when I got into the game the killfeed is missing the player names :/
This also happens with the default scoreboard installed

I tried the hud with no customizations and then with the same customizations you are using and i can see the killfeed names with both. I'm not sure what the problem can be tbh.

PapaSoulzunehow do I change the overheal shadow to the numbers instead

Basically inside scripts/hudanimations_m0re you want to:

1) Change every PlayerStatusHealthValueShadow to > PlayerStatusHealthValue.

2) Then delete all the Animate PlayerStatusHealthValueShadowExtra lines you find.

3) Last in both HudHealthBonusPulseStop and HudHealthDyingPulseStop categories change the
Animate PlayerStatusHealthValue "fgcolor" from "0 0 0 255" to > "Health Numbers"

That should do it!

[quote=Wild_Piggie][quote=Wild_Piggie]Actually, when I got into the game the killfeed is missing the player names :/[/quote]

This also happens with the default scoreboard installed[/quote]

I tried the hud with no customizations and then with the same customizations you are using and i can see the killfeed names with both. I'm not sure what the problem can be tbh.

[quote=PapaSoulzune]how do I change the overheal shadow to the numbers instead[/quote]

Basically inside scripts/hudanimations_m0re you want to:

1) Change every PlayerStatusHealthValueShadow to > PlayerStatusHealthValue.

2) Then delete all the Animate PlayerStatusHealthValueShadowExtra lines you find.

3) Last in both HudHealthBonusPulseStop and HudHealthDyingPulseStop categories change the
Animate PlayerStatusHealthValue "fgcolor" from "0 0 0 255" to > "Health Numbers"

That should do it!
281
#281
0 Frags +
jsuhquestion: how can i change / add a custom image background when joining a server, when joining a server the image is default tf2 hud right, can i change it? how?HypnotizeSorry for the very late answer as well. The file is StatSummary.res (Isn't there on m0rehud since is default you need to take it and add it from the base tf2 files) and then in that file you add the code for the background (after the "TFStatsSummary" code is fine)

something like:
Show Content
"Background_custom"
{
"ControlName" "ImagePanel"
"fieldName" "Background_Custom"
"xpox" "0"
"ypos" "0"
"zpos" "1"
"wide" "f0"
"tall" "480"
"visible" "1"
"enabled" "1"
"image" "replay/thumbnails/Loading_Custom"
"scaleImage" "1"
}

The image vtf and vmt goes in materials\vgui\replay\thumbnails\loading_custom.vtf/vmt

custom loading screen? can you show an example (file with picture on vtf) so i can easily experiment on customizations, i cant seem to get it work when following your instructions, also how do you change font that will lowercase the font on the menu and is it possible to get those 3 icons back on the right side in the menu

[quote=jsuh]question: how can i change / add a custom image background when joining a server, when joining a server the image is default tf2 hud right, can i change it? how?[/quote]

[quote=Hypnotize]Sorry for the very late answer as well. The file is StatSummary.res (Isn't there on m0rehud since is default you need to take it and add it from the base tf2 files) and then in that file you add the code for the background (after the "TFStatsSummary" code is fine)

something like:
[spoiler]
"Background_custom"
{
"ControlName" "ImagePanel"
"fieldName" "Background_Custom"
"xpox" "0"
"ypos" "0"
"zpos" "1"
"wide" "f0"
"tall" "480"
"visible" "1"
"enabled" "1"
"image" "replay/thumbnails/Loading_Custom"
"scaleImage" "1"
}
[/spoiler]

The image vtf and vmt goes in materials\vgui\replay\thumbnails\loading_custom.vtf/vmt[/quote]

custom loading screen? can you show an example (file with picture on vtf) so i can easily experiment on customizations, i cant seem to get it work when following your instructions, also how do you change font that will lowercase the font on the menu and is it possible to get those 3 icons back on the right side in the menu
282
#282
0 Frags +

Heyo,
I'm having trouble with getting the server timer on the main hud (not just the scoreboard). Everything seems to be enabled in HudObjectiveTimePanel.res and autoexec, but nothing apears on the hud. No idea what I'm doing wrong (probably somthing obvious), and I seem to be going in circles. Would really appriciate some help from anyone. (:

https://imgur.com/a/6KEDCpA

Show Content
"TimePanelBG"
{
"ControlName" "CTFImagePanel"
"fieldName" "TimePanelBG"
"xpos" "30"
"ypos" "0"
"zpos" "2"
"wide" "41"
"tall" "14"
"visible" "1"
"enabled" "1"
"image" "../hud/color_panel_blu"
"scaleImage" "1"
"src_corner_height" "10"
"src_corner_width" "10"
"draw_corner_width" "0"
"draw_corner_height" "0"
}

"ServerTimeLimitLabel"
{
"ControlName" "CExLabel"
"fieldName" "ServerTimeLimitLabel"
"xpos" "26"
"ypos" "14"
"zpos" "3"
"wide" "50"
"tall" "15"
"visible" "1"
"enabled" "1"
"labelText" "%servertimeleft%"
"textAlignment" "center"
"dulltext" "0"
"brighttext" "0"
"wrap" "0"
"font" "m0refont12"
"fgcolor" "255 255 255 255"

if_mvm
{
"visible" "0"
}
}

"ServerTimeLimitLabelBG"
{
"ControlName" "ImagePanel"
"fieldName" "ServerTimeLimitLabelBG"
"xpos" "30"
"ypos" "15"
"zpos" "3"
"wide" "41"
"tall" "15"
"visible" "1"
"enabled" "1"
"fillcolor" "0 0 0 100"

if_mvm
{
"visible" "0"
}
}
Heyo,
I'm having trouble with getting the server timer on the main hud (not just the scoreboard). Everything seems to be enabled in HudObjectiveTimePanel.res and autoexec, but nothing apears on the hud. No idea what I'm doing wrong (probably somthing obvious), and I seem to be going in circles. Would really appriciate some help from anyone. (:

[img]https://imgur.com/a/6KEDCpA[/img]

[spoiler]
"TimePanelBG"
{
"ControlName" "CTFImagePanel"
"fieldName" "TimePanelBG"
"xpos" "30"
"ypos" "0"
"zpos" "2"
"wide" "41"
"tall" "14"
"visible" "1"
"enabled" "1"
"image" "../hud/color_panel_blu"
"scaleImage" "1"
"src_corner_height" "10"
"src_corner_width" "10"
"draw_corner_width" "0"
"draw_corner_height" "0"
}

"ServerTimeLimitLabel"
{
"ControlName" "CExLabel"
"fieldName" "ServerTimeLimitLabel"
"xpos" "26"
"ypos" "14"
"zpos" "3"
"wide" "50"
"tall" "15"
"visible" "1"
"enabled" "1"
"labelText" "%servertimeleft%"
"textAlignment" "center"
"dulltext" "0"
"brighttext" "0"
"wrap" "0"
"font" "m0refont12"
"fgcolor" "255 255 255 255"

if_mvm
{
"visible" "0"
}
}

"ServerTimeLimitLabelBG"
{
"ControlName" "ImagePanel"
"fieldName" "ServerTimeLimitLabelBG"
"xpos" "30"
"ypos" "15"
"zpos" "3"
"wide" "41"
"tall" "15"
"visible" "1"
"enabled" "1"
"fillcolor" "0 0 0 100"

if_mvm
{
"visible" "0"
}
}
[/spoiler]
283
#283
0 Frags +
maiden custom loading screen? can you show an example (file with picture on vtf) so i can easily experiment on customizations, i cant seem to get it work when following your instructions, also how do you change font that will lowercase the font on the menu and is it possible to get those 3 icons back on the right side in the menu

Download the previous version to get the 3 icons back here (thats the only change I made in the last update)

In order to lowercase the menu labels open MainMenuOverride.res and search for every "AllCaps" "1" and turn them to "AllCaps" "0". You might need to do the same with PvPRankPanel.res

Last for the loading screen use these files here you just need to add them to whatever hud you want, they are set to work with every hud by default so you should be fine with m0rehud and everything else.

Once you added the files if you want to change the image used you need to take whatever image you want to use, turn it in to a vtf file and replace it inside materials\vgui\replay\thumbnails and you should be good. If you don't know how to convert images to vtfs there are plenty of tutorials out there.

StarachHeyo,
I'm having trouble with getting the server timer on the main hud (not just the scoreboard). Everything seems to be enabled in HudObjectiveTimePanel.res and autoexec, but nothing apears on the hud. No idea what I'm doing wrong (probably somthing obvious), and I seem to be going in circles. Would really appriciate some help from anyone. (:

https://imgur.com/a/6KEDCpA
Show Content
"TimePanelBG"
{
"ControlName" "CTFImagePanel"
"fieldName" "TimePanelBG"
"xpos" "30"
"ypos" "0"
"zpos" "2"
"wide" "41"
"tall" "14"
"visible" "1"
"enabled" "1"
"image" "../hud/color_panel_blu"
"scaleImage" "1"
"src_corner_height" "10"
"src_corner_width" "10"
"draw_corner_width" "0"
"draw_corner_height" "0"
}

"ServerTimeLimitLabel"
{
"ControlName" "CExLabel"
"fieldName" "ServerTimeLimitLabel"
"xpos" "26"
"ypos" "14"
"zpos" "3"
"wide" "50"
"tall" "15"
"visible" "1"
"enabled" "1"
"labelText" "%servertimeleft%"
"textAlignment" "center"
"dulltext" "0"
"brighttext" "0"
"wrap" "0"
"font" "m0refont12"
"fgcolor" "255 255 255 255"

if_mvm
{
"visible" "0"
}
}

"ServerTimeLimitLabelBG"
{
"ControlName" "ImagePanel"
"fieldName" "ServerTimeLimitLabelBG"
"xpos" "30"
"ypos" "15"
"zpos" "3"
"wide" "41"
"tall" "15"
"visible" "1"
"enabled" "1"
"fillcolor" "0 0 0 100"

if_mvm
{
"visible" "0"
}
}

Do you have tf_hud_show_servertimelimit set to "1" already?

[quote=maiden] custom loading screen? can you show an example (file with picture on vtf) so i can easily experiment on customizations, i cant seem to get it work when following your instructions, also how do you change font that will lowercase the font on the menu and is it possible to get those 3 icons back on the right side in the menu [/quote]

Download the previous version to get the 3 icons back [url=https://github.com/Hypnootize/m0rehud/tree/5440e2bd525ebd5ecd8f1e3bd138e10de616cca1]here[/url] (thats the only change I made in the last update)

In order to lowercase the menu labels open MainMenuOverride.res and search for every "AllCaps" "1" and turn them to "AllCaps" "0". You might need to do the same with PvPRankPanel.res

Last for the loading screen use these files [url=https://www.dropbox.com/s/mdgx9jkxp14se34/custom%20load%20screen.rar?dl=0]here[/url] you just need to add them to whatever hud you want, they are set to work with every hud by default so you should be fine with m0rehud and everything else.

Once you added the files if you want to change the image used you need to take whatever image you want to use, turn it in to a vtf file and replace it inside materials\vgui\replay\thumbnails and you should be good. If you don't know how to convert images to vtfs there are plenty of tutorials out there.

[quote=Starach]Heyo,
I'm having trouble with getting the server timer on the main hud (not just the scoreboard). Everything seems to be enabled in HudObjectiveTimePanel.res and autoexec, but nothing apears on the hud. No idea what I'm doing wrong (probably somthing obvious), and I seem to be going in circles. Would really appriciate some help from anyone. (:

[img]https://imgur.com/a/6KEDCpA[/img]

[spoiler]
"TimePanelBG"
{
"ControlName" "CTFImagePanel"
"fieldName" "TimePanelBG"
"xpos" "30"
"ypos" "0"
"zpos" "2"
"wide" "41"
"tall" "14"
"visible" "1"
"enabled" "1"
"image" "../hud/color_panel_blu"
"scaleImage" "1"
"src_corner_height" "10"
"src_corner_width" "10"
"draw_corner_width" "0"
"draw_corner_height" "0"
}

"ServerTimeLimitLabel"
{
"ControlName" "CExLabel"
"fieldName" "ServerTimeLimitLabel"
"xpos" "26"
"ypos" "14"
"zpos" "3"
"wide" "50"
"tall" "15"
"visible" "1"
"enabled" "1"
"labelText" "%servertimeleft%"
"textAlignment" "center"
"dulltext" "0"
"brighttext" "0"
"wrap" "0"
"font" "m0refont12"
"fgcolor" "255 255 255 255"

if_mvm
{
"visible" "0"
}
}

"ServerTimeLimitLabelBG"
{
"ControlName" "ImagePanel"
"fieldName" "ServerTimeLimitLabelBG"
"xpos" "30"
"ypos" "15"
"zpos" "3"
"wide" "41"
"tall" "15"
"visible" "1"
"enabled" "1"
"fillcolor" "0 0 0 100"

if_mvm
{
"visible" "0"
}
}
[/spoiler][/quote]

Do you have tf_hud_show_servertimelimit set to "1" already?
284
#284
0 Frags +
Do you have tf_hud_show_servertimelimit set to "1" already?

I did, and I have no idea what happened, but when I booted my game up today it was all working. Might have just needed a restart. Thank you though (:

[quote]Do you have tf_hud_show_servertimelimit set to "1" already?[/quote]

I did, and I have no idea what happened, but when I booted my game up today it was all working. Might have just needed a restart. Thank you though (:
285
#285
-1 Frags +

@Hypnotize

So I brought the old Hypno/m0rehud main menu into my hud (Which looks great btw)

My question is that the font that says my steam name and rank are still the same (I can't seem to find the ui to edit it)
The text is also mixed in together.

https://imgur.com/a/CCkAi1w

How would I fix this?

@Hypnotize

So I brought the old Hypno/m0rehud main menu into my hud (Which looks great btw)

My question is that the font that says my steam name and rank are still the same (I can't seem to find the ui to edit it)
The text is also mixed in together.

https://imgur.com/a/CCkAi1w

How would I fix this?
286
#286
0 Frags +
vanitas@Hypnotize

So I brought the old Hypno/m0rehud main menu into my hud (Which looks great btw)

My question is that the font that says my steam name and rank are still the same (I can't seem to find the ui to edit it)
The text is also mixed in together.

https://imgur.com/a/CCkAi1w

How would I fix this?

Import PvPrankPanel as well, that should fix it

[quote=vanitas]@Hypnotize

So I brought the old Hypno/m0rehud main menu into my hud (Which looks great btw)

My question is that the font that says my steam name and rank are still the same (I can't seem to find the ui to edit it)
The text is also mixed in together.

https://imgur.com/a/CCkAi1w

How would I fix this?[/quote]

Import PvPrankPanel as well, that should fix it
287
#287
6 Frags +

just wanted to say thanks for maintaining this hud, it's the best

just wanted to say thanks for maintaining this hud, it's the best
288
#288
0 Frags +

Hiya, would love help to brighten the colours of control points and how to get an X on the locked control points instead of a padlock

https://imgur.com/a/rAHd0TO

Thanks for any help in advance

Hiya, would love help to brighten the colours of control points and how to get an X on the locked control points instead of a padlock

https://imgur.com/a/rAHd0TO

Thanks for any help in advance
1 ⋅⋅ 7 8 9 10
Please sign in through STEAM to post a comment.