Upvote Upvoted 8 Downvote Downvoted
1 2
all my demos are choppy
posted in Q/A Help
31
#31
0 Frags +
CapuTry demo_interpolateview 1.

it was already at 1

as for what #29 said, yeah it is still jittery

[quote=Capu]Try demo_interpolateview 1.[/quote]
it was already at 1

as for what #29 said, yeah it is still jittery
32
#32
1 Frags +

OK, well that rules out that guess.

Only other thing I can think of to try that is still logical (because your guy's network settings are fine) is to disable multicore rendering, record a new demo, play that demo back (you can turn it back on afterwards).

e: yukari could you upload one of these jittery demos for me if the multicore rendering doesn't work, I want to fool around with it?

OK, well that rules out that guess.

Only other thing I can think of to try that is still logical (because your guy's network settings are fine) is to disable multicore rendering, record a new demo, play that demo back (you can turn it back on afterwards).

e: yukari could you upload one of these jittery demos for me if the multicore rendering doesn't work, I want to fool around with it?
33
#33
0 Frags +

https://www.mediafire.com/?cr4iv1xc4g3w1zf here's a demo from yesterday

thanks for your help ^^

https://www.mediafire.com/?cr4iv1xc4g3w1zf here's a demo from yesterday

thanks for your help ^^
34
#34
0 Frags +

I'm assuming multicore rendering didn't help then? Do you have any special error messages in console while playing while recording demos?

Anyways...

Good news #1: The problem is 100% definitely in the recording of the demo.

Good news #2: I'm pretty sure the cause is that something is interfering in the packet creation of the recorder which is causing the "jitter" effect and creating an essentially "inaccurate" demo. You can very clearly see this yourself by loading the demo, then sv_cheats 1 and watch it in host_timescale 0.1. You literally teleport during the jitters and during these intervals your crosshair movement even drops usually. Basically, the demo doesn't have information there and just moves you ahead to the next packet of information.

Bad news #1: I have no idea what is causing it, everything reasonable in-game doesn't seem to be the cause which means this is veering into the territory of:

* a weird bug with some weird cvar (and there's hundreds of these)

* weird threading issue that goes beyond the multicore rendering setting (dunno if you have a similar CPU/GPU to the OP or what),

* something odd with the specific time these recordings are happening breaking the recorder (this used to happen in CSGO, idk if they fixed it, if you recorded a demo after freeze time your demo would break in a manner very similar to this)

* your HDD sucks enough ass at writing small data chunks consistently (this is demo recording in a nutshell) and is causing this.

Bad news #2: It's even harder to figure this out because the .dem format has not been reverse engineered to completion to really dig deep into this. (this is for the best as far as cheating goes tho, if you could do this you could edit them and hide your hacks better)

Bad news #3: This also means these demos will be broken pretty much forever tho.

I'm assuming multicore rendering didn't help then? Do you have any special error messages in console while playing while recording demos?

Anyways...

Good news #1: The problem is 100% definitely in the recording of the demo.

Good news #2: I'm pretty sure the cause is that something is interfering in the packet creation of the recorder which is causing the "jitter" effect and creating an essentially "inaccurate" demo. You can very clearly see this yourself by loading the demo, then sv_cheats 1 and watch it in host_timescale 0.1. You literally teleport during the jitters and during these intervals your crosshair movement even drops usually. Basically, the demo doesn't have information there and just moves you ahead to the next packet of information.

Bad news #1: I have no idea what is causing it, everything reasonable in-game doesn't seem to be the cause which means this is veering into the territory of:

* a weird bug with some weird cvar (and there's hundreds of these)

* weird threading issue that goes beyond the multicore rendering setting (dunno if you have a similar CPU/GPU to the OP or what),

* something odd with the specific time these recordings are happening breaking the recorder (this used to happen in CSGO, idk if they fixed it, if you recorded a demo after freeze time your demo would break in a manner very similar to this)

* your HDD sucks enough ass at writing small data chunks consistently (this is demo recording in a nutshell) and is causing this.

Bad news #2: It's even harder to figure this out because the .dem format has not been reverse engineered to completion to really dig deep into this. (this is for the best as far as cheating goes tho, if you could do this you could edit them and hide your hacks better)

Bad news #3: This also means these demos will be broken pretty much forever tho.
35
#35
0 Frags +

the problem fixed itself after a couple of months in my case

i can say that i didnt change anything in my config at all, maybe that information is of any help

the problem fixed itself after a couple of months in my case

i can say that i didnt change anything in my config at all, maybe that information is of any help
36
#36
-1 Frags +
smzithe problem fixed itself after a couple of months in my case

i can say that i didnt change anything in my config at all, maybe that information is of any help

well if this is true (and i'm assuming you didn't change any hardware) then that pretty much narrows it down to weird threading issue that Valve needs to fix (from CPU/GPU, weird driver issue possibly, etc) or weird cvar issue still (since you two likely have different configs past network settings) I guess.

Sorry I can't be more help Yukari but you're pretty much out of my area of expertise and have fallen into the realm of hoping Valve inexplicably fixes your problem in a random update most likely.

[quote=smzi]the problem fixed itself after a couple of months in my case

i can say that i didnt change anything in my config at all, maybe that information is of any help[/quote]

well if this is true (and i'm assuming you didn't change any hardware) then that pretty much narrows it down to weird threading issue that Valve needs to fix (from CPU/GPU, weird driver issue possibly, etc) or weird cvar issue still (since you two likely have different configs past network settings) I guess.

Sorry I can't be more help Yukari but you're pretty much out of my area of expertise and have fallen into the realm of hoping Valve inexplicably fixes your problem in a random update most likely.
37
#37
0 Frags +

thanks a lot for the insightful replies, honestly i'm pretty sure it's because of my internet connection as i do drop packets a lot so that's most likely why it's happening.
if that's not the reason then it is probably due to my shitty HDD

if i end up finding a fix for this i'll bump the thread, again, thanks a lot for your help

thanks a lot for the insightful replies, honestly i'm pretty sure it's because of my internet connection as i do drop packets a lot so that's most likely why it's happening.
if that's not the reason then it is probably due to my shitty HDD

if i end up finding a fix for this i'll bump the thread, again, thanks a lot for your help
38
#38
2 Frags +

rate 60000 was the culprit for me, using anything between 80000 - 100000002537764290115403776 bytes/sec fixes it

rate 60000 was the culprit for me, using anything between 80000 - 100000002537764290115403776 bytes/sec fixes it
39
#39
12 Frags +

very late but try these 2

1. try using in game demos, not prec.

2. put these in when you're in the demo

demo_interpolateview 1
demo_interplimit 999999999999999

very late but try these 2

1. try using in game demos, not prec.

2. put these in when you're in the demo

demo_interpolateview 1
demo_interplimit 999999999999999
40
#40
26 Frags +

im sure svmzi will appreciate the help *checks calendar* 7 years later

im sure svmzi will appreciate the help *checks calendar* 7 years later
41
#41
35 Frags +

Thank you i can finally finish my season 12 fragvideo

Thank you i can finally finish my season 12 fragvideo
42
#42
0 Frags +
smziThank you i can finally finish my season 12 fragvideo

unironically hyped for it bro

[quote=smzi]Thank you i can finally finish my season 12 fragvideo[/quote]
unironically hyped for it bro
1 2
Please sign in through STEAM to post a comment.