Upvote Upvoted 1 Downvote Downvoted
Weird visual bug - constrasty colors
posted in Q/A Help
1
#1
0 Frags +

hey,
so a couple days ago when launching TF2, I noticed that every ALT +TAB I did resulted in a seemingly random chance of getting a weird contrasty image when I tabbed back in tf2 (instead of my usual bright TF2 - I use mat_monitorgamma 1.6 aka the brightest for better visibility). To fix the issue, I have to tab out then back into the game a random number of times before the colors get back to normal. Using the latest nvidia drivers and windows update, everything is up to date and my monitor doesnt have auto brightness or anything like that. I tryed to record screeshots to showcase the issue and have a way to compare but the various programms I tried to capture footage (screenshots or video) never represent what I actually see. So I only have this which is an accurate representation of that annoying constrasty look I'm getting. I'm sure everyone knows that a bright tf2 never looks anything like that.
Any ideas on how to fix it ?

hey,
so a couple days ago when launching TF2, I noticed that every ALT +TAB I did resulted in a seemingly random chance of getting a weird contrasty image when I tabbed back in tf2 (instead of my usual bright TF2 - I use mat_monitorgamma 1.6 aka the brightest for better visibility). To fix the issue, I have to tab out then back into the game a random number of times before the colors get back to normal. Using the latest nvidia drivers and windows update, everything is up to date and my monitor doesnt have auto brightness or anything like that. I tryed to record screeshots to showcase the issue and have a way to compare but the various programms I tried to capture footage (screenshots or video) never represent what I actually see. So I only have [url=https://imgur.com/a/kIWziJQ]this[/url] which is an accurate representation of that annoying constrasty look I'm getting. I'm sure everyone knows that a bright tf2 never looks anything like that.
Any ideas on how to fix it ?
2
#2
1 Frags +

when i used a lot of vpks this would happen, are u using any?

when i used a lot of vpks this would happen, are u using any?
3
#3
1 Frags +

I also had this issue, for me it was from some more uncommon launch options, I would try removing those first.

I also had this issue, for me it was from some more uncommon launch options, I would try removing those first.
4
#4
0 Frags +
yerbwhen i used a lot of vpks this would happen, are u using any?

Depends on how you define "a lot" but yes good catch bc I think this is only happening since I updated my headsfeet vpk to the newest 7.3.20 version (I use 5 vpks), I'll test that later.

raduI also had this issue, for me it was from some more uncommon launch options, I would try removing those first.

Do you know which ones specifically may cause the issue ? I tryed removing some of them bc they were either seemingly useless or outdated. I currently have this :

-dxlevel 91 -novid -full -w 1920 -h 1080 -console -nojoy -noff -nohltv -nouserclip -softparticlesdefaultoff -reuse -usetcp -nostartupsound -primarysound -snoforceformat -nosteamcontroller -disable_d3d9_hacks -NoQueuedPacketThread +cl_clean_texture
[quote=yerb]when i used a lot of vpks this would happen, are u using any?[/quote]
Depends on how you define "a lot" but yes good catch bc I think this is only happening since I updated my headsfeet vpk to the newest 7.3.20 version (I use 5 vpks), I'll test that later.

[quote=radu]I also had this issue, for me it was from some more uncommon launch options, I would try removing those first.[/quote]
Do you know which ones specifically may cause the issue ? I tryed removing some of them bc they were either seemingly useless or outdated. I currently have this :
[code]-dxlevel 91 -novid -full -w 1920 -h 1080 -console -nojoy -noff -nohltv -nouserclip -softparticlesdefaultoff -reuse -usetcp -nostartupsound -primarysound -snoforceformat -nosteamcontroller -disable_d3d9_hacks -NoQueuedPacketThread +cl_clean_texture[/code]
5
#5
2 Frags +
osvaldo+cl_clean_texture

sorry for jacking the thread, what's that?

[quote=osvaldo]+cl_clean_texture
[/quote]

sorry for jacking the thread, what's that?
6
#6
0 Frags +

also sorry about derailing the thread but what are -noff, -nouserclip, -usetcp -disable_d3d9_hacks, -NoQueuedPacketThread?

also sorry about derailing the thread but what are -noff, -nouserclip, -usetcp -disable_d3d9_hacks, -NoQueuedPacketThread?
7
#7
0 Frags +
kordyansorry for jacking the thread, what's that?Hogosakialso sorry about derailing the thread but what are -noff, -nouserclip, -usetcp -disable_d3d9_hacks, -NoQueuedPacketThread?

Alright so my launch options are all from a mix between comanglia's config and mastercoms' recommandations - newer and often better explained. So since I forgot what each of them actually do, I'd recommend going over mastercoms' config or asking her directly (lots of it is also explained here but you'd have to find the right pages and the thread is very long.

e: on mastercoms' website, there's a launch options dedicated sections https://docs.mastercomfig.com/en/latest/customization/launch_options/ So for instance, you have

-nouserclip : uses software clipping instead of hardware user clip planes, FPS increase or decrease depends on your CPU+GPU and graphics API
[quote=kordyan]sorry for jacking the thread, what's that?[/quote]
[quote=Hogosaki]also sorry about derailing the thread but what are -noff, -nouserclip, -usetcp -disable_d3d9_hacks, -NoQueuedPacketThread?[/quote]
Alright so my launch options are all from a mix between comanglia's config and mastercoms' recommandations - newer and often better explained. So since I forgot what each of them actually do, I'd recommend going over mastercoms' config or asking her directly (lots of it is also explained [url=https://www.teamfortress.tv/42867/mastercomfig-fps-customization-config]here [/url] but you'd have to find the right pages and the thread is very long.

e: on mastercoms' website, there's a launch options dedicated sections https://docs.mastercomfig.com/en/latest/customization/launch_options/ So for instance, you have
[code]-nouserclip : uses software clipping instead of hardware user clip planes, FPS increase or decrease depends on your CPU+GPU and graphics API[/code]
8
#8
1 Frags +
-dxlevel 91 -novid -full -w 1920 -h 1080 -console -nojoy -noff -nohltv -nouserclip -softparticlesdefaultoff -reuse -usetcp -nostartupsound -primarysound -snoforceformat -nosteamcontroller -disable_d3d9_hacks -NoQueuedPacketThread +cl_clean_texture

Out of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.

[code]-dxlevel 91 -novid -full -w 1920 -h 1080 -console -nojoy -noff -nohltv -nouserclip -softparticlesdefaultoff -reuse -usetcp -nostartupsound -primarysound -snoforceformat -nosteamcontroller -disable_d3d9_hacks -NoQueuedPacketThread +cl_clean_texture[/code]

Out of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.
9
#9
0 Frags +
raduOut of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.

After testing, sadly, removing all my vpks did not fix it, neither did removing a lot of launch options - I'm down to this :

-dxlevel 91 -full -w 1920 -h 1080 -freq 144 -console -novid -nojoy -nosteamcontroller -nohltv -particles 1 -nostartupsound
[quote=radu]Out of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.[/quote]
After testing, sadly, removing all my vpks did [u]not[/u] fix it, neither did removing a lot of launch options - I'm down to this :

[code]-dxlevel 91 -full -w 1920 -h 1080 -freq 144 -console -novid -nojoy -nosteamcontroller -nohltv -particles 1 -nostartupsound[/code]
10
#10
0 Frags +
osvaldoraduOut of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.After testing, sadly, removing all my vpks did not fix it, neither did removing a lot of launch options - I'm down to this :
-dxlevel 91 -full -w 1920 -h 1080 -freq 144 -console -novid -nojoy -nosteamcontroller -nohltv -particles 1 -nostartupsound

I don't really know what to suggest further, maybe try resetting your game to default (https://docs.mastercomfig.com/en/stable/setup/clean_up/) or roll back GPU drivers or even try to restore to a previous version of windows.

[quote=osvaldo][quote=radu]Out of that list, I think I had -nouserclip -softparticlesdefaultoff, if you determine that the issue is not from the headsfeet vpk I would try and remove "disable_d3d9_hacks" and "cl_clean_texture" (besides the 2 I mentioned at the beginning of the sentence) since I don't see how the other ones would cause this.[/quote]
After testing, sadly, removing all my vpks did [u]not[/u] fix it, neither did removing a lot of launch options - I'm down to this :

[code]-dxlevel 91 -full -w 1920 -h 1080 -freq 144 -console -novid -nojoy -nosteamcontroller -nohltv -particles 1 -nostartupsound[/code][/quote]

I don't really know what to suggest further, maybe try resetting your game to default (https://docs.mastercomfig.com/en/stable/setup/clean_up/) or roll back GPU drivers or even try to restore to a previous version of windows.
11
#11
0 Frags +

Remove -dxlevel 91 -full -w 1920 -h 1080

Remove -dxlevel 91 -full -w 1920 -h 1080
12
#12
0 Frags +
mastercomsRemove -dxlevel 91 -full -w 1920 -h 1080

So you recommend setting the resolution through the game and let it remember it every launch ?
+ how useful is the dxlevel launch option versus setting it in an autoexec with mat_dxlevel 91 or are they different ?

[quote=mastercoms]Remove -dxlevel 91 -full -w 1920 -h 1080[/quote]
So you recommend setting the resolution through the game and let it remember it every launch ?
+ how useful is the dxlevel launch option versus setting it in an autoexec with mat_dxlevel 91 or are they different ?
13
#13
0 Frags +

You use -dxlevel once to set it, and after that first launch, remove it. Nothing else is needed. Don't use mat_dxlevel.

And yes, there's no reason to use those window parameters. Resolution only gets reset by using -dxlevel.

You use -dxlevel once to set it, and after that first launch, remove it. Nothing else is needed. Don't use mat_dxlevel.

And yes, there's no reason to use those window parameters. Resolution only gets reset by using -dxlevel.
Please sign in through STEAM to post a comment.