Upvote Upvoted 231 Downvote Downvoted
1 2 3 4 5 ⋅⋅ 56
mastercomfig - fps/customization config
posted in Customization
31
#31
3 Frags +
ComangliaI would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime like this.

I would but I have no idea how :(

[quote=Comanglia]I would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime [url=https://techreport.com/r.x/2016_12_7_Radeon_Software_ReLive_Edition_overview/csgo2.png]like this[/url].[/quote]
I would but I have no idea how :(
32
#32
4 Frags +
ComangliaI would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime like this.

I did that for my own config. https://www.youtube.com/watch?v=faNeipYH4cw

I apologize for my awful gameplay, the overlay was displayed while I played, so I couldn't see anything :(

[quote=Comanglia]I would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime [url=https://techreport.com/r.x/2016_12_7_Radeon_Software_ReLive_Edition_overview/csgo2.png]like this[/url].[/quote]

I did that for my own config. https://www.youtube.com/watch?v=faNeipYH4cw

I apologize for my awful gameplay, the overlay was displayed while I played, so I couldn't see anything :(
33
#33
3 Frags +
mastercomsComangliaI would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime like this.
I did that for my own config. https://www.youtube.com/watch?v=faNeipYH4cw

I apologize for my awful gameplay, the overlay was displayed while I played, so I couldn't see anything :(

That's really cool, could you do that with the benchmark demo? Should give you a very good comparison of the 2 configs. My suspicion is yours well have a lot less variance while mine will have a higher average.

[quote=mastercoms][quote=Comanglia]I would be extremely grateful if anyone would test these configs with Average and Minimum frametimes and well as a graphed out frametime [url=https://techreport.com/r.x/2016_12_7_Radeon_Software_ReLive_Edition_overview/csgo2.png]like this[/url].[/quote]

I did that for my own config. https://www.youtube.com/watch?v=faNeipYH4cw

I apologize for my awful gameplay, the overlay was displayed while I played, so I couldn't see anything :([/quote]

That's really cool, could you do that with the benchmark demo? Should give you a very good comparison of the 2 configs. My suspicion is yours well have a lot less variance while mine will have a higher average.
34
#34
2 Frags +
ComangliaThat's really cool, could you do that with the benchmark demo? Should give you a very good comparison of the 2 configs. My suspicion is yours well have a lot less variance while mine will have a higher average.

Sure, but it will take me some time to get it out though since I now use a Nvidia card and only AMD cards have this feature on Linux. I'm building a new PC (with Vega) in around December since this i7 870 is falling off now.

[quote=Comanglia]
That's really cool, could you do that with the benchmark demo? Should give you a very good comparison of the 2 configs. My suspicion is yours well have a lot less variance while mine will have a higher average.[/quote]

Sure, but it will take me some time to get it out though since I now use a Nvidia card and only AMD cards have this feature on Linux. I'm building a new PC (with Vega) in around December since this i7 870 is falling off now.
35
#35
4 Frags +
r_lod -1

Isn't r_lod 0 the highest value?

[quote]r_lod -1[/quote]
Isn't r_lod 0 the highest value?
36
#36
9 Frags +
ZeRo5Isn't r_lod 0 the highest value?

r_lod -1 uses automatic LOD, i.e, uses r_rootlod and fades through different LODs. Using anything other than -1 is not recommended (unless you're using 0 to force best quality), because if you try to use r_lod to force a lower LOD, you might not be using the ideal LOD (performance-wise) for that distance.

[quote=ZeRo5]
Isn't r_lod 0 the highest value?[/quote]

r_lod -1 uses automatic LOD, i.e, uses r_rootlod and fades through different LODs. Using anything other than -1 is not recommended (unless you're using 0 to force best quality), because if you try to use r_lod to force a lower LOD, you might not be using the ideal LOD (performance-wise) for that distance.
37
#37
2 Frags +
mastercomsz3taim getting a white screen ig pls help
What are your launch options? Do you have any modifications installed?

My Launch Options:

-full -w 1920 -h 1080 -console -freq 144 -novid -nojoy -noff -nohltv

I have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.

[quote=mastercoms][quote=z3ta]im getting a white screen ig pls help[/quote]

What are your launch options? Do you have any modifications installed?[/quote]

My Launch Options:
[quote]-full -w 1920 -h 1080 -console -freq 144 -novid -nojoy -noff -nohltv[/quote]
I have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.
38
#38
5 Frags +
mastercomsZeRo5Isn't r_lod 0 the highest value?
r_lod -1 uses automatic LOD, i.e, uses r_rootlod and fades through different LODs. Using anything other than -1 is not recommended (unless you're using 0 to force best quality), because if you try to use r_lod to force a lower LOD, you might not be using the ideal LOD (performance-wise) for that distance.

Interesting. Most fps configs use r_lod 2 even comanglia's config.

[quote=mastercoms][quote=ZeRo5]
Isn't r_lod 0 the highest value?[/quote]

r_lod -1 uses automatic LOD, i.e, uses r_rootlod and fades through different LODs. Using anything other than -1 is not recommended (unless you're using 0 to force best quality), because if you try to use r_lod to force a lower LOD, you might not be using the ideal LOD (performance-wise) for that distance.[/quote]
Interesting. Most fps configs use r_lod 2 even comanglia's config.
39
#39
6 Frags +
z3taI have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.

Does your HUD have transparent viewmodels?

ZeRo5Interesting. Most fps configs use r_lod 2 even comanglia's config.

Well if a model has a lower LOD level than 2, it won't ever be used. r_rootlod sets the highest LOD level that can be used, so while r_lod 2 will always use LOD level 2, r_rootlod 2 will start at LOD level 2, and fade to even lower LODs if needed.

[quote=z3ta]
I have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.[/quote]

Does your HUD have transparent viewmodels?

[quote=ZeRo5]
Interesting. Most fps configs use r_lod 2 even comanglia's config.[/quote]

Well if a model has a lower LOD level than 2, it won't ever be used. r_rootlod sets the highest LOD level that can be used, so while r_lod 2 will always use LOD level 2, r_rootlod 2 will start at LOD level 2, and fade to even lower LODs if needed.
40
#40
3 Frags +
mastercomsz3taI have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.
Does your HUD have transparent viewmodels?

yah, i forgot to add the cmds lol
edit: actually that didn't fix anything

[quote=mastercoms][quote=z3ta]
I have some custom particles, a killsound, and a hud. If I open up a menu while playing I can see the game though.[/quote]

Does your HUD have transparent viewmodels?[/quote]
yah, i forgot to add the cmds lol
edit: actually that didn't fix anything
41
#41
1 Frags +
z3tayah, i forgot to add the cmds lol
edit: actually that didn't fix anything

Try using building_cubemaps 0.

[quote=z3ta]
yah, i forgot to add the cmds lol
edit: actually that didn't fix anything[/quote]

Try using building_cubemaps 0.
42
#42
4 Frags +
mastercomsTry using building_cubemaps 0.

Still no change :(

[quote=mastercoms]
Try using building_cubemaps 0.[/quote]
Still no change :(
43
#43
1 Frags +
z3taStill no change :(

:( I'll try out transparent viewmodels and see what the problem is. Could I use your HUD (for consistency)?

[quote=z3ta]
Still no change :([/quote]

:( I'll try out transparent viewmodels and see what the problem is. Could I use your HUD (for consistency)?
44
#44
3 Frags +
z3tamastercomsTry using building_cubemaps 0.Still no change :(

Why not upload your entire custom folder?

[quote=z3ta][quote=mastercoms]
Try using building_cubemaps 0.[/quote]
Still no change :([/quote]
Why not upload your entire custom folder?
45
#45
3 Frags +

i use omphud-redux. here is custom folder

i use omphud-redux. [url=https://drive.google.com/open?id=0By3nMBF0zydSNHp2QUxTZndYZUk]here is custom folder[/url]
46
#46
6 Frags +

i5 650 iGPU - 640 x 480
Integrated graphics didnt seem to handle the slighly higher quality very well...I should get a gpu.

Show Content
-default - DX9:
2639 frames 48.176 seconds 54.78 fps (18.26 ms/f) 5.601 fps variability

-default - DX8
2639 frames 42.202 seconds 62.53 fps (15.99 ms/f) 4.789 fps variability

Comanglia - DX9
2639 frames 29.050 seconds 90.84 fps (11.01 ms/f) 6.042 fps variability

Comanglia - DX8
2639 frames 25.908 seconds 101.86 fps ( 9.82 ms/f) 7.380 fps variability

Felik low end - DX8:
2639 frames 26.271 seconds 100.45 fps ( 9.95 ms/f) 7.384 fps variability

mastercoms - DX8
2639 frames 33.088 seconds 79.76 fps (12.54 ms/f) 5.343 fps variability
i5 650 iGPU - 640 x 480
Integrated graphics didnt seem to handle the slighly higher quality very well...I should get a gpu.

[spoiler]-default - DX9:
2639 frames 48.176 seconds 54.78 fps (18.26 ms/f) 5.601 fps variability

-default - DX8
2639 frames 42.202 seconds 62.53 fps (15.99 ms/f) 4.789 fps variability

Comanglia - DX9
2639 frames 29.050 seconds 90.84 fps (11.01 ms/f) 6.042 fps variability

Comanglia - DX8
2639 frames 25.908 seconds 101.86 fps ( 9.82 ms/f) 7.380 fps variability

Felik low end - DX8:
2639 frames 26.271 seconds 100.45 fps ( 9.95 ms/f) 7.384 fps variability

mastercoms - DX8
2639 frames 33.088 seconds 79.76 fps (12.54 ms/f) 5.343 fps variability
[/spoiler]
47
#47
7 Frags +
notsoi5 650

your igpu isn't the problem my man

[quote=notso]i5 650[/quote]
your igpu isn't the problem my man
48
#48
3 Frags +
notsoi5 650 iGPU - 640 x 480
Integrated graphics didnt seem to handle the slighly higher quality very well...I should get a gpu.

There are a few config options that the comments suggest setting based on if you have a weak GPU and weak CPU. Try setting those. Also, I haven't investigated a lot of the visual settings that will boost FPS on these potato computers.

Even with that, I feel like FPS only gives part of the story. What about load times, stuttering, etc?

z3tai use omphud-redux. here is custom folder

Thanks. I'll investigate soon.

[quote=notso]i5 650 iGPU - 640 x 480
Integrated graphics didnt seem to handle the slighly higher quality very well...I should get a gpu.
[/quote]

There are a few config options that the comments suggest setting based on if you have a weak GPU and weak CPU. Try setting those. Also, I haven't investigated a lot of the visual settings that will boost FPS on these potato computers.

Even with that, I feel like FPS only gives part of the story. What about load times, stuttering, etc?

[quote=z3ta]i use omphud-redux. [url=https://drive.google.com/open?id=0By3nMBF0zydSNHp2QUxTZndYZUk]here is custom folder[/url][/quote]

Thanks. I'll investigate soon.
49
#49
7 Frags +

In addition to adding more options to make the graphics less taxing on weak computers, I'm also planning on revamping the comments. Right now, the purpose of comments aren't very well defined, so I wanted to have each comment both explain the CVar, as well as why I chose a certain value for that CVar to be the default for the config. However, I'm not entirely sure how to organize the text for that. So, anyone have ideas on what they would prefer for comment formatting?

Also, I've been thinking for a while now about adding presets/versions for my config for different setups (kind of like what Comanglia did for their config). However, the problem that's been making me hesitant to do that is that there isn't really a one size fits all for some of these CVars (eg maxframes) and that's why I've only added comments suggesting to change values in certain cases. I'm turning to the community for feedback as to what I should do for this problem about varying values being optimal for different PCs.

In addition to adding more options to make the graphics less taxing on weak computers, I'm also planning on revamping the comments. Right now, the purpose of comments aren't very well defined, so I wanted to have each comment both explain the CVar, as well as why I chose a certain value for that CVar to be the default for the config. However, I'm not entirely sure how to organize the text for that. So, anyone have ideas on what they would prefer for comment formatting?

Also, I've been thinking for a while now about adding presets/versions for my config for different setups (kind of like what Comanglia did for their config). However, the problem that's been making me hesitant to do that is that there isn't really a one size fits all for some of these CVars (eg maxframes) and that's why I've only added comments suggesting to change values in certain cases. I'm turning to the community for feedback as to what I should do for this problem about varying values being optimal for different PCs.
50
#50
1 Frags +

So I just installed this config and there's a few issues I've encountered so far.

Whenever I join my own local server, I just get stuck in respawn, cannot move and can't shoot, the fire sound just laps and no projectiles or scatters come out.

Also another thing I've noticed is that whenever I try and change my settings or even change a crosshair while in a casual game, when I press ok it disconnects me out of the game? Very strange

Also what is the reasoning on having mat_trilinear 0

So I just installed this config and there's a few issues I've encountered so far.

Whenever I join my own local server, I just get stuck in respawn, cannot move and can't shoot, the fire sound just laps and no projectiles or scatters come out.

Also another thing I've noticed is that whenever I try and change my settings or even change a crosshair while in a casual game, when I press ok it disconnects me out of the game? Very strange

Also what is the reasoning on having mat_trilinear 0
51
#51
5 Frags +

check page 1 for ur first problem

check page 1 for ur first problem
52
#52
1 Frags +

should I use this or comang high / 7700k r9 390

should I use this or comang high / 7700k r9 390
53
#53
50 Frags +

MORE FIXES!
yaay

(Dropbox) Download: https://www.dropbox.com/s/yj0v0608tz8a7gi/cp_prolands_b2b.zip?dl=0

cp_prolands_b2a -> cp_prolands_b2b

BUG FIX:
- Fixed being able to leave the map
- Fixed two spots where you were able to stand on rooves
- Fixed a spot where you could stand in the middle of nothing
- Fixed a couple of graphical errors
- Hopefully fixed the HUD issues(?) (The settings were on default in hammer editor but I think my custom HUD might have something to do with it…)

Shoutout to carn for helping me!

[h]MORE FIXES![/h]
yaay

(Dropbox) Download: https://www.dropbox.com/s/yj0v0608tz8a7gi/cp_prolands_b2b.zip?dl=0

cp_prolands_b2a -> cp_prolands_b2b

[b]BUG FIX:[/b]
- Fixed being able to leave the map
- Fixed two spots where you were able to stand on rooves
- Fixed a spot where you could stand in the middle of nothing
- Fixed a couple of graphical errors
- Hopefully fixed the HUD issues(?) (The settings were on default in hammer editor but I think my custom HUD might have something to do with it…)

Shoutout to carn for helping me!
54
#54
22 Frags +
CollaideMORE FIXES!
yaay

(Dropbox) Download: https://www.dropbox.com/s/yj0v0608tz8a7gi/cp_prolands_b2b.zip?dl=0

cp_prolands_b2a -> cp_prolands_b2b

BUG FIX:
- Fixed being able to leave the map
- Fixed two spots where you were able to stand on rooves
- Fixed a spot where you could stand in the middle of nothing
- Fixed a couple of graphical errors
- Hopefully fixed the HUD issues(?) (The settings were on default in hammer editor but I think my custom HUD might have something to do with it…)

Shoutout to carn for helping me!

Wrong thread?

[quote=Collaide][h]MORE FIXES![/h]
yaay

(Dropbox) Download: https://www.dropbox.com/s/yj0v0608tz8a7gi/cp_prolands_b2b.zip?dl=0

cp_prolands_b2a -> cp_prolands_b2b

[b]BUG FIX:[/b]
- Fixed being able to leave the map
- Fixed two spots where you were able to stand on rooves
- Fixed a spot where you could stand in the middle of nothing
- Fixed a couple of graphical errors
- Hopefully fixed the HUD issues(?) (The settings were on default in hammer editor but I think my custom HUD might have something to do with it…)

Shoutout to carn for helping me![/quote]


Wrong thread?
55
#55
46 Frags +

What the fuck

When did I click on this thread

I am retard

please admins delete

EDIT: DELET THIS

EDIT 2: Dear admins, please delete. Thanks.

EDIT 3: This is not a joke, I would appreciate if you could delete this. Sincerely, Collaide.

EDIT 4: Can you delete this already

What the fuck

When did I click on this thread

I am retard

please admins delete

EDIT: DELET THIS

EDIT 2: Dear admins, please delete. Thanks.

EDIT 3: This is not a joke, I would appreciate if you could delete this. Sincerely, Collaide.

EDIT 4: Can you delete this already
56
#56
3 Frags +
ViglSo I just installed this config and there's a few issues I've encountered so far.

Whenever I join my own local server, I just get stuck in respawn, cannot move and can't shoot, the fire sound just laps and no projectiles or scatters come out.

Also another thing I've noticed is that whenever I try and change my settings or even change a crosshair while in a casual game, when I press ok it disconnects me out of the game? Very strange

Also what is the reasoning on having mat_trilinear 0

host_thread_mode 0 breaks local servers but apparently helps when you're online. You can just make a toggle-bind for it.

[quote=Vigl]So I just installed this config and there's a few issues I've encountered so far.

Whenever I join my own local server, I just get stuck in respawn, cannot move and can't shoot, the fire sound just laps and no projectiles or scatters come out.

Also another thing I've noticed is that whenever I try and change my settings or even change a crosshair while in a casual game, when I press ok it disconnects me out of the game? Very strange

Also what is the reasoning on having mat_trilinear 0[/quote]
host_thread_mode 0 breaks local servers but apparently helps when you're online. You can just make a toggle-bind for it.
57
#57
3 Frags +

4790K, GTX 1070, 1920x1080 DX9

benchmark1.dem:

Default - 121.0 fps, 10.4 fps variability
Mastercom - 144.2 fps, 11.6 fps variability
Personal - 149.9 fps, 12.6 variability
Comanglia - 177.1 fps, 15.8 fps variability

Pub demo I made today:

Default - 150.9 fps, 20.9 fps variability
Personal - 190.3 fps, 24.1 fps variability
Mastercom - 202.6 fps, 29.3 fps variability
Comanglia - 221.0 fps, 30.4 fps variability
4790K, GTX 1070, 1920x1080 DX9

benchmark1.dem:
[code]
Default - 121.0 fps, 10.4 fps variability
Mastercom - 144.2 fps, 11.6 fps variability
Personal - 149.9 fps, 12.6 variability
Comanglia - 177.1 fps, 15.8 fps variability
[/code]

Pub demo I made today:
[code]
Default - 150.9 fps, 20.9 fps variability
Personal - 190.3 fps, 24.1 fps variability
Mastercom - 202.6 fps, 29.3 fps variability
Comanglia - 221.0 fps, 30.4 fps variability
[/code]
58
#58
2 Frags +
z3taim getting a white screen ig pls help

TF2 defaults to mat_dxlevel 81, so changing this to 90 fix's it

[quote=z3ta]im getting a white screen ig pls help[/quote]
TF2 defaults to mat_dxlevel 81, so changing this to 90 fix's it
59
#59
3 Frags +

Ryzen 1600 @ 3.9 Ghz, 970, 1080p, DX9
Rhapsodies Performance Config

2639 frames 20.299 seconds 130.01 fps ( 7.69 ms/f) 11.588 fps variability

Mastercom

2639 frames 19.082 seconds 138.30 fps ( 7.23 ms/f) 12.944 fps variability
Ryzen 1600 @ 3.9 Ghz, 970, 1080p, DX9
Rhapsodies Performance Config
[quote]2639 frames 20.299 seconds 130.01 fps ( 7.69 ms/f) 11.588 fps variability[/quote]
Mastercom
[quote]2639 frames 19.082 seconds 138.30 fps ( 7.23 ms/f) 12.944 fps variability[/quote]
60
#60
2 Frags +

i want configs to magically work really well all of a sudden

i want configs to magically work really well all of a sudden
1 2 3 4 5 ⋅⋅ 56
Please sign in through STEAM to post a comment.