Upvote Upvoted 32 Downvote Downvoted
1 2 3
Lawena v4.0 is out.
posted in Videos
1
#1
19 Frags +

Well, it's been out for a week, but for those who don't know and use Lawena, here you go.

Lawena v4.0

Changelog:

New features:
- Renewed user interface
- Supports custom materials/models/skins/etc as folders or VPKs
- Fixes a missing models TF2 crash on demo playback
- Included PLDX enhanced particles
- Many included resources are now packed into VPKs
- Auto-updates using the launcher
- Linux TF2 support

Lawena now looks different and gives additional options.

http://i.imgur.com/JGfZ1fn.png

*** NOTE *** In this image where it says "omphud [hud]", it will more than likely instead say whatever you name the folder inside of your custom folder. With this you can easily use your own HUD.[/b]

You can also change your TF2 and Movie folder that you direct Lawena to by clicking File and selecting Change TF2 Folder and/or Change Movie Folder. No longer requires you to delete your lwrt.dir (or whatever it was) file.

Well, it's been out for a week, but for those who don't know and use Lawena, here you go.

[url=https://code.google.com/p/lawenarecordingtool/downloads/detail?name=lawena-recording-tool.v4.zip&can=2&q=]Lawena v4.0[/url]

Changelog:

[quote]New features:
- Renewed user interface
- Supports custom materials/models/skins/etc as folders or VPKs
- Fixes a missing models TF2 crash on demo playback
- Included PLDX enhanced particles
- Many included resources are now packed into VPKs
- Auto-updates using the launcher
- Linux TF2 support[/quote]

Lawena now looks different and gives additional options.

[img]http://i.imgur.com/JGfZ1fn.png[/img]

[b]*** NOTE ***[/b] In this image where it says "omphud [hud]", it will more than likely instead say whatever you name the folder inside of your custom folder. With this you can easily use your own HUD.[/b]

You can also change your TF2 and Movie folder that you direct Lawena to by clicking [b][i]File[/i][/b] and selecting [b][i]Change TF2 Folder[/i][/b] and/or [b][i]Change Movie Folder[/i][/b]. No longer requires you to delete your lwrt.dir (or whatever it was) file.
2
#2
5 Frags +

Please not fragmovies with ugly particles again :(

Please not fragmovies with ugly particles again :(
3
#3
2 Frags +

I will get to seeing what this does specifically soon.

I will get to seeing what this does specifically soon.
4
#4
4 Frags +

Holy shit that's awesome. Now I don't have to rename all my hud folders when I want kill feed/fullhud.

Holy shit that's awesome. Now I don't have to rename all my hud folders when I want kill feed/fullhud.
5
#5
0 Frags +

yes
i hope this fixes lots of he problems!

yes
i hope this fixes lots of he problems!
6
#6
0 Frags +

Crashes every time I load a demo :c Back to v.30

Crashes every time I load a demo :c Back to v.30
7
#7
0 Frags +

are older demos still broken?

are older demos still broken?
8
#8
0 Frags +

whats the prec/dingaling?

whats the prec/dingaling?
9
#9
1 Frags +
Bubbawhats the prec/dingaling?

they're folders in your custom directory

[quote=Bubba]whats the prec/dingaling?[/quote]

they're folders in your custom directory
10
#10
7 Frags +

after launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.

after launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.
11
#11
-3 Frags +

fixed

fixed
12
#12
0 Frags +
Protatoafter launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.

Never happened to me, and anyway the folder should still be somewhere in the tf2 directory, just under a different name, all lawena does is copying everything to a different place and renaming it

Besides, you should know to backup all your data when using this kind of software.

This guy quantic has been doing an amazing job with lawena, the improvements and features He added are awesome. The auto updater is the icing on the cake, seriously I see a whole new future for tf2 moviemaking

[quote=Protato]after launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.[/quote]
Never happened to me, and anyway the folder should still be somewhere in the tf2 directory, just under a different name, all lawena does is copying everything to a different place and renaming it

Besides, you should know to backup all your data when using this kind of software.

This guy quantic has been doing an amazing job with lawena, the improvements and features He added are awesome. The auto updater is the icing on the cake, seriously I see a whole new future for tf2 moviemaking
13
#13
3 Frags +
Protatoafter launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.

At least in the past this would happen if lawena crashed.

Lawena like does a temp swap of the custom files you use to make the game look vanilla and pretty then swaps them back when your done. Usually to fix that you just need to launch tf2 using lawena again and close it properly.

[quote=Protato]after launching lawena once, i lost everything in my custom folder (replaced by lawena stuff)
cool.[/quote]

At least in the past this would happen if lawena crashed.

Lawena like does a temp swap of the custom files you use to make the game look vanilla and pretty then swaps them back when your done. Usually to fix that you just need to launch tf2 using lawena again and close it properly.
14
#14
1 Frags +

So I had this bug with the vdm files feature and quantic walked me through the fix, it was some issue with the updater, so I redownloaded a .jar file and everything was alright.

Then I have had this strange bug with the hitsounds and chat not disabling properly for ages in any recording tool, I have tried almie's, demobuddy, old lawena, everything, and it never work. Turns out class specific configs are run on demo's as well and somehow my custom class configs were overriding the lawena settings even though they weren't even on the custom folder (I dont even have an idea how that could happen). This guy, quantic, helped me solve this 2 issues, even though the 2nd one was my own fault, he still helped me. After like 4-5 months trying to solve it finally I did it with his help.

This tool is in very good hands now, and I have nothing but respect for him for helping me and taking (a lot) of his time to do it! <3

So I had this bug with the vdm files feature and quantic walked me through the fix, it was some issue with the updater, so I redownloaded a .jar file and everything was alright.

Then I have had this strange bug with the hitsounds and chat not disabling properly for ages in any recording tool, I have tried almie's, demobuddy, old lawena, everything, and it never work. Turns out class specific configs are run on demo's as well and somehow my custom class configs were overriding the lawena settings even though they weren't even on the custom folder (I dont even have an idea how that could happen). This guy, quantic, helped me solve this 2 issues, even though the 2nd one was my own fault, he still helped me. After like 4-5 months trying to solve it finally I did it with his help.

This tool is in very good hands now, and I have nothing but respect for him for helping me and taking (a lot) of his time to do it! <3
15
#15
0 Frags +

Sounds like its a bit unstable right now, I will stick with Almie for now.

Sounds like its a bit unstable right now, I will stick with Almie for now.
16
#16
0 Frags +

http://puu.sh/3op9n.png

So yea when i hit drop down menus and move my mouse around shit gets really weird and when i go to screenshot half the area i select goes white, help?

[img]http://puu.sh/3op9n.png[/img]

So yea when i hit drop down menus and move my mouse around shit gets really weird and when i go to screenshot half the area i select goes white, help?
17
#17
4 Frags +
Bubbahow do i install this
I downloaded it > then extracted it > and extracted the .jar file > now i have a 'getdown-client' folder with a bunch of stuff in it, and i am stuck :P

please help

Hi, you just need to extract lawena-recording-tool.v4.zip to a folder, execute lawena.exe and that's it, it will download some files and then show up the interface.

Tell me if you solved it.

alec_So yea when i hit drop down menus and move my mouse around shit gets really weird and when i go to screenshot half the area i select goes white, help?

Wow that's a weird looking screenshot, can you please run the tool again and let it update to see if this persists? Otherwise try updating Java. Thanks for reporting it.

[quote=Bubba]how do i install this
I downloaded it > then extracted it > and extracted the .jar file > now i have a 'getdown-client' folder with a bunch of stuff in it, and i am stuck :P

please help[/quote]

Hi, you just need to extract lawena-recording-tool.v4.zip to a folder, execute lawena.exe and that's it, it will download some files and then show up the interface.

Tell me if you solved it.


[quote=alec_]So yea when i hit drop down menus and move my mouse around shit gets really weird and when i go to screenshot half the area i select goes white, help?[/quote]

Wow that's a weird looking screenshot, can you please run the tool again and let it update to see if this persists? Otherwise try updating Java. Thanks for reporting it.
18
#18
0 Frags +

doesn't let me set a custom res, I usually record at 1680x945 :<

doesn't let me set a custom res, I usually record at 1680x945 :<
19
#19
2 Frags +
Toonidoesn't let me set a custom res, I usually record at 1680x945 :<

You can write "1680x945" in the resolution box.

[quote=Tooni]doesn't let me set a custom res, I usually record at 1680x945 :<[/quote]

You can write "1680x945" in the resolution box.
20
#20
0 Frags +
quanticToonidoesn't let me set a custom res, I usually record at 1680x945 :<
You can write "1680x945" in the resolution box.

Oh I didn't realise it was possible to type in there, I thought it was just a dropdown menu, my bad

[quote=quantic][quote=Tooni]doesn't let me set a custom res, I usually record at 1680x945 :<[/quote]

You can write "1680x945" in the resolution box.[/quote]

Oh I didn't realise it was possible to type in there, I thought it was just a dropdown menu, my bad
21
#21
0 Frags +

The game crashes whenever I load cp_ediface demos. Is it just me?

The game crashes whenever I load cp_ediface demos. Is it just me?
22
#22
2 Frags +

Works great for me! Thanks!

Works great for me! Thanks!
23
#23
0 Frags +

Got a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.466] Started lawena Recording Tool 4.0-24-g44ef06e build 20130630145051
[14:46:09.467] TF2 path: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf
[14:46:09.467] Movie path: E:\movie
[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom

Got a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.466] Started lawena Recording Tool 4.0-24-g44ef06e build 20130630145051
[14:46:09.467] TF2 path: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf
[14:46:09.467] Movie path: E:\movie
[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom
24
#24
0 Frags +

tried it last night works fine for me.

tried it last night works fine for me.
25
#25
1 Frags +
Linux TF2 support

cool I've been wanting to try this

[quote]Linux TF2 support[/quote]

cool I've been wanting to try this
26
#26
0 Frags +
deliGot a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom

I'm not sure if the issue you described is related to that error message. That error is showing up because there is no "custom" folder inside your tf directory. Create that folder and retry.

Linecool I've been wanting to try this

Great! I'd appreciate any feedback about it.

[quote=deli]Got a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom[/quote]

I'm not sure if the issue you described is related to that error message. That error is showing up because there is no "custom" folder inside your tf directory. Create that folder and retry.

[quote=Line]cool I've been wanting to try this[/quote]

Great! I'd appreciate any feedback about it.
27
#27
0 Frags +
quanticdeliGot a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom

I'm not sure if the issue you described is related to that error message. That error is showing up because there is no "custom" folder inside your tf directory. Create that folder and retry.
Linecool I've been wanting to try this
Great! I'd appreciate any feedback about it.

Oh right! I forgot to create custom folder after tf reinstall, everything is working well now
Thanks!

[quote=quantic][quote=deli]Got a strange issue,
Lawena cant save my paths to movie and tf folder logs said:

[14:46:09.511] Problem while loading custom paths
Caused by java.nio.file.NoSuchFileException: c:\program files (x86)\steam\SteamApps\common\Team Fortress 2\tf\custom[/quote]

I'm not sure if the issue you described is related to that error message. That error is showing up because there is no "custom" folder inside your tf directory. Create that folder and retry.

[quote=Line]cool I've been wanting to try this[/quote]

Great! I'd appreciate any feedback about it.[/quote]


Oh right! I forgot to create custom folder after tf reinstall, everything is working well now
Thanks!
28
#28
0 Frags +

this works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip

this works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip
29
#29
1 Frags +
Calithis works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip

About that first issue, Is it giving any error message in the logs when it happens? Maybe you can check if the no-sound vpks are being loaded, using the "path" command in the TF2 console. (they should be at tf/custom/no_announcer_voices.vpk and no_domination_sounds.vpk)

Edit: I've had this sound issue happen to me as well, but only with older demos (March-April 2013). Is that your case too?

[quote=Cali]this works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip[/quote]

About that first issue, Is it giving any error message in the logs when it happens? Maybe you can check if the no-sound vpks are being loaded, using the "path" command in the TF2 console. (they should be at tf/custom/no_announcer_voices.vpk and no_domination_sounds.vpk)

Edit: I've had this sound issue happen to me as well, but only with older demos (March-April 2013). Is that your case too?
30
#30
0 Frags +

Ya

quanticCalithis works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip

About that first issue, Is it giving any error message in the logs when it happens? Maybe you can check if the no-sound vpks are being loaded, using the "path" command in the TF2 console. (they should be at tf/custom/no_announcer_voices.vpk and no_domination_sounds.vpk)

Edit: I've had this sound issue happen to me as well, but only with older demos (March-April 2013). Is that your case too?

I don't remember seeing any errors but they were older demos that seem to be having this problem, thanks for the info.

Ya [quote=quantic][quote=Cali]this works good for me but few things I noticed maybe they are unique to my setup.

-Seems like the disable announcer and domination sounds doesn't always work
-Disable steam community never seems to do anything I have to go offline so it doesn't mess up a clip[/quote]

About that first issue, Is it giving any error message in the logs when it happens? Maybe you can check if the no-sound vpks are being loaded, using the "path" command in the TF2 console. (they should be at tf/custom/no_announcer_voices.vpk and no_domination_sounds.vpk)

Edit: I've had this sound issue happen to me as well, but only with older demos (March-April 2013). Is that your case too?[/quote]


I don't remember seeing any errors but they were older demos that seem to be having this problem, thanks for the info.
1 2 3
Please sign in through STEAM to post a comment.