Upvote Upvoted 3 Downvote Downvoted
Keep alt-tabbing out of the game randomly
posted in Q/A Help
1
#1
0 Frags +

So yesterday, i was playing a bit of mge with some of my team and the game was acting normal, but i was getting alt-tabbed out of the game at seemingly completely random times. I could go for up to 10 minutes without having it happen, or have it happen twice in the span of 5 seconds, so i haven't noticed any kind of pattern in that sense.

Also noting that i had played both during the morning and later during the evening, and the problem started during the evening, with seemingly no reason since i don't recall having done anything to alter the system since, i just took a break and came back and booted up tf2 like always.

I don't recall anything having been updated recently, but it's possible that Windows 10 updated without me realising because i don't check how my computer is doing while i leave it shutting down.

I've since run a few scans with SuperAntiSpyware, Malwarebytes and Avast and nothing outside simple adtracking cookies was found and deleted. It persists.

I've tried giving hl2.exe a higher priority on the task manager but again no to avail.

It's absurdly infuriating and i don't know what to do anymore. Ask whatever info about the system you may need, i'll try to answer as best i can.

EDIT: Realized i could add a few more observations i've gathered since the problem started.

- Only happens in TF2. Was playing DBFighterZ right after for a solid half hour and there was no such problem.
- There doesn't need to be user input. It happened when spectating or dead, when my hands were completely away from both keyboard and mouse.
- It tabs out to whatever is open. If there's nothing it goes to the desktop, so there's seemingly no connection with anything open.
- I don't see any CMD prompt when tabbed out.

EDIT 2: This worked for me! I played for around half an hour with no issues

WafuI had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.
So yesterday, i was playing a bit of mge with some of my team and the game was acting normal, but i was getting alt-tabbed out of the game at seemingly completely random times. I could go for up to 10 minutes without having it happen, or have it happen twice in the span of 5 seconds, so i haven't noticed any kind of pattern in that sense.

Also noting that i had played both during the morning and later during the evening, and the problem started during the evening, with seemingly no reason since i don't recall having done anything to alter the system since, i just took a break and came back and booted up tf2 like always.

I don't recall anything having been updated recently, but it's possible that Windows 10 updated without me realising because i don't check how my computer is doing while i leave it shutting down.

I've since run a few scans with SuperAntiSpyware, Malwarebytes and Avast and nothing outside simple adtracking cookies was found and deleted. It persists.

I've tried giving hl2.exe a higher priority on the task manager but again no to avail.

It's absurdly infuriating and i don't know what to do anymore. Ask whatever info about the system you may need, i'll try to answer as best i can.

EDIT: Realized i could add a few more observations i've gathered since the problem started.

- Only happens in TF2. Was playing DBFighterZ right after for a solid half hour and there was no such problem.
- There doesn't need to be user input. It happened when spectating or dead, when my hands were completely away from both keyboard and mouse.
- It tabs out to whatever is open. If there's nothing it goes to the desktop, so there's seemingly no connection with anything open.
- I don't see any CMD prompt when tabbed out.

EDIT 2: This worked for me! I played for around half an hour with no issues

[quote=Wafu]I had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.[/quote]
2
#2
1 Frags +

Do you have a second monitor? You could be flicking and then click onto the second monitor. Try fullscreen, there is also a program that keeps your mouse locked to a window but I can't remember what its called

Do you have a second monitor? You could be flicking and then click onto the second monitor. Try fullscreen, there is also a program that keeps your mouse locked to a window but I can't remember what its called
3
#3
0 Frags +

I was originally in fullscreen when it happened and i've tried switching to borderless windowed with no results.

I have a single monitor.

Thanks for your help though

I was originally in fullscreen when it happened and i've tried switching to borderless windowed with no results.

I have a single monitor.

Thanks for your help though
4
#4
0 Frags +

This may lead to nothing but lower your desktop mouse sens to a really really low level and see if it works. Not your mouse DPI but https://m.wikihow.com/Change-Mouse-Settings-in-Windows-8. I know this sounds retarded but try it.

This may lead to nothing but lower your desktop mouse sens to a really really low level and see if it works. Not your mouse DPI but https://m.wikihow.com/Change-Mouse-Settings-in-Windows-8. I know this sounds retarded but try it.
5
#5
4 Frags +

it started happening to me aswell just today, there seems to be no reason for that aswell. It started when I switched to flamehud and resolution of 1600x900 if that helps somehow

it started happening to me aswell just today, there seems to be no reason for that aswell. It started when I switched to flamehud and resolution of 1600x900 if that helps somehow
6
#6
0 Frags +

#4 It didn't work, but thanks for trying. Although i'd like to know what's the reasoning for that method.

#5 That's curious. I'll try deleting my hud, although i haven't changed it recently. I'll edit this further.

EDIT: Going back to default HUD didn't work either.

#4 It didn't work, but thanks for trying. Although i'd like to know what's the reasoning for that method.

#5 That's curious. I'll try deleting my hud, although i haven't changed it recently. I'll edit this further.

EDIT: Going back to default HUD didn't work either.
7
#7
1 Frags +

I'm getting this same problem today, i do have a high dpi (2000) but i don't think that's the problem, it seems to happen when my game hitches, which is also a new problem that I've started experiencing today, i'd be very interested in seeing if anyone can find a fix for this
EDIT: i also haven't changed any of my settings like maros so it may not be related to resolution, but idk

I'm getting this same problem today, i do have a high dpi (2000) but i don't think that's the problem, it seems to happen when my game hitches, which is also a new problem that I've started experiencing today, i'd be very interested in seeing if anyone can find a fix for this
EDIT: i also haven't changed any of my settings like maros so it may not be related to resolution, but idk
8
#8
1 Frags +

same issue here pls help

same issue here pls help
9
#9
8 Frags +

I had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.

I had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.
10
#10
1 Frags +

Turning off the do-not-disturb mode in my antivirus fixed the issue. Thanks!

Turning off the do-not-disturb mode in my antivirus fixed the issue. Thanks!
11
#11
1 Frags +

#9 I'll try it out tomorrow, but i'm hopeful from what #10 said!

Of course, i'll edit the main post once i can see 100% it works :)

#9 I'll try it out tomorrow, but i'm hopeful from what #10 said!

Of course, i'll edit the main post once i can see 100% it works :)
12
#12
2 Frags +

BUMP.

WafuI had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.

This worked for me! I hope it works for everyone else with the same problem aswell

BUMP.

[quote=Wafu]I had this issue a few days ago and mine was linked to Avast. I went into settings and in the components tab there was a do not disturb mode which was active, I uninstalled that and the issue went. Hope this helps someone.[/quote]

This worked for me! I hope it works for everyone else with the same problem aswell
13
#13
2 Frags +

Yeah Avast caused it in my case as well, cheers Wafu as I had to go through ridiculous 'solutions' for 3 hours suggested on the internet with no luck.

Yeah Avast caused it in my case as well, cheers Wafu as I had to go through ridiculous 'solutions' for 3 hours suggested on the internet with no luck.
Please sign in through STEAM to post a comment.