Upvote Upvoted 220 Downvote Downvoted
1 ⋅⋅ 17 18 19 20 21 22 23 ⋅⋅ 34
yahud
posted in Customization
571
#571
0 Frags +

http://i.imgur.com/phhavwY.png

what is the pink thing in the corner and how do i remove it? it doesn't appear in any other corners. i'm using CMYK on 1280x720 with the closed captioning optional folder dragged in and no other edits yet

edit: it's the team color, but is that an intentional indicator or a stray element?

[img]http://i.imgur.com/phhavwY.png[/img]

what is the pink thing in the corner and how do i remove it? it doesn't appear in any other corners. i'm using CMYK on 1280x720 with the closed captioning optional folder dragged in and no other edits yet

edit: it's the team color, but is that an intentional indicator or a stray element?
572
#572
4 Frags +

I had the pleasure to talk to trog a bit. His 3D thingy is part of the HUD now.

The 3D class icon is implemented & 2D works properly again. The triangle should work better at all resolutions now also.

The team indicator will be a stripe for 3D and the old triangle for 2D.

Here's the updated disguise panel:

http://i.imgur.com/XOBIe24.jpg

I had the pleasure to talk to trog a bit. His 3D thingy is part of the HUD now.

The 3D class icon is implemented & 2D works properly again. The triangle should work better at all resolutions now also.

The team indicator will be a stripe for 3D and the old triangle for 2D.

Here's the updated disguise panel:
[img]http://i.imgur.com/XOBIe24.jpg[/img]
573
#573
0 Frags +

Really liking the hud,

Quick question though, I was wanting to try adding a semi transparent background to the health and ammo counts(similar to when the health is low and the red background appears), but I have no idea how to do it. I've tried messing around with the HudPlayerHealth.res file but to no avail...

Some help would be greatly appreciated!

Really liking the hud,

Quick question though, I was wanting to try adding a semi transparent background to the health and ammo counts(similar to when the health is low and the red background appears), but I have no idea how to do it. I've tried messing around with the HudPlayerHealth.res file but to no avail...

Some help would be greatly appreciated!
574
#574
0 Frags +
Meat_JesusReally liking the hud,

Quick question though, I was wanting to try adding a semi transparent background to the health and ammo counts(similar to when the health is low and the red background appears), but I have no idea how to do it. I've tried messing around with the HudPlayerHealth.res file but to no avail...

Some help would be greatly appreciated!

This is an explanation assuming that you know how to edit a HUD, for general stuff refer to guide like doodles'. http://doodlesstuff.com/?tutorial=tf2hud

At the beginning of the HP and Ammo files there's a BG entry. Change "blank" to the color you want. Then navigate to /scripts/hudanimations and change the blank entries for that BG (search for "AmmoBG" and "HealthBG") to that color also.

[quote=Meat_Jesus]Really liking the hud,

Quick question though, I was wanting to try adding a semi transparent background to the health and ammo counts(similar to when the health is low and the red background appears), but I have no idea how to do it. I've tried messing around with the HudPlayerHealth.res file but to no avail...

Some help would be greatly appreciated![/quote]


This is an explanation assuming that you know how to edit a HUD, for general stuff refer to guide like doodles'. http://doodlesstuff.com/?tutorial=tf2hud

At the beginning of the HP and Ammo files there's a BG entry. Change "blank" to the color you want. Then navigate to /scripts/hudanimations and change the blank entries for that BG (search for "AmmoBG" and "HealthBG") to that color also.
575
#575
0 Frags +
whayayThen navigate to /scripts/hudanimations and change the blank entries for that BG (search for "AmmoBG" and "HealthBG") to that color also.

This was why it wasn't working, hadn't updated them here, thanks!

[quote=whayay]
Then navigate to /scripts/hudanimations and change the blank entries for that BG (search for "AmmoBG" and "HealthBG") to that color also.[/quote]

This was why it wasn't working, hadn't updated them here, thanks!
576
#576
1 Frags +

Another small issue I've found:

http://i.imgur.com/nNqkc4s.jpg

The classes only appear when I hover over them.

Another small issue I've found:

[img]http://i.imgur.com/nNqkc4s.jpg[/img]

The classes only appear when I hover over them.
577
#577
0 Frags +
trogThe stripe uses the files bg_blue and bg_red in materials/vgui/replay/thumbnail. Make sure the vtfs and vmts for both are there, and if not download them again. Not sure what else would cause that.

I didn't test it with unusuals because I don't have any. Could you post some screenshots?

http://i.imgur.com/Gdv05Ax.png

http://i.imgur.com/fBzX759.png

[quote=trog]The stripe uses the files bg_blue and bg_red in materials/vgui/replay/thumbnail. Make sure the vtfs and vmts for both are there, and if not download them again. Not sure what else would cause that.

I didn't test it with unusuals because I don't have any. Could you post some screenshots?[/quote]

[IMG]http://i.imgur.com/Gdv05Ax.png[/IMG]

[IMG]http://i.imgur.com/fBzX759.png[/IMG]
578
#578
0 Frags +

For the hat try deleting HudPlayerClass.res and see if it's still messed up. Some hats are bugged and don't display properly, you'll have to wait until Valve fixes it if that's the case.

For the box try this if you're sure the materials are there: http://pastebin.com/raw.php?i=qKPLAJqA

For the hat try deleting HudPlayerClass.res and see if it's still messed up. Some hats are bugged and don't display properly, you'll have to wait until Valve fixes it if that's the case.

For the box try this if you're sure the materials are there: http://pastebin.com/raw.php?i=qKPLAJqA
579
#579
0 Frags +
Meat_JesusAnother small issue I've found:

(img)

The classes only appear when I hover over them.

fixed

[quote=Meat_Jesus]Another small issue I've found:

(img)

The classes only appear when I hover over them.[/quote]

fixed
580
#580
0 Frags +
trogFor the hat try deleting HudPlayerClass.res and see if it's still messed up. Some hats are bugged and don't display properly, you'll have to wait until Valve fixes it if that's the case.

For the box try this if you're sure the materials are there: http://pastebin.com/raw.php?i=qKPLAJqA

For some reason I don't have the materials anywhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download. And I'm on Mac so I can't use GCFScape to grab the materials from the vpk.

[quote=trog]For the hat try deleting HudPlayerClass.res and see if it's still messed up. Some hats are bugged and don't display properly, you'll have to wait until Valve fixes it if that's the case.

For the box try this if you're sure the materials are there: http://pastebin.com/raw.php?i=qKPLAJqA[/quote]

For some reason I don't have the materials anywhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download. And I'm on Mac so I can't use GCFScape to grab the materials from the vpk.
581
#581
0 Frags +
SevinFor some reason I have the materials nowhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download.

It's a custom texture from the hud. Done with broesel's method.

[quote=Sevin]For some reason I have the materials nowhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download.[/quote]

It's a custom texture from the hud. Done with broesel's method.
582
#582
0 Frags +

You were right trog, the hat is indeed bugged. Repasting that stuff from pastebin did nothing to fix the box however.

whayaySevinFor some reason I have the materials nowhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download.
It's a custom texture from the hud. Done with broesel's method.

I don't have the latest version of ya_hud because I began building off one of your earlier versions some time ago. Is this texture one you added with one of the recent patches?

EDIT: I checked your materials folder and added the necessary materials so it's fixed now. Now if Valve will just fix particle effects...

EDIT 2: Now I can't get the class model to widen out. It clips on itself like it isn't wide enough, but when I adjust the wide value of what I think the appropriate value is, "classmodelpanel", it just makes the model bigger:

http://i.imgur.com/M2EdTut.png

You were right trog, the hat is indeed bugged. Repasting that stuff from pastebin did nothing to fix the box however.

[quote=whayay][quote=Sevin]For some reason I have the materials nowhere. I've checked my materials folder outside of the custom folder, it does not contain it. I have no materials folder inside my custom folder so I don't know why it didn't download.[/quote]

It's a custom texture from the hud. Done with broesel's method.[/quote]

I don't have the latest version of ya_hud because I began building off one of your earlier versions some time ago. Is this texture one you added with one of the recent patches?

EDIT: I checked your materials folder and added the necessary materials so it's fixed now. Now if Valve will just fix particle effects...

EDIT 2: Now I can't get the class model to widen out. It clips on itself like it isn't wide enough, but when I adjust the wide value of what I think the appropriate value is, "classmodelpanel", it just makes the model bigger:

[IMG]http://i.imgur.com/M2EdTut.png[/IMG]
583
#583
0 Frags +

how do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean

http://i.imgur.com/rw66BKW.jpg

how do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean

http://i.imgur.com/rw66BKW.jpg
584
#584
0 Frags +

http://cloud-2.steampowered.com/ugc/921272559301235578/DFEE3F6644609A7E60AA5280F9FC25CFB573F7D7/

http://cloud-3.steampowered.com/ugc/921272559301237284/8BBDE37D419BE0FF256B01BBA72017A7D3A450E5/

http://cloud-2.steampowered.com/ugc/921272559301237948/40F2071071FC4B45555966F5BD63010A0621B7C6/

Certain letters have clipping issues for me (4:3 640 x 480)

http://cloud-2.steampowered.com/ugc/921272559301235578/DFEE3F6644609A7E60AA5280F9FC25CFB573F7D7/

http://cloud-3.steampowered.com/ugc/921272559301237284/8BBDE37D419BE0FF256B01BBA72017A7D3A450E5/

http://cloud-2.steampowered.com/ugc/921272559301237948/40F2071071FC4B45555966F5BD63010A0621B7C6/

Certain letters have clipping issues for me (4:3 640 x 480)
585
#585
1 Frags +
rangahow do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean

http://i.imgur.com/rw66BKW.jpg

Go into advanced options and uncheck hud class icons.

[quote=ranga]how do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean

http://i.imgur.com/rw66BKW.jpg[/quote]

Go into advanced options and uncheck hud class icons.
586
#586
1 Frags +

Also, would it be possible to position the default scoreboard on the top or in the middle instead of the bottom?

Also, would it be possible to position the default scoreboard on the top or in the middle instead of the bottom?
587
#587
0 Frags +
rangahow do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean

It's gone by default in 2D now. Uploaded the fix.

FogCertain letters have clipping issues for me (4:3 640 x 480)

Also, would it be possible to position the default scoreboard on the top or in the middle instead of the bottom?

Don't think I'll be able to fix all of the cutoffs at certain resolutions, sorry. Looks like TF2 just randomly doesn't display them properly.

Scoreboard will stay at the bottom by default so that the design works across version (centered wouldnt work with FLV). The right side one is a decent alternative I think.

You could also edit the ypos values in for the scoreboard file, adding something like 200 to all the "r>yposvalue<" and taking away the same vaue from all regular ">yposvalue<" entries.

[quote=ranga]how do i remove the class image on the bottom left?

i'm just using the CMYK one without the 3d advanced shit... just want it nice and clean
[/quote]

It's gone by default in 2D now. Uploaded the fix.



[quote=Fog]Certain letters have clipping issues for me (4:3 640 x 480)

Also, would it be possible to position the default scoreboard on the top or in the middle instead of the bottom?[/quote]

Don't think I'll be able to fix all of the cutoffs at certain resolutions, sorry. Looks like TF2 just randomly doesn't display them properly.

Scoreboard will stay at the bottom by default so that the design works across version (centered wouldnt work with FLV). The right side one is a decent alternative I think.

You could also edit the ypos values in for the scoreboard file, adding something like 200 to all the "r>yposvalue<" and taking away the same vaue from all regular ">yposvalue<" entries.
588
#588
0 Frags +

I am loving the new HUD, but I am trying to get Fog's crosshairs back. I looked up a tutorial and tried to add the new font back in, but it just gives me a number/letter rather than the actual crosshair.


	"fogCrosshair"
	{
	"controlname"	"CExLabel"
	"fieldname"	"fogCrosshair"

	"visible"	"1"			//1
	"enabled"	"1"

	"xpos"		"c-14"
	"ypos"		"c-11"
	"zpos"		"2"

	"wide"		"28"
	"tall"		"28"

	"font"		"fogCrosshair"

	"labeltext"	"9"
	 //Change the "1" to represent the crosshair you want displayed in the Crosshairs.jpg

	 //Remember, each resolution behaves differently, if your crosshair is skewed, not centered,
	 //you will have to play around with the "xpos", "ypos", "wide" and "tall" values.
	 //There are no fixed numbers for this
	"textAlignment"	"center"

	//"fgcolor"	"White"

	// You can insert an RGB code here instead of the "White"

	// R	G	B	Transparency	= color
	// "255 255 255 255"	= White
	// "255 255 0 255 	= Yellow
	// "145 225 25 255"	= Green
	// If you change this, remember to change the same value in HudAnimations_tf.txt
	// Otherwise the crosshair will change back to the default white color after
	// flashing upon giving damage.

	}

	"Crosshair"
		{
        "controlname"	"CExLabel"
		"fieldname"	"Crosshair"
        "textAlignment"	"center"
		"xpos"		"0"
		"ypos"		"0"
		"zpos"		"-2"
		"wide"		"f0"
		"tall"		"480"
        "enabled"	"1"

        "visible"	"1"			     //"1" to enable

		"labeltext"	"9"              //Change this to use a different crosshair
                                     //You can see the list of crosshairs in yacrosshairs.png

        "font"		"fogCrosshair"    //Use "CrosshairOL" for a crosshair with an outline
                                     //or "CrosshairAA" for a smooth crosshair w/o an outline 

                                     //You can add "Small" or "Big" at the end to change the size
                                     //e.g. "CrosshairOLSmall"

        "fgcolor"	"white"      //Color is changed via the clientscheme
                                     //in the "/resource/" folder
	}
  

EDIT: Yes, I do have the font fogCrosshair.tff in my resouce/fonts/ folder.

I am loving the new HUD, but I am trying to get Fog's crosshairs back. I looked up a tutorial and tried to add the new font back in, but it just gives me a number/letter rather than the actual crosshair.

[code]

"fogCrosshair"
{
"controlname" "CExLabel"
"fieldname" "fogCrosshair"

"visible" "1" //1
"enabled" "1"

"xpos" "c-14"
"ypos" "c-11"
"zpos" "2"

"wide" "28"
"tall" "28"

"font" "fogCrosshair"

"labeltext" "9"
//Change the "1" to represent the crosshair you want displayed in the Crosshairs.jpg

//Remember, each resolution behaves differently, if your crosshair is skewed, not centered,
//you will have to play around with the "xpos", "ypos", "wide" and "tall" values.
//There are no fixed numbers for this
"textAlignment" "center"

//"fgcolor" "White"

// You can insert an RGB code here instead of the "White"

// R G B Transparency = color
// "255 255 255 255" = White
// "255 255 0 255 = Yellow
// "145 225 25 255" = Green
// If you change this, remember to change the same value in HudAnimations_tf.txt
// Otherwise the crosshair will change back to the default white color after
// flashing upon giving damage.

}

"Crosshair"
{
"controlname" "CExLabel"
"fieldname" "Crosshair"
"textAlignment" "center"
"xpos" "0"
"ypos" "0"
"zpos" "-2"
"wide" "f0"
"tall" "480"
"enabled" "1"

"visible" "1" //"1" to enable

"labeltext" "9" //Change this to use a different crosshair
//You can see the list of crosshairs in yacrosshairs.png

"font" "fogCrosshair" //Use "CrosshairOL" for a crosshair with an outline
//or "CrosshairAA" for a smooth crosshair w/o an outline

//You can add "Small" or "Big" at the end to change the size
//e.g. "CrosshairOLSmall"

"fgcolor" "white" //Color is changed via the clientscheme
//in the "/resource/" folder
}
[/code]

EDIT: Yes, I do have the font fogCrosshair.tff in my resouce/fonts/ folder.
589
#589
0 Frags +
VoloderI am loving the new HUD, but I am trying to get Fog's crosshairs back. I looked up a tutorial and tried to add the new font back in, but it just gives me a number/letter rather than the actual crosshair.

(code)

EDIT: Yes, I do have the font fogCrosshair.tff in my resouce/fonts/ folder.

I assume you want to use a different version of fog's crosshair.

The font will need to be called "crosshairs", this includes the actual font ID name also, you'll need a program like FontForge to change that.

Alternatively: search for "Crosshairs" in the clientscheme (ignore "crosshair" without the "s") and change it to the font's name. then search for "fog" and change the font name entry to the new name also.

[quote=Voloder]I am loving the new HUD, but I am trying to get Fog's crosshairs back. I looked up a tutorial and tried to add the new font back in, but it just gives me a number/letter rather than the actual crosshair.

(code)

EDIT: Yes, I do have the font fogCrosshair.tff in my resouce/fonts/ folder.[/quote]

I assume you want to use a different version of fog's crosshair.

The font will need to be called "crosshairs", this includes the actual font ID name also, you'll need a program like FontForge to change that.

Alternatively: search for "Crosshairs" in the clientscheme (ignore "crosshair" without the "s") and change it to the font's name. then search for "fog" and change the font name entry to the new name also.
590
#590
0 Frags +
whayayI assume you want to use a different version of fog's crosshair.

No, just the ones that were used in the previous version of yA_HUD.

[quote=whayay]
I assume you want to use a different version of fog's crosshair.
[/quote]
No, just the ones that were used in the previous version of yA_HUD.
591
#591
0 Frags +
VoloderwhayayI assume you want to use a different version of fog's crosshair.No, just the ones that were used in the previous version of yA_HUD.

The font needs to be called "crosshairs", without fog in its name.

The crosshair works fine for me, I just scrolled down to the fog entry and enabled it. You shouldn't have to do anything else.

[quote=Voloder][quote=whayay]
I assume you want to use a different version of fog's crosshair.
[/quote]
No, just the ones that were used in the previous version of yA_HUD.[/quote]

The font needs to be called "crosshairs", without fog in its name.

The crosshair works fine for me, I just scrolled down to the fog entry and enabled it. You shouldn't have to do anything else.
592
#592
1 Frags +

Is it possible to enable the 3d portrait only when disguising as spy?

Is it possible to enable the 3d portrait only when disguising as spy?
593
#593
0 Frags +

I'm having an issue with the class icons being slightly cut off. As well as some strange numbers showing up immediately after the enemy team's name on the scoreboard. Could you tell me what values I'd have to tweak to adjust the icons as well as what to do to remove the numbers on the side of each name?

http://i.imgur.com/9mHkOzN.jpg

I'm having an issue with the class icons being slightly cut off. As well as some strange numbers showing up immediately after the enemy team's name on the scoreboard. Could you tell me what values I'd have to tweak to adjust the icons as well as what to do to remove the numbers on the side of each name?

[img]http://i.imgur.com/9mHkOzN.jpg[/img]
594
#594
0 Frags +
boutrosI'm having an issue with the class icons being slightly cut off. As well as some strange numbers showing up immediately after the enemy team's name on the scoreboard. Could you tell me what values I'd have to tweak to adjust the icons as well as what to do to remove the numbers on the side of each name?

http://i.imgur.com/9mHkOzN.jpg

Try decreasing "avatar_width" at the very top (under "scores") of your scoreboard.res.
Avatars gets messy with lower vertical resolutions sadly :(

[quote=boutros]I'm having an issue with the class icons being slightly cut off. As well as some strange numbers showing up immediately after the enemy team's name on the scoreboard. Could you tell me what values I'd have to tweak to adjust the icons as well as what to do to remove the numbers on the side of each name?

[img]http://i.imgur.com/9mHkOzN.jpg[/img][/quote]

Try decreasing "avatar_width" at the very top (under "scores") of your scoreboard.res.
Avatars gets messy with lower vertical resolutions sadly :(
595
#595
1 Frags +

Sorry if this has been answered before, just trying your hud for the first time and it is really great...

I love FLV version, only not the loading/main menu screen because they are too bright/harsh on the eyes, is there a way to change the main menu and loading menus to the ones of 5MD version?

Sorry if this has been answered before, just trying your hud for the first time and it is really great...

I love FLV version, only not the loading/main menu screen because they are too bright/harsh on the eyes, is there a way to change the main menu and loading menus to the ones of 5MD version?
596
#596
0 Frags +

alright, this may be a previously asked question.
any text is lower than it should be. This includes the hud text and even the little question mark bubble in the loadout slot.
I'm a mac user, what can I do to fix this?

alright, this may be a previously asked question.
any text is lower than it should be. This includes the hud text and even the little question mark bubble in the loadout slot.
I'm a mac user, what can I do to fix this?
597
#597
0 Frags +

I was playing on a Arena server and i wanted to know if there was anyway to add something so i can see how many players are left alive?

I was playing on a Arena server and i wanted to know if there was anyway to add something so i can see how many players are left alive?
598
#598
0 Frags +
MoldexI was playing on a Arena server and i wanted to know if there was anyway to add something so i can see how many players are left alive?

Thanks for the pointer, I fixed the player count and the scoreboard for arena now.

[quote=Moldex]I was playing on a Arena server and i wanted to know if there was anyway to add something so i can see how many players are left alive?[/quote]

Thanks for the pointer, I fixed the player count and the scoreboard for arena now.
599
#599
0 Frags +
KanecoSorry if this has been answered before, just trying your hud for the first time and it is really great...

I love FLV version, only not the loading/main menu screen because they are too bright/harsh on the eyes, is there a way to change the main menu and loading menus to the ones of 5MD version?

You can edit the "Flavor" entry in the clientscheme to make it darker.

jyapperalright, this may be a previously asked question.
any text is lower than it should be. This includes the hud text and even the little question mark bubble in the loadout slot.
I'm a mac user, what can I do to fix this?

It's a mac only issue and I sadly can't offer proper mac support atm. I'm happy that it's at least no longer crashing on startup on mac os x.

[quote=Kaneco]Sorry if this has been answered before, just trying your hud for the first time and it is really great...

I love FLV version, only not the loading/main menu screen because they are too bright/harsh on the eyes, is there a way to change the main menu and loading menus to the ones of 5MD version?[/quote]
You can edit the "Flavor" entry in the clientscheme to make it darker.

[quote=jyapper]alright, this may be a previously asked question.
any text is lower than it should be. This includes the hud text and even the little question mark bubble in the loadout slot.
I'm a mac user, what can I do to fix this?[/quote]
It's a mac only issue and I sadly can't offer proper mac support atm. I'm happy that it's at least no longer crashing on startup on mac os x.
600
#600
3 Frags +

There's a new (semi-unfinished, experimental) Fravid HUD now.

http://i.imgur.com/yJ773gq.jpg

&

http://i.imgur.com/uwVfY7R.jpg

Ammo can be disabled like here, otherwise it will be displayed like the Uber %.

There's a new (semi-unfinished, experimental) Fravid HUD now.

[img]http://i.imgur.com/yJ773gq.jpg[/img]

&

[img]http://i.imgur.com/uwVfY7R.jpg[/img]

Ammo can be disabled like here, otherwise it will be displayed like the Uber %.
1 ⋅⋅ 17 18 19 20 21 22 23 ⋅⋅ 34
Please sign in through STEAM to post a comment.