Upvote Upvoted 84 Downvote Downvoted
1 2 3 4
Source Recording Tool
posted in Customization
31
#31
-2 Frags +
hl2mukkeldrakCan anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help!

[quote=hl2mukkel][quote=drak]Can anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.[/quote]

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.[/quote]

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help!
32
#32
0 Frags +
drakhl2mukkeldrakCan anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help!

Yeah I'm having the same problem. Where are the auto compiled videos going?

[quote=drak][quote=hl2mukkel][quote=drak]Can anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.[/quote]

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.[/quote]

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help![/quote]

Yeah I'm having the same problem. Where are the auto compiled videos going?
33
#33
0 Frags +

Oh nvm, I found them, they go to the recordings.

Oh nvm, I found them, they go to the recordings.
34
#34
1 Frags +

Working on VDM support atm: http://youtu.be/4WEubViEmDw

if anyone has suggestions you can leave them here anytime

Working on VDM support atm: http://youtu.be/4WEubViEmDw

if anyone has suggestions you can leave them here anytime
35
#35
0 Frags +
hl2mukkelWorking on VDM support atm: http://youtu.be/4WEubViEmDw

if anyone has suggestions you can leave them here anytime

Thats awesome! :) Just what I needed.

I think a great feature would be to scan the killstreaks.txt file and automatically detect certain number of things (killstreaks or bookmarks or both) and add it to the vdm list.

I reckon the most complicated thing here would be when to stop recording, but maybe it could be customized by us so that we can really set and forget.

[quote=hl2mukkel]Working on VDM support atm: http://youtu.be/4WEubViEmDw

if anyone has suggestions you can leave them here anytime[/quote]
Thats awesome! :) Just what I needed.

I think a great feature would be to scan the killstreaks.txt file and automatically detect certain number of things (killstreaks or bookmarks or both) and add it to the vdm list.

I reckon the most complicated thing here would be when to stop recording, but maybe it could be customized by us so that we can really set and forget.
36
#36
0 Frags +

after using source recorder tool my prec decided to not work, does anyone else have this problem as well?

after using source recorder tool my prec decided to not work, does anyone else have this problem as well?
37
#37
1 Frags +
drakhl2mukkeldrakCan anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help!

Hey, sorry haven't seen that there's a second page on the thread, silly me
Thank you very much! & Yes, by default it records in the same directory as the tool. I should add a welcome page or something

Zhengodafter using source recorder tool my prec decided to not work, does anyone else have this problem as well?

Hey there, something proberbly went wrong, please check your gamepath and see whether it contains "addons_play" or look up in your backup directory, prec will surely be in there

[quote=drak][quote=hl2mukkel][quote=drak]Can anybody provide any feedback on the mp4 (it says avi?) creation, it'd be really appreciated.

Also: Upon launching TF2 from it, the source recorder crashed, and then my custom files were replaced and unable to be deleted, even with an unlocking tool. If you could, can you make a restore custom files button?

Many thanks for the creation of this.[/quote]

Mp4 (h264 encoding) is a feature by valve added to startmovie, you need QuickTime in order to use it, maybe that's what you're missing.[/quote]

Alrighty, so it provides an error since my tf2 directory isn't in the usual place (C://)
However, if I allow it to play out, it launches, and works wonderfully. You have really created a refined yet robust TF2 moviemaking experience. Thank you.

However, I still have an issue with the video file creation. It goes into what seems frame by frame recording, so that's excellent. However, when the video is stopped, I can't find a file created anywhere? I changed my avi directory, but it appears in neither that one nor the default one.

Thanks for the help![/quote]

Hey, sorry haven't seen that there's a second page on the thread, silly me
Thank you very much! & Yes, by default it records in the same directory as the tool. I should add a welcome page or something

[quote=Zhengod]after using source recorder tool my prec decided to not work, does anyone else have this problem as well?[/quote]

Hey there, something proberbly went wrong, please check your gamepath and see whether it contains "addons_play" or look up in your backup directory, prec will surely be in there
38
#38
1 Frags +

alright fixed it thanks!

alright fixed it thanks!
39
#39
1 Frags +

Thanks for making this great tool! I noticed two minor things.

The movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.

I use "toggle r_drawviewmodel" to turn my viewmodels on/off. If I hit my toggle key in a demo it circumvents the viewmodel locking. I "fixed" that by using "alias toggle "say asdf"" while recording.

It is probably worth mentioning that Sony Vegas 12 apparently cannot import the h264-encoded movie files per default. You need the qt7plug.dll plugin which is put into <installation directory>\Sony\Vegas Pro 12.0\FileIO Plug-Ins\compoundplug. You also have to rename compoundplug.dll to any name according to some tutorial I found on youtube (it worked for me like that). I got qt7plug.dll from http://www.sonycreativesoftware.com/support/files/qt7plug.dll which appears to be an official sony site so I hope it's malwarefree.

Thanks for making this great tool! I noticed two minor things.

The movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.

I use "toggle r_drawviewmodel" to turn my viewmodels on/off. If I hit my toggle key in a demo it circumvents the viewmodel locking. I "fixed" that by using "alias toggle "say asdf"" while recording.

It is probably worth mentioning that Sony Vegas 12 apparently cannot import the h264-encoded movie files per default. You need the qt7plug.dll plugin which is put into <installation directory>\Sony\Vegas Pro 12.0\FileIO Plug-Ins\compoundplug. You also have to rename compoundplug.dll to any name according to some tutorial I found on youtube (it worked for me like that). I got qt7plug.dll from http://www.sonycreativesoftware.com/support/files/qt7plug.dll which appears to be an official sony site so I hope it's malwarefree.
40
#40
0 Frags +
TommiThanks for making this great tool! I noticed two minor things.

The movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.

I use "toggle r_drawviewmodel" to turn my viewmodels on/off. If I hit my toggle key in a demo it circumvents the viewmodel locking. I "fixed" that by using "alias toggle "say asdf"" while recording.

It is probably worth mentioning that Sony Vegas 12 apparently cannot import the h264-encoded movie files per default. You need the qt7plug.dll plugin which is put into <installation directory>\Sony\Vegas Pro 12.0\FileIO Plug-Ins\compoundplug. You also have to rename compoundplug.dll to any name according to some tutorial I found on youtube (it worked for me like that). I got qt7plug.dll from http://www.sonycreativesoftware.com/support/files/qt7plug.dll which appears to be an official sony site so I hope it's malwarefree.

cool thanks, gonna speak to python about the hud, is there a list of official sony vegas plugins?

[quote=Tommi]Thanks for making this great tool! I noticed two minor things.

The movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.

I use "toggle r_drawviewmodel" to turn my viewmodels on/off. If I hit my toggle key in a demo it circumvents the viewmodel locking. I "fixed" that by using "alias toggle "say asdf"" while recording.

It is probably worth mentioning that Sony Vegas 12 apparently cannot import the h264-encoded movie files per default. You need the qt7plug.dll plugin which is put into <installation directory>\Sony\Vegas Pro 12.0\FileIO Plug-Ins\compoundplug. You also have to rename compoundplug.dll to any name according to some tutorial I found on youtube (it worked for me like that). I got qt7plug.dll from http://www.sonycreativesoftware.com/support/files/qt7plug.dll which appears to be an official sony site so I hope it's malwarefree.[/quote]

cool thanks, gonna speak to python about the hud, is there a list of official sony vegas plugins?
41
#41
0 Frags +
hl2mukkelflipperswait does this work with csgo or noYes, just select Counter-Strike: Global Offensive from the game list and it should work otherwise
it'll be fixed in an update

[/quote]

I tried and none of the binds worked. :(

[quote=hl2mukkel][quote=flippers]wait does this work with csgo or no[/quote]
Yes, just select Counter-Strike: Global Offensive from the game list and it should work otherwise
it'll be fixed in an update[/quote]
[/quote]

I tried and none of the binds worked. :(
42
#42
0 Frags +
-Mike-hl2mukkelflipperswait does this work with csgo or noYes, just select Counter-Strike: Global Offensive from the game list and it should work otherwise
it'll be fixed in an update

I tried and none of the binds worked. :([/quote]
Okay, CSGO support is not yet official anyway, it will only record in 30 fps because valve has locked the host_framerate command for it, so unless the plugin is used it won't work and it doesn't copy the plugin yet

[quote=-Mike-][quote=hl2mukkel][quote=flippers]wait does this work with csgo or no[/quote]
Yes, just select Counter-Strike: Global Offensive from the game list and it should work otherwise
it'll be fixed in an update[/quote]
[/quote]

I tried and none of the binds worked. :([/quote]
Okay, CSGO support is not yet official anyway, it will only record in 30 fps because valve has locked the host_framerate command for it, so unless the plugin is used it won't work and it doesn't copy the plugin yet
43
#43
0 Frags +

eagerly waiting for the full CSGO support as well.

Have been trying it on TF2 and its working fine atm

eagerly waiting for the full CSGO support as well.

Have been trying it on TF2 and its working fine atm
44
#44
0 Frags +

As long as it is in 'insecure' mode, hostframerate should be able to be edited, right?

and a bind for the csgo to hide some hud elements is "cl_draw_only_deathnotices 1"

As long as it is in 'insecure' mode, hostframerate should be able to be edited, right?

and a bind for the csgo to hide some hud elements is "cl_draw_only_deathnotices 1"
45
#45
0 Frags +
TommiThe movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.

it has been fixed now, thanks for reporting again! :)

-Mike-As long as it is in 'insecure' mode, hostframerate should be able to be edited, right?

and a bind for the csgo to hide some hud elements is "cl_draw_only_deathnotices 1"

Sadly not & wow such a command really exists in csgo? Amazing!

[quote=Tommi]The movie hud does not remove the timer on payload map. Since it does on koth/5cp I suppose that's not intended.[/quote]

it has been fixed now, thanks for reporting again! :)

[quote=-Mike-]As long as it is in 'insecure' mode, hostframerate should be able to be edited, right?

and a bind for the csgo to hide some hud elements is "cl_draw_only_deathnotices 1"[/quote]

Sadly not & wow such a command really exists in csgo? Amazing!
46
#46
0 Frags +

Crashes for me when I click "Start Game" http://gyazo.com/2cda321a2e98e5828148f5094b213bdd

Really, the only thing I'm interested is the ability to go straight to avi. How does one go about using virtual dub progammatically? Is there an api for virtual dub or something? I know lawena is open source so I might be willing to attempt adding that feature and submitting a pull request. I'd rather stick with lawena as I have that pretty down pat to be honest.

Crashes for me when I click "Start Game" http://gyazo.com/2cda321a2e98e5828148f5094b213bdd

Really, the only thing I'm interested is the ability to go straight to avi. How does one go about using virtual dub progammatically? Is there an api for virtual dub or something? I know lawena is open source so I might be willing to attempt adding that feature and submitting a pull request. I'd rather stick with lawena as I have that pretty down pat to be honest.
47
#47
0 Frags +
AfterglowCrashes for me when I click "Start Game" http://gyazo.com/2cda321a2e98e5828148f5094b213bdd

Really, the only thing I'm interested is the ability to go straight to avi. How does one go about using virtual dub progammatically? Is there an api for virtual dub or something? I know lawena is open source so I might be willing to attempt adding that feature and submitting a pull request. I'd rather stick with lawena as I have that pretty down pat to be honest.

Hi, please add me on steam so we can resolve the issue: http://steamcommunity.com/id/hl2mukkel

[quote=Afterglow]Crashes for me when I click "Start Game" http://gyazo.com/2cda321a2e98e5828148f5094b213bdd

Really, the only thing I'm interested is the ability to go straight to avi. How does one go about using virtual dub progammatically? Is there an api for virtual dub or something? I know lawena is open source so I might be willing to attempt adding that feature and submitting a pull request. I'd rather stick with lawena as I have that pretty down pat to be honest.[/quote]

Hi, please add me on steam so we can resolve the issue: http://steamcommunity.com/id/hl2mukkel
48
#48
0 Frags +

Update: fixed the bug & added experimental csgo support

Update: fixed the bug & added experimental csgo support
49
#49
0 Frags +

Thank you! Only a couple problems so far :(

sv_showimpacts 2 and sv_showimpacts_time 10 were set in the config which aren't great for vids, but a simple 2 line fix of changing values to 0.

And I did a recording at 30 and 60 fps and the audio was really distorted and "boomy". I tried both the f9 and f10 options for recording and the audio was the same either way. I can get an example up in a few minutes.

Edit: only the recorded sounds don't work, but in game sounds are fine.

video: http://youtu.be/1DJdXRoRr0w

Thank you! Only a couple problems so far :(

sv_showimpacts 2 and sv_showimpacts_time 10 were set in the config which aren't great for vids, but a simple 2 line fix of changing values to 0.

And I did a recording at 30 and 60 fps and the audio was really distorted and "boomy". I tried both the f9 and f10 options for recording and the audio was the same either way. I can get an example up in a few minutes.

Edit: only the recorded sounds don't work, but in game sounds are fine.

video: http://youtu.be/1DJdXRoRr0w
50
#50
0 Frags +
-Mike-Thank you! Only a couple problems so far :(

sv_showimpacts 2 and sv_showimpacts_time 10 were set in the config which aren't great for vids, but a simple 2 line fix of changing values to 0.

And I did a recording at 30 and 60 fps and the audio was really distorted and "boomy". I tried both the f9 and f10 options for recording and the audio was the same either way. I can get an example up in a few minutes.

Edit: only the recorded sounds don't work, but in game sounds are fine.

video: http://youtu.be/1DJdXRoRr0w

Thanks, sorry updated it now in the latest version which I'll release soon (it'll have an auto updater so you don't need to redownload it everytime) if you need further assitance you can add me @ id/hl2mukkel

[quote=-Mike-]Thank you! Only a couple problems so far :(

sv_showimpacts 2 and sv_showimpacts_time 10 were set in the config which aren't great for vids, but a simple 2 line fix of changing values to 0.

And I did a recording at 30 and 60 fps and the audio was really distorted and "boomy". I tried both the f9 and f10 options for recording and the audio was the same either way. I can get an example up in a few minutes.

Edit: only the recorded sounds don't work, but in game sounds are fine.

video: http://youtu.be/1DJdXRoRr0w[/quote]

Thanks, sorry updated it now in the latest version which I'll release soon (it'll have an auto updater so you don't need to redownload it everytime) if you need further assitance you can add me @ id/hl2mukkel
51
#51
0 Frags +

Is there any way to change the directory from which it launches TF2 from? I can't seem to find one and I have TF2 installed on a separate SSD.

Is there any way to change the directory from which it launches TF2 from? I can't seem to find one and I have TF2 installed on a separate SSD.
52
#52
0 Frags +

I've my TF2 directory on a seperate SSD partition as well and it works just fine. How did you manage to install it to a different directory? I used NTFS links.

I've my TF2 directory on a seperate SSD partition as well and it works just fine. How did you manage to install it to a different directory? I used NTFS links.
53
#53
0 Frags +

I just installed all Source games onto an SSD, so I have 2 "common" foldiers.

I just installed all Source games onto an SSD, so I have 2 "common" foldiers.
54
#54
0 Frags +
BuschmasterACRIs there any way to change the directory from which it launches TF2 from? I can't seem to find one and I have TF2 installed on a separate SSD.

not yet, that's next on my to-do list, I'll add support for that soon.

[quote=BuschmasterACR]Is there any way to change the directory from which it launches TF2 from? I can't seem to find one and I have TF2 installed on a separate SSD.[/quote]

not yet, that's next on my to-do list, I'll add support for that soon.
55
#55
1 Frags +

Update: working on an auto-updater atm.
Also created a Steam Group:
http://steamcommunity.com/groups/sourcerecordingtool
for issues, bugs, suggestions, beta versions and so forth

Update: working on an auto-updater atm.
Also created a Steam Group:
http://steamcommunity.com/groups/sourcerecordingtool
for issues, bugs, suggestions, beta versions and so forth
56
#56
0 Frags +

oi, now it stops working after starting the program.

oi, now it stops working after starting the program.
57
#57
0 Frags +

hey mike, you might need to install .NET framework 4.5 to make the auto updater working

hey mike, you might need to install .NET framework 4.5 to make the auto updater working
58
#58
0 Frags +

The only thing I've done with it is had it schedule record and its worked great with the tf-movie.cfg however, when I use the tf-play.cfg it crashes when the demo loads. Any help with this? Also what does tf2-viewed-bypass mean?

The only thing I've done with it is had it schedule record and its worked great with the tf-movie.cfg however, when I use the tf-play.cfg it crashes when the demo loads. Any help with this? Also what does tf2-viewed-bypass mean?
59
#59
0 Frags +

The 4.5 .Net worked, but CSGO doesn't seem to want to have correct audio.

The 4.5 .Net worked, but CSGO doesn't seem to want to have correct audio.
60
#60
2 Frags +

When I try to launch TF2 I get "Unable to find executable." How to fix?

When I try to launch TF2 I get "Unable to find executable." How to fix?
1 2 3 4
Please sign in through STEAM to post a comment.