Upvote Upvoted 227 Downvote Downvoted
1 ⋅⋅ 43 44 45 46 47 48 49 ⋅⋅ 55
mastercomfig - fps/customization config
posted in Customization
1351
#1351
1 Frags +

So I just recently got back home from school and started using my good computer. Upon playing tf2 with the medium config installed I average about between 113 fps according to fraps (Same results for medium low). I am aware that tf2 is optimized but I feel as if I should be getting better fps with this computer.
Specs:
GTX 1080
16 GB Ram
i7-6700 @ 3.8 GHz
Any help is appreciated.
Edit: Medium config version 6.7.0 for April 27th is installed.

So I just recently got back home from school and started using my good computer. Upon playing tf2 with the medium config installed I average about between 113 fps according to fraps (Same results for medium low). I am aware that tf2 is optimized but I feel as if I should be getting better fps with this computer.
Specs:
GTX 1080
16 GB Ram
i7-6700 @ 3.8 GHz
Any help is appreciated.
Edit: Medium config version 6.7.0 for April 27th is installed.
1352
#1352
4 Frags +

The medium config isn't in a very good spot right now. I'd recommend the medium-low, medium-high or high presets.

The medium config isn't in a very good spot right now. I'd recommend the medium-low, medium-high or high presets.
1353
#1353
0 Frags +

I tried both with similar results that I would consider margin of error.

I tried both with similar results that I would consider margin of error.
1354
#1354
0 Frags +

Are you sure you tested them under the same conditions? And did you try the medium high config?

Are you sure you tested them under the same conditions? And did you try the medium high config?
1355
#1355
0 Frags +

fixed

fixed
1356
#1356
1 Frags +
mastercomsAre you sure you tested them under the same conditions? And did you try the medium high config?

I used a demo to test the configs and cleaned my tf2 for each cfg install. I am currently using the medium-high cfg and I gives me similar results.

[quote=mastercoms]Are you sure you tested them under the same conditions? And did you try the medium high config?[/quote]
I used a demo to test the configs and cleaned my tf2 for each cfg install. I am currently using the medium-high cfg and I gives me similar results.
1357
#1357
-5 Frags +

.

.
1358
#1358
4 Frags +
Blungohttps://imgur.com/a/zDVvz0n

anyone else got this glitch

using comfig w/ dx81

You already asked this in your own thread and I answered you there: http://www.teamfortress.tv/47516/dxlevel-81-spy-arm-glitch#7

[quote=Blungo]https://imgur.com/a/zDVvz0n

anyone else got this glitch

using comfig w/ dx81[/quote]
You already asked this in your own thread and I answered you there: http://www.teamfortress.tv/47516/dxlevel-81-spy-arm-glitch#7
1359
#1359
-1 Frags +
mastercomsBlungohttps://imgur.com/a/zDVvz0n

anyone else got this glitch

using comfig w/ dx81
You already asked this in your own thread and I answered you there: http://www.teamfortress.tv/47516/dxlevel-81-spy-arm-glitch#7
[quote=mastercoms][quote=Blungo]https://imgur.com/a/zDVvz0n

anyone else got this glitch

using comfig w/ dx81[/quote]
You already asked this in your own thread and I answered you there: http://www.teamfortress.tv/47516/dxlevel-81-spy-arm-glitch#7[/quote]
1360
#1360
0 Frags +
fizzwhizBy the way, my game is looking good and performing well so far with the new Medium Low preset. But won't high texture quality result in increased memory usage?

Turns out that textures_low still gives a higher fps, on my system at least. To those who are using any of the new Medium presets, how is the fps since the new higher default texture quality? I know I can just activate the textures_low preset automatically but since many who use the comp preset are likely not to have "modern hardware", I think it can still be considered an improvement to revert to the old default? Some input from other users would help.

[quote=fizzwhiz]By the way, my game is looking good and performing well so far with the new Medium Low preset. But won't high texture quality result in increased memory usage?[/quote]

Turns out that textures_low still gives a higher fps, on my system at least. To those who are using any of the new Medium presets, how is the fps since the new higher default texture quality? I know I can just activate the textures_low preset automatically but since many who use the comp preset are likely not to have "modern hardware", I think it can still be considered an improvement to revert to the old default? Some input from other users would help.
1361
#1361
0 Frags +
Blungoyou didnt say whether it was my game or dx81
mentionin glitched shaders which are also included in your cfg doesnt help

Shaders are not included in my config. I don't think it's even possible to access or mod Source's built in shaders. It's specifically dx8's shaders.

fizzwhizTurns out that textures_low still gives a higher fps, on my system at least. To those who are using any of the new Medium presets, how is the fps since the new higher default texture quality? I know I can just activate the textures_low preset automatically but since many who use the comp preset are likely not to have "modern hardware", I think it can still be considered an improvement to revert to the old default? Some input from other users would help.

There's a fix for this coming in an upcoming update.

[quote=Blungo]you didnt say whether it was my game or dx81
mentionin glitched shaders which are also included in your cfg doesnt help[/quote]
Shaders are not included in my config. I don't think it's even possible to access or mod Source's built in shaders. It's specifically dx8's shaders.

[quote=fizzwhiz]Turns out that textures_low still gives a higher fps, on my system at least. To those who are using any of the new Medium presets, how is the fps since the new higher default texture quality? I know I can just activate the textures_low preset automatically but since many who use the comp preset are likely not to have "modern hardware", I think it can still be considered an improvement to revert to the old default? Some input from other users would help.[/quote]
There's a fix for this coming in an upcoming update.
1362
#1362
0 Frags +
mastercomsThere's a fix for this coming in an upcoming update.

What kind of a fix will that be?

Edit: wording

[quote=mastercoms]There's a fix for this coming in an upcoming update.[/quote]

What kind of a fix will that be?

Edit: wording
1363
#1363
0 Frags +

OS: Windows 7 Enterprise 64-bit SP1
-TF2 is given permissions with my firewall and anti-virus.
-Using recommended hardware settings in BIOS
Processer: Intel Core i5 @ 3.40GHz
RAM: 7.00GB
Graphics Card: 2047MB NVIDIA GeForce GTX 650 Ti

Upload Speed 1.0 Mbps
Download Speed 3.5 Mbps
Realtek PCIe GBE Family Controller / Driver 7.116.119.2018 (Directly connected to Modem)
Modem: Motorola SBG6580
TF2 Matchmaking server ping 60-80

I used the rate generator to get my optimal rate and splitrate. I would like your advice on the other network settings in your config as I feel they aren't optimized, I suspect because of my internet speeds.

The default settings aren't unplayable, however, other players movement is choppy along with hit-scan registration feeling unnatural with my cross hair position and mouse input. I hit shots I shouldn't, and miss shots I should.

One more request I have that with a 2-monitor set up I really like having the game run in a borderless window. However, you suggested not using (noborder -fullscreen -w -h -full -sw) on your wiki and that I should set these in-game.

The display modes don't give me an option like this. When playing in a windowed game I exit the game because my cursor will cross over to my 2nd monitor.

Do you know of any settings that could give me a smooth alt+tab but without the cursor issue ? (google searches only give me people saying to use the settings that you advise against.)

OS: Windows 7 Enterprise 64-bit SP1
-TF2 is given permissions with my firewall and anti-virus.
-Using recommended hardware settings in BIOS
Processer: Intel Core i5 @ 3.40GHz
RAM: 7.00GB
Graphics Card: 2047MB NVIDIA GeForce GTX 650 Ti

Upload Speed 1.0 Mbps
Download Speed 3.5 Mbps
Realtek PCIe GBE Family Controller / Driver 7.116.119.2018 (Directly connected to Modem)
Modem: Motorola SBG6580
TF2 Matchmaking server ping 60-80

I used the rate generator to get my optimal rate and splitrate. I would like your advice on the other network settings in your config as I feel they aren't optimized, I suspect because of my internet speeds.

The default settings aren't unplayable, however, other players movement is choppy along with hit-scan registration feeling unnatural with my cross hair position and mouse input. I hit shots I shouldn't, and miss shots I should.

One more request I have that with a 2-monitor set up I really like having the game run in a borderless window. However, you suggested not using (noborder -fullscreen -w -h -full -sw) on your wiki and that I should set these in-game.

The display modes don't give me an option like this. When playing in a windowed game I exit the game because my cursor will cross over to my 2nd monitor.

Do you know of any settings that could give me a smooth alt+tab but without the cursor issue ? (google searches only give me people saying to use the settings that you advise against.)
1364
#1364
0 Frags +

Confused by the AA system. I'm using medium high 6.7.0 and want some AA since this preset has none by default -- what console option should I enter to get some AA that won't wreck performance, and should that option go into custom.cfg or could it cause issues there?

Confused by the AA system. I'm using medium high 6.7.0 and want some AA since this preset has none by default -- what console option should I enter to get some AA that won't wreck performance, and should that option go into custom.cfg or could it cause issues there?
1365
#1365
0 Frags +

hi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?

hi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?
1366
#1366
1 Frags +
mattThi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?

You don't need to clean your install once you're using mastercomfig. It's only if you want to reset your TF2 to default or if you go to another config.

[quote=mattT]hi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?[/quote]
You don't need to clean your install once you're using mastercomfig. It's only if you want to reset your TF2 to default or if you go to another config.
1367
#1367
0 Frags +

hey, just wondering, can you enable csaa without msaa?

hey, just wondering, can you enable csaa without msaa?
1368
#1368
0 Frags +
mastercomsmattThi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?You don't need to clean your install once you're using mastercomfig. It's only if you want to reset your TF2 to default or if you go to another config.

gotcha thanks

[quote=mastercoms][quote=mattT]hi sorry this might be a pleb question but to switch from one cfg preset to another do I need to clean up my install again or can I just replace the old one with a new one? like can I just delete the medium preset cfg from my custom folder and put the medium-low in, or do I have to wipe my cloud files and everything again?[/quote]
You don't need to clean your install once you're using mastercomfig. It's only if you want to reset your TF2 to default or if you go to another config.[/quote]

gotcha thanks
1369
#1369
0 Frags +
rmhey, just wondering, can you enable csaa without msaa?

i think so

[quote=rm]hey, just wondering, can you enable csaa without msaa?[/quote]
i think so
1370
#1370
0 Frags +

I was wondering if it was possible to make flames invisible using the -force_vendor_id and -force_device_id launch options. I know people used them to fix invisible flames by using a certain graphic card number. If it sounds like it could work is there somewhere I could look to find the corresponding IDs for certain GPUs and test em?

Also have you had any luck fixing the issue with enabling the wait command on local servers?

mastercomsfizzwhizWhat causes the visibility bugs in the Low and Very Low presets? By the way, why does mat_filtertextures occur twice in each of the following modules?Mostly a high value for r_worldlightmin. It is repeated to workaround a bug where mat_filtertextures does not get set the first time it is used.

So would using the low preset vpk and putting the lighting_medium module alias in custom.cfg be like using the old comp preset?

I was wondering if it was possible to make flames invisible using the -force_vendor_id and -force_device_id launch options. I know people used them to fix invisible flames by using a certain graphic card number. If it sounds like it could work is there somewhere I could look to find the corresponding IDs for certain GPUs and test em?

Also have you had any luck fixing the issue with [url=http://www.teamfortress.tv/42867/mastercomfig-fps-customization-config/?page=41#1206]enabling[/url] the wait command on local servers?

[quote=mastercoms][quote=fizzwhiz]What causes the visibility bugs in the Low and Very Low presets? By the way, why does mat_filtertextures occur twice in each of the following modules?
[/quote]
Mostly a high value for r_worldlightmin. It is repeated to workaround a bug where mat_filtertextures does not get set the first time it is used.[/quote]

So would using the low preset vpk and putting the lighting_medium module alias in custom.cfg be like using the old comp preset?
1371
#1371
0 Frags +
HonsterI was wondering if it was possible to make flames invisible using the -force_vendor_id and -force_device_id launch options. I know people used them to fix invisible flames by using a certain graphic card number. If it sounds like it could work is there somewhere I could look to find the corresponding IDs for certain GPUs and test em?

Also have you had any luck fixing the issue with enabling the wait command on local servers?

try downloading the lighter particles mod and preloading the flames should be invis on casual servers

[quote=Honster]I was wondering if it was possible to make flames invisible using the -force_vendor_id and -force_device_id launch options. I know people used them to fix invisible flames by using a certain graphic card number. If it sounds like it could work is there somewhere I could look to find the corresponding IDs for certain GPUs and test em?

Also have you had any luck fixing the issue with [url=http://www.teamfortress.tv/42867/mastercomfig-fps-customization-config/?page=41#1206]enabling[/url] the wait command on local servers?[/quote]

try downloading the lighter particles mod and preloading the flames should be invis on casual servers
1372
#1372
0 Frags +
HonsterSo would using the low preset vpk and putting the lighting_medium module alias in custom.cfg be like using the old comp preset?

I'd like to know as well. What optimisations are there in the Low preset that are not in the Medium Low preset, other than textures_low and lighting_low?

Edit: grammar

[quote=Honster]So would using the low preset vpk and putting the lighting_medium module alias in custom.cfg be like using the old comp preset?[/quote]

I'd like to know as well. What optimisations are there in the Low preset that are not in the Medium Low preset, other than textures_low and lighting_low?

Edit: grammar
1373
#1373
0 Frags +
donnyraytry downloading the lighter particles mod and preloading the flames should be invis on casual servers

Tried this with preset 3 of the particle limitation pack and it didnt work for me.

[quote=donnyray]
try downloading the lighter particles mod and preloading the flames should be invis on casual servers[/quote]

Tried this with preset 3 of the [url=http://www.teamfortress.tv/22586/particle-limitation-pack]particle limitation pack[/url] and it didnt work for me.
1374
#1374
-1 Frags +

.

.
1375
#1375
0 Frags +

How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.

How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.
1376
#1376
1 Frags +
FirePOW10How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.

Maybe they're set in your custom.cfg? Mastercomfig doesn't change those settings.

[quote=FirePOW10]How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.[/quote]
Maybe they're set in your custom.cfg? Mastercomfig doesn't change those settings.
1377
#1377
0 Frags +
mastercomsFirePOW10How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.
Maybe they're set in your custom.cfg? Mastercomfig doesn't change those settings.

It actually does set hud_medichealtargetmarker to 1

[quote=mastercoms][quote=FirePOW10]How do I disable demos starting every time I play a match?

Also, how do I disable advanced options for medic? It keeps booting with the same settings, even after I change them.[/quote]
Maybe they're set in your custom.cfg? Mastercomfig doesn't change those settings.[/quote]

It actually does set hud_medichealtargetmarker to 1
1378
#1378
0 Frags +

I recently moved to a different PC from my old one which had no issues. For this computer I followed the clean up process, then added in my custom and cfg folders from my old pc. I'm using the medium-low preset but whenever I launch tf2 my advanced video settings have model, shader, and texture detail set to high which I have to change to low every time I launch the game. When trying comanglia's config by putting it all into an autoexec file, I had the same issue with my video settings as though the autoexec doesn't run automatically on its own, for that config I just typed exec autoexec every time I launched the game and it worked then. I have the mastercomfig .VPK files inside /tf /custom and my config files inside /tf /cfg. My autoexec is now empty but I have a custom.cfg. My question is, do you have any ideas with why the .VPK files or my autoexec.cfg (when it had things inside it) are not running on their own?

I recently moved to a different PC from my old one which had no issues. For this computer I followed the clean up process, then added in my custom and cfg folders from my old pc. I'm using the medium-low preset but whenever I launch tf2 my advanced video settings have model, shader, and texture detail set to high which I have to change to low every time I launch the game. When trying comanglia's config by putting it all into an autoexec file, I had the same issue with my video settings as though the autoexec doesn't run automatically on its own, for that config I just typed exec autoexec every time I launched the game and it worked then. I have the mastercomfig .VPK files inside /tf /custom and my config files inside /tf /cfg. My autoexec is now empty but I have a custom.cfg. My question is, do you have any ideas with why the .VPK files or my autoexec.cfg (when it had things inside it) are not running on their own?
1379
#1379
1 Frags +

How do I get my game to look like this? I am using the medium-high preset with mat_phong 0 and r_rimlight 0 in my custom.cfg file. So far, it just looks like the default lighting but in the 3D model in my HUD, it looks like it has mat_phong 0, same thing with the 3D models in the loadout panel.

Also, without using this config, mat_phong 0 worked.

Edit: I fixed it by going though your config and setting the default light settings.

How do I get my game to look like [url=https://youtu.be/ZpDlvLoIHdI?t=1m11s]this[/url]? I am using the medium-high preset with mat_phong 0 and r_rimlight 0 in my custom.cfg file. So far, it just looks like the default lighting but in the 3D model in my HUD, it looks like it has mat_phong 0, same thing with the 3D models in the loadout panel.

Also, without using this config, mat_phong 0 worked.

Edit: I fixed it by going though your config and setting the default light settings.
1380
#1380
0 Frags +

How come fps_max always caps fps at a value somewhere below the specified value for me? E.g. fps_max 240 gives me a cap of ~233, fps_max 300 gives me around 292, etc. I had to override the default mastercom cap of 240 because of this (I play on 240hz monitor)

How come fps_max always caps fps at a value somewhere below the specified value for me? E.g. fps_max 240 gives me a cap of ~233, fps_max 300 gives me around 292, etc. I had to override the default mastercom cap of 240 because of this (I play on 240hz monitor)
1 ⋅⋅ 43 44 45 46 47 48 49 ⋅⋅ 55
Please sign in through STEAM to post a comment.