Upvote Upvoted 289 Downvote Downvoted
1 ⋅⋅ 5 6 7 8 9 10 11 ⋅⋅ 26
Comanglia's Config / FPS Guide
posted in Customization
211
#211
0 Frags +

thanks, it worked!

thanks, it worked!
212
#212
0 Frags +

so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced

so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced
213
#213
0 Frags +
greyfreak19so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced

Technically, you should be using the High Quality PC one.

TF2 is pretty cut and dry on what is a GPU reliant setting and what is a CPU reliant setting meaning increasing settings in one place won't make it switch the performance load from the cpu to the gpu or vice versa.

Also FPS drops suck, but their's A LOT of things that can cause it.

- I've had a PC that could get 120avg FPS in DX9 until somebody was on fire and my fps would drop to 20-30 for reasons I don't understand, and then be perfectly fine no matter what in DX8
- Power settings might not be right
- Thermal throttling
- Weird Maps / 32 person servers.
- Background programs with memory leaks
- Background programs in general

[quote=greyfreak19]so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced[/quote]

Technically, you should be using the High Quality PC one.

TF2 is pretty cut and dry on what is a GPU reliant setting and what is a CPU reliant setting meaning increasing settings in one place won't make it switch the performance load from the cpu to the gpu or vice versa.

Also FPS drops suck, but their's A LOT of things that can cause it.

- I've had a PC that could get 120avg FPS in DX9 until somebody was on fire and my fps would drop to 20-30 for reasons I don't understand, and then be perfectly fine no matter what in DX8
- Power settings might not be right
- Thermal throttling
- Weird Maps / 32 person servers.
- Background programs with memory leaks
- Background programs in general
214
#214
0 Frags +
Comangliagreyfreak19so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced

Technically, you should be using the High Quality PC one.

TF2 is pretty cut and dry on what is a GPU reliant setting and what is a CPU reliant setting meaning increasing settings in one place won't make it switch the performance load from the cpu to the gpu or vice versa.

Also FPS drops suck, but their's A LOT of things that can cause it.

- I've had a PC that could get 120avg FPS in DX9 until somebody was on fire and my fps would drop to 20-30 for reasons I don't understand, and then be perfectly fine no matter what in DX8
- Power settings might not be right
- Thermal throttling
- Weird Maps / 32 person servers.
- Background programs with memory leaks
- Background programs in general

Yeah i have set power options profile to high performance idk about background program with memory leaks haven't checked that and i disabled parking using park control csgo runs fine and i tested those fps on 24 player valve server as for the config thank you now i now which one to use

[quote=Comanglia][quote=greyfreak19]so i tried both your configs still get fps drops like down to 30fps sometimes usually it drops to 40 and i dnt know which config is the best cuz i tried both your configs the unstable and the stable one here are my system specs

CPU: Intel Core I3 3210 3.2GHz
GPU: AMD Radeon R9270
RAM:4 GB 1333 MHz
Windows: Win 7 ultimate 64Bit
Resolution: 1920X1080 with 2XMSAA
Video settings: everything low/off exept texture to high model detail to high and multicore rendering enabled DXlvl 95

tell me first which config i should use secondly scence i know my gpu is stronger then my cpu idk which settings i should choose to get the max fps out of this sytem will upgrade to an i5 later but for now i have to settle with this so which cfg should i use? and any other tweaks/launch options?
Thanks in advanced[/quote]

Technically, you should be using the High Quality PC one.

TF2 is pretty cut and dry on what is a GPU reliant setting and what is a CPU reliant setting meaning increasing settings in one place won't make it switch the performance load from the cpu to the gpu or vice versa.

Also FPS drops suck, but their's A LOT of things that can cause it.

- I've had a PC that could get 120avg FPS in DX9 until somebody was on fire and my fps would drop to 20-30 for reasons I don't understand, and then be perfectly fine no matter what in DX8
- Power settings might not be right
- Thermal throttling
- Weird Maps / 32 person servers.
- Background programs with memory leaks
- Background programs in general[/quote]
Yeah i have set power options profile to high performance idk about background program with memory leaks haven't checked that and i disabled parking using park control csgo runs fine and i tested those fps on 24 player valve server as for the config thank you now i now which one to use
215
#215
0 Frags +

Ok i know it was mentioned somewhere before but whats the command for texture down scaling? is it the mat_viewportscale / mat_viewportupscale commands?

Ok i know it was mentioned somewhere before but whats the command for texture down scaling? is it the mat_viewportscale / mat_viewportupscale commands?
216
#216
1 Frags +
Tino_Ok i know it was mentioned somewhere before but whats the command for texture down scaling? is it the mat_viewportscale / mat_viewportupscale commands?

Those are it, viewportscale default is one anything smaller makes it blurry
edit: that's for resolution downscaling, you could try mat_picmip for textures

[quote=Tino_]Ok i know it was mentioned somewhere before but whats the command for texture down scaling? is it the mat_viewportscale / mat_viewportupscale commands?[/quote]

Those are it, viewportscale default is one anything smaller makes it blurry
edit: that's for resolution downscaling, you could try mat_picmip for textures
217
#217
0 Frags +

yeah it was mat_picmip thanks

yeah it was mat_picmip thanks
218
#218
2 Frags +

Great Config! +1 This'll help a lot with my new 144Hz monitor

I'm okay with many of the graphics being turned down, but I enjoy being able to see bloodmarks on players from hitscan (if the other sniper got me because of his ping I want to know it and be mad about it :P), and I can tolerate having shiny textures (e.g. the gold part of the Killer's Kabuto) appear as they would normally (instead of the splotchy lowres texture). Which settings would I change for these?

Great Config! +1 This'll help a lot with my new 144Hz monitor

I'm okay with many of the graphics being turned down, but I enjoy being able to see bloodmarks on players from hitscan (if the other sniper got me because of his ping I want to know it and be mad about it :P), and I can tolerate having shiny textures (e.g. the gold part of the Killer's Kabuto) appear as they would normally (instead of the splotchy lowres texture). Which settings would I change for these?
219
#219
1 Frags +

Can anyone post the latest few updates of Comanglias original config plz?:)

Can anyone post the latest few updates of Comanglias original config plz?:)
220
#220
1 Frags +
the_tsCan anyone post the latest few updates of Comanglias original config plz?:)

the maxframes one is the original config iirc and it is on v. 1.7a

[quote=the_ts]Can anyone post the latest few updates of Comanglias original config plz?:)[/quote]

the maxframes one is the original config iirc and it is on v. 1.7a
221
#221
1 Frags +
Mubbythe_tsCan anyone post the latest few updates of Comanglias original config plz?:)
the maxframes one is the original config iirc and it is on v. 1.7a

I really want the console commands he added.

[quote=Mubby][quote=the_ts]Can anyone post the latest few updates of Comanglias original config plz?:)[/quote]

the maxframes one is the original config iirc and it is on v. 1.7a[/quote]
I really want the console commands he added.
222
#222
0 Frags +
ESPerWhenever I turn left or right, the water seems to have weird bars that move around:
http://i.imgur.com/fpHVbrq.jpg
http://i.imgur.com/caFtTLY.jpg
http://i.imgur.com/II0qO1M.jpg
Not only the water, but the config also give me weird lighting effect:
http://i.imgur.com/lSESsJ9.jpg
http://i.imgur.com/ass5GEa.jpg
http://i.imgur.com/ez0FVED.jpg
http://i.imgur.com/4FFFmcJ.jpg
The LODs are also lowered:
http://i.imgur.com/fHOMkpi.jpg
I need fix pls ;-;

I'm still having this problem, any help?

[quote=ESPer]Whenever I turn left or right, the water seems to have weird bars that move around:
http://i.imgur.com/fpHVbrq.jpg
http://i.imgur.com/caFtTLY.jpg
http://i.imgur.com/II0qO1M.jpg
Not only the water, but the config also give me weird lighting effect:
http://i.imgur.com/lSESsJ9.jpg
http://i.imgur.com/ass5GEa.jpg
http://i.imgur.com/ez0FVED.jpg
http://i.imgur.com/4FFFmcJ.jpg
The LODs are also lowered:
http://i.imgur.com/fHOMkpi.jpg
I need fix pls ;-;[/quote]
I'm still having this problem, any help?
223
#223
0 Frags +
ESPerESPerWhenever I turn left or right, the water seems to have weird bars that move around:
http://i.imgur.com/fpHVbrq.jpg
http://i.imgur.com/caFtTLY.jpg
http://i.imgur.com/II0qO1M.jpg
Not only the water, but the config also give me weird lighting effect:
http://i.imgur.com/lSESsJ9.jpg
http://i.imgur.com/ass5GEa.jpg
http://i.imgur.com/ez0FVED.jpg
http://i.imgur.com/4FFFmcJ.jpg
The LODs are also lowered:
http://i.imgur.com/fHOMkpi.jpg
I need fix pls ;-;
I'm still having this problem, any help?

I actually am having the same problem and I feel as if it is only for dx9.

[quote=ESPer][quote=ESPer]Whenever I turn left or right, the water seems to have weird bars that move around:
http://i.imgur.com/fpHVbrq.jpg
http://i.imgur.com/caFtTLY.jpg
http://i.imgur.com/II0qO1M.jpg
Not only the water, but the config also give me weird lighting effect:
http://i.imgur.com/lSESsJ9.jpg
http://i.imgur.com/ass5GEa.jpg
http://i.imgur.com/ez0FVED.jpg
http://i.imgur.com/4FFFmcJ.jpg
The LODs are also lowered:
http://i.imgur.com/fHOMkpi.jpg
I need fix pls ;-;[/quote]
I'm still having this problem, any help?[/quote]
I actually am having the same problem and I feel as if it is only for dx9.
224
#224
1 Frags +

As of the halloween im recieving significantly lower fps (almost halved). I find this particularily Strange considering most people are actually reporting that their fps has improved. Any suggestions?

As of the halloween im recieving significantly lower fps (almost halved). I find this particularily Strange considering most people are actually reporting that their fps has improved. Any suggestions?
225
#225
-6 Frags +

k

k
226
#226
1 Frags +

These bug reports are all for "Max FPS for High Quality PCs".

cl_loadondemand_default 

no longer exists on the latest version of TF2 and causes a warning to be printed.

For some reason (I was previous on rhapsody's config) alt-tabbing out of TF2 while in the main menu causes music stuttering. EDIT: It was caused by the snd_mixahead buffer being too small. Better leave it at 100ms so it doesn't stutter while tabbed out.

This one is a minor one, but

mat_disable_d3d9ex

causes a warning on first launch (with an empty config.cfg) that a restart is needed to apply the change.

The "Enable facial features section" has convars set for disabling that aren't present in the enable section such as blink_duration. Here's the default values for this section:

// Enable facial features -- turning them on lowers framerate by 5ish%
r_eyes 1
r_flex 1
r_lod -1
r_rootlod 0
r_teeth 1
r_eyemove 0
r_eyeshift_x 0
r_eyeshift_y 0
r_eyeshift_z 0
r_eyesize 0
blink_duration 0.2 // Not in the convar list?

This is also happening in other sections like shadows (nb_shadow_dist) and gibs (cl_phys_timescale). I take it you expect the user to delete or comment out the entire "disabled" section and not just the ones that are set in the "enabled" section, right?

Maybe you should consider GitHub so people can file bug reports and see what's changed?

These bug reports are all for "Max FPS for High Quality PCs".

[code]cl_loadondemand_default [/code]no longer exists on the latest version of TF2 and causes a warning to be printed.

For some reason (I was previous on rhapsody's config) alt-tabbing out of TF2 while in the main menu causes music stuttering. EDIT: It was caused by the snd_mixahead buffer being too small. Better leave it at 100ms so it doesn't stutter while tabbed out.

This one is a minor one, but [code]mat_disable_d3d9ex[/code] causes a warning on first launch (with an empty config.cfg) that a restart is needed to apply the change.

The "Enable facial features section" has convars set for disabling that aren't present in the enable section such as blink_duration. Here's the default values for this section:
[code]// Enable facial features -- turning them on lowers framerate by 5ish%
r_eyes 1
r_flex 1
r_lod -1
r_rootlod 0
r_teeth 1
r_eyemove 0
r_eyeshift_x 0
r_eyeshift_y 0
r_eyeshift_z 0
r_eyesize 0
blink_duration 0.2 // Not in the convar list?[/code]

This is also happening in other sections like shadows (nb_shadow_dist) and gibs (cl_phys_timescale). I take it you expect the user to delete or comment out the [i]entire[/i] "disabled" section and not just the ones that are set in the "enabled" section, right?

Maybe you should consider GitHub so people can file bug reports and see what's changed?
227
#227
0 Frags +

What happened to the toaster config?

What happened to the toaster config?
228
#228
0 Frags +
athairusThis is also happening in other sections like shadows (nb_shadow_dist) and gibs (cl_phys_timescale).

cl_phys_timescale is a cheat, and nb_shadow_dist is unrelated to visible shadows (all the nb_ convars stand for NextBot, and nb_shadow_dist has to do with physics engine shadows)

[quote=athairus]
This is also happening in other sections like shadows (nb_shadow_dist) and gibs (cl_phys_timescale).[/quote]

cl_phys_timescale is a cheat, and nb_shadow_dist is unrelated to visible shadows (all the nb_ convars stand for NextBot, and nb_shadow_dist has to do with physics engine shadows)
229
#229
0 Frags +

how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?

how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?
230
#230
0 Frags +
RiotxEP1CWhat happened to the toaster config?

_____________________________________________________________________________________________

Comanglialeonwhat happened to the toaster config link?ComangliaI really should take the potato config down, there's alot of people who use it when they probably shouldn't
To many people were downloading it thinking it was the best one for them when it wasn't. I'd imagine less than 0.5% of the ENTIRE TF2 userbase should actually use that config.

I made that config for people who we on old netbooks with on chip GPUs literally people with fullsize laptops that are relatively new or even most desktops from the Windows XP era should be using the mid-quality PC one.
[quote=RiotxEP1C]What happened to the toaster config?[/quote]

[b]_____________________________________________________________________________________________[/b]

[quote=Comanglia][quote=leon]what happened to the toaster config link?[/quote]

[quote=Comanglia]I really should take the potato config down, there's alot of people who use it when they probably shouldn't[/quote]

To many people were downloading it thinking it was the best one for them when it wasn't. I'd imagine less than 0.5% of the ENTIRE TF2 userbase should actually use that config.

I made that config for people who we on old netbooks with on chip GPUs literally people with fullsize laptops that are relatively new or even most desktops from the Windows XP era should be using the mid-quality PC one.[/quote]
231
#231
1 Frags +

that's why i need it... i'm exactly in that situtation atm :\

that's why i need it... i'm exactly in that situtation atm :\
232
#232
2 Frags +
venger47how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?

everything looks solid gold still? You're using DX 8 then.

cirlothat's why i need it... i'm exactly in that situtation atm :\

I'll post a change log between The Stability and Toaster one, so people can make the changes themselves if they REALLY want it.

[quote=venger47]how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?[/quote]

everything looks solid gold still? You're using DX 8 then.

[quote=cirlo]that's why i need it... i'm exactly in that situtation atm :\[/quote]
I'll post a change log between The Stability and Toaster one, so people can make the changes themselves if they REALLY want it.
233
#233
0 Frags +
Comangliavenger47how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?
everything looks solid gold still? You're using DX 8 then.
cirlothat's why i need it... i'm exactly in that situtation atm :\I'll post a change log between The Stability and Toaster one, so people can make the changes themselves if they REALLY want it.

Sounds great

[quote=Comanglia][quote=venger47]how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?[/quote]

everything looks solid gold still? You're using DX 8 then.

[quote=cirlo]that's why i need it... i'm exactly in that situtation atm :\[/quote]
I'll post a change log between The Stability and Toaster one, so people can make the changes themselves if they REALLY want it.[/quote]
Sounds great
234
#234
11 Frags +

Changing Stability config to Toaster config

Change the following commands within the Stability config to these values

mat_filterlightmaps 0
mat_filtertextures 0
mat_specular 0
mat_trilinear 0
mat_viewportscale 0.5 //0.5 to 1 is the acceptable range on this if you do get a fps boost from this but 0.5 is to blurry try 0.75 or 0.9

[b]Changing Stability config to Toaster config[/b]

Change the following commands within the Stability config to these values

mat_filterlightmaps 0
mat_filtertextures 0
mat_specular 0
mat_trilinear 0
mat_viewportscale 0.5 //0.5 to 1 is the acceptable range on this if you do get a fps boost from this but 0.5 is to blurry try 0.75 or 0.9
235
#235
1 Frags +
Comangliavenger47how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?
everything looks solid gold still? You're using DX 8 then.

yep fixed it, but by setting mat_phong to 1 and setting it on dx9 now all my settings are set on HIGH, which makes me wonder if this breaks the config? because im at around 100 fps but when i get into firefights it goes down to like 20.

[quote=Comanglia][quote=venger47]how do i get the authentic look for australiums with this config? i tried mat_phong 1 using dx9 but it still looks like its all covered in gold. any suggestions?[/quote]

everything looks solid gold still? You're using DX 8 then.[/quote]

yep fixed it, but by setting mat_phong to 1 and setting it on dx9 now all my settings are set on HIGH, which makes me wonder if this breaks the config? because im at around 100 fps but when i get into firefights it goes down to like 20.
236
#236
1 Frags +

Game crashing for someone else on sm_doomsday_event ?

Running Max FPS for High Quality PCs on dxlevel 91

Game crashing for someone else on sm_doomsday_event ?

Running Max FPS for High Quality PCs on dxlevel 91
237
#237
1 Frags +
HomerJGame crashing for someone else on sm_doomsday_event ?

Running Max FPS for High Quality PCs on dxlevel 91

mat_picmip -1

[quote=HomerJ]Game crashing for someone else on sm_doomsday_event ?

Running Max FPS for High Quality PCs on dxlevel 91[/quote]
mat_picmip -1
238
#238
2 Frags +

Updated GFX and Stability Configs

added a lot of useless commands, most of which are still default value

both configs now have mat_picmip -1

[b]Updated [/b]GFX and Stability Configs

added a lot of useless commands, most of which are still default value

both configs now have mat_picmip -1
239
#239
0 Frags +

You forgot to change the version number

v1.7a | 17 May 2015 | https://dl.dropboxusercontent.com/u/92187841/gfx.cfg
You forgot to change the version number
[code]v1.7a | 17 May 2015 | https://dl.dropboxusercontent.com/u/92187841/gfx.cfg[/code]
240
#240
1 Frags +

when should i set r_occlusion to 0?

when should i set r_occlusion to 0?
1 ⋅⋅ 5 6 7 8 9 10 11 ⋅⋅ 26
Please sign in through STEAM to post a comment.